]> git.pld-linux.org Git - packages/ghc-alsa-mixer.git/blob - ghc-alsa-mixer.spec
rebuild with ghc 8.10.7
[packages/ghc-alsa-mixer.git] / ghc-alsa-mixer.spec
1 %define         pkgname alsa-mixer
2 Summary:        A Haskell binding to the alsa-mixer graphics library
3 Name:           ghc-%{pkgname}
4 Version:        0.3.0
5 Release:        2
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  f5384dbbef508bd965dd0c4490b893b2
10 URL:            http://hackage.haskell.org/package/alsa-mixer/
11 BuildRequires:  alsa-lib-devel
12 BuildRequires:  ghc >= 6.12.3
13 BuildRequires:  ghc-alsa-core >= 0.5
14 BuildRequires:  ghc-c2hs
15 BuildRequires:  rpmbuild(macros) >= 1.608
16 %requires_eq    ghc
17 Requires:       ghc-alsa-core >= 0.5
18 Requires:       ghc-c2hs
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 # debuginfo is not useful for ghc
22 %define         _enable_debug_packages  0
23
24 %description
25 A Haskell binding to the alsa-mixer graphics library.
26
27 %package doc
28 Summary:        HTML documentation for %{pkgname}
29 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
30 Group:          Documentation
31
32 %description doc
33 HTML documentation for %{pkgname}.
34
35 %description doc -l pl.UTF-8
36 Dokumentacja w formacie HTML dla %{pkgname}.
37
38 %prep
39 %setup -q -n %{pkgname}-%{version}
40
41 %build
42 runhaskell Setup.hs configure -v2 \
43         --prefix=%{_prefix} \
44         --libdir=%{_libdir} \
45         --libexecdir=%{_libexecdir} \
46         --docdir=%{_docdir}/%{name}-%{version}
47
48 runhaskell Setup.hs build
49 runhaskell Setup.hs haddock --executables
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
54
55 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
56
57 # work around automatic haddock docs installation
58 rm -rf %{name}-%{version}-doc
59 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
60 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
61
62 runhaskell Setup.hs register \
63         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post
69 %ghc_pkg_recache
70
71 %postun
72 %ghc_pkg_recache
73
74 %files
75 %defattr(644,root,root,755)
76 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
77 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
78
79 %files doc
80 %defattr(644,root,root,755)
81 %doc %{name}-%{version}-doc/*
This page took 0.11781 seconds and 3 git commands to generate.