]> git.pld-linux.org Git - packages/ghc-alsa-mixer.git/blame - ghc-alsa-mixer.spec
rebuild with ghc 8.10.7
[packages/ghc-alsa-mixer.git] / ghc-alsa-mixer.spec
CommitLineData
bbe74f11
JP
1%define pkgname alsa-mixer
2Summary: A Haskell binding to the alsa-mixer graphics library
3Name: ghc-%{pkgname}
e21df059 4Version: 0.3.0
7899bd9c 5Release: 2
bbe74f11
JP
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
e21df059 9# Source0-md5: f5384dbbef508bd965dd0c4490b893b2
bbe74f11 10URL: http://hackage.haskell.org/package/alsa-mixer/
60785c5d 11BuildRequires: alsa-lib-devel
bbe74f11
JP
12BuildRequires: ghc >= 6.12.3
13BuildRequires: ghc-alsa-core >= 0.5
14BuildRequires: ghc-c2hs
15BuildRequires: rpmbuild(macros) >= 1.608
16%requires_eq ghc
17Requires: ghc-alsa-core >= 0.5
18Requires: ghc-c2hs
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21# debuginfo is not useful for ghc
22%define _enable_debug_packages 0
23
24%description
25A Haskell binding to the alsa-mixer graphics library.
26
27%package doc
28Summary: HTML documentation for %{pkgname}
29Summary(pl.UTF-8): Dokumentacja w formacie HTML dla %{pkgname}
30Group: Documentation
31
32%description doc
33HTML documentation for %{pkgname}.
34
35%description doc -l pl.UTF-8
36Dokumentacja w formacie HTML dla %{pkgname}.
37
38%prep
39%setup -q -n %{pkgname}-%{version}
40
41%build
42runhaskell Setup.hs configure -v2 \
43 --prefix=%{_prefix} \
44 --libdir=%{_libdir} \
45 --libexecdir=%{_libexecdir} \
46 --docdir=%{_docdir}/%{name}-%{version}
47
48runhaskell Setup.hs build
49runhaskell Setup.hs haddock --executables
50
51%install
52rm -rf $RPM_BUILD_ROOT
53install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
54
55runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
56
57# work around automatic haddock docs installation
58rm -rf %{name}-%{version}-doc
59cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
60%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
61
62runhaskell Setup.hs register \
63 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%post
69%ghc_pkg_recache
70
71%postun
72%ghc_pkg_recache
73
74%files
75%defattr(644,root,root,755)
76%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
77%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
78
79%files doc
80%defattr(644,root,root,755)
81%doc %{name}-%{version}-doc/*
This page took 0.044035 seconds and 4 git commands to generate.