]> git.pld-linux.org Git - packages/ggz-server.git/blob - ggz-server.spec
- add missing R for -devel
[packages/ggz-server.git] / ggz-server.spec
1 Summary:        Main GGZ server
2 Summary(pl.UTF-8):      Główny serwer GGZ
3 Name:           ggz-server
4 Version:        0.0.14.1
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications
8 Source0:        http://ftp.belnet.be/packages/ggzgamingzone/ggz/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  254caaf8fe7b4a2bafcb62576abba72c
10 Source1:        %{name}.init
11 Source2:        %{name}.conf
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-db4.patch
14 URL:            http://www.ggzgamingzone.org/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake
17 BuildRequires:  avahi-devel
18 BuildRequires:  db-devel >= 4
19 BuildRequires:  expat-devel >= 1.95
20 BuildRequires:  libggz-devel >= 0.0.14
21 BuildRequires:  libtool
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 Requires(post,preun):   /sbin/chkconfig
24 Requires:       %{name}-libs = %{version}-%{release}
25 Requires:       rc-scripts
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _localstatedir  /var/lib
29
30 %description
31 This package contains the main GGZ server, some administrative
32 utilities and lots of game servers.
33
34 %description -l pl.UTF-8
35 Ta paczka zawiera główny serwer GGZ, kilka narzędzi administracyjnych
36 oraz dużo serwerów gier.
37
38 %package libs
39 Summary:        ggz-server libraries
40 Summary(pl.UTF-8):      Biblioteki ggz-server
41 Group:          Libraries
42
43 %description libs
44 ggz-server libraries.
45
46 %description libs -l pl.UTF-8
47 Biblioteki ggz-server.
48
49 %package devel
50 Summary:        Header files for ggz-server library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ggz-server
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       %{name}-libs = %{version}-%{release}
55 Requires:       libggz-devel >= 0.0.14
56
57 %description devel
58 Header files for ggz-server library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki ggz-server.
62
63 %package static
64 Summary:        Static ggz-server library
65 Summary(pl.UTF-8):      Statyczna biblioteka ggz-server
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static ggz-server library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka ggz-server.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4 -I m4/ggz
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         --with-database=db4 \
87         --with-zeroconf=avahi \
88         --with-reconfiguration=inotify
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,ggzd,logrotate.d},%{_var}/{lib/ggzd,log}}
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ggzd
101 sed -e 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/ggzd/ggzd.conf
102 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
103
104 :> $RPM_BUILD_ROOT%{_var}/log/ggz-server.log
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 /sbin/chkconfig --add ggzd
111 %service ggzd restart
112
113 %preun
114 if [ "$1" = "0" ]; then
115         %service ggzd stop
116         /sbin/chkconfig --del ggzd
117 fi
118
119 %post libs -p /sbin/ldconfig
120 %postun libs -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc AUTHORS ChangeLog NEWS README TODO ggzd/ggzd.conf.example
125 %attr(755,root,root) %{_bindir}/ggzd
126 %attr(755,root,root) %{_bindir}/ggzduedit
127 %dir %{_libdir}/ggzd
128 %attr(755,root,root) %{_libdir}/ggzd/geekgameserver
129 %attr(755,root,root) %{_libdir}/ggzd/ggzd.ccheckers
130 %attr(755,root,root) %{_libdir}/ggzd/ggzd.chess
131 %attr(755,root,root) %{_libdir}/ggzd/ggzd.combat
132 %attr(755,root,root) %{_libdir}/ggzd/ggzd.connectx
133 %attr(755,root,root) %{_libdir}/ggzd/ggzd.dots
134 %attr(755,root,root) %{_libdir}/ggzd/ggzd.escape
135 %attr(755,root,root) %{_libdir}/ggzd/ggzd.ggzcards
136 %attr(755,root,root) %{_libdir}/ggzd/ggzd.ggzcards.ai-random
137 %attr(755,root,root) %{_libdir}/ggzd/ggzd.ggzcards.ai-spades
138 %attr(755,root,root) %{_libdir}/ggzd/ggzd.ggzcards.ai-suaro
139 %attr(755,root,root) %{_libdir}/ggzd/ggzd.hastings
140 %attr(755,root,root) %{_libdir}/ggzd/ggzd.reversi
141 %attr(755,root,root) %{_libdir}/ggzd/ggzd.spades
142 %attr(755,root,root) %{_libdir}/ggzd/ggzd.tictactoe
143 %attr(755,root,root) %{_libdir}/ggzd/keepalivesrv
144 %attr(755,root,root) %{_libdir}/ggzd/krosswater_server
145 %attr(755,root,root) %{_libdir}/ggzd/muehleserv
146 %attr(755,root,root) %{_libdir}/ggzd/tuxmanserv
147 %attr(755,root,root) %{_libdir}/ggzd/widelands_server
148 %dir %{_sysconfdir}/ggzd
149 %dir %{_sysconfdir}/ggzd/games
150 %{_sysconfdir}/ggzd/games/ccheckers.dsc
151 %{_sysconfdir}/ggzd/games/chess.dsc
152 %{_sysconfdir}/ggzd/games/combat.dsc
153 %{_sysconfdir}/ggzd/games/connectx.dsc
154 %{_sysconfdir}/ggzd/games/dots.dsc
155 %{_sysconfdir}/ggzd/games/escape.dsc
156 %{_sysconfdir}/ggzd/games/geekgame.dsc
157 %{_sysconfdir}/ggzd/games/ggzcards-bridge.dsc
158 %{_sysconfdir}/ggzd/games/ggzcards-fortytwo.dsc
159 %{_sysconfdir}/ggzd/games/ggzcards-hearts.dsc
160 %{_sysconfdir}/ggzd/games/ggzcards-lapocha.dsc
161 %{_sysconfdir}/ggzd/games/ggzcards-spades.dsc
162 %{_sysconfdir}/ggzd/games/ggzcards-suaro.dsc
163 %{_sysconfdir}/ggzd/games/ggzcards-sueca.dsc
164 %{_sysconfdir}/ggzd/games/ggzcards-whist.dsc
165 %{_sysconfdir}/ggzd/games/ggzcards.dsc
166 %{_sysconfdir}/ggzd/games/hastings.dsc
167 %{_sysconfdir}/ggzd/games/keepalive.dsc
168 %{_sysconfdir}/ggzd/games/krosswater.dsc
169 %{_sysconfdir}/ggzd/games/muehle.dsc
170 %{_sysconfdir}/ggzd/games/reversi.dsc
171 %{_sysconfdir}/ggzd/games/spades.dsc
172 %{_sysconfdir}/ggzd/games/tictactoe.dsc
173 %{_sysconfdir}/ggzd/games/tuxman.dsc
174 %{_sysconfdir}/ggzd/games/widelands.dsc
175 %dir %{_sysconfdir}/ggzd/rooms
176 %{_sysconfdir}/ggzd/rooms/ccheckers.room
177 %{_sysconfdir}/ggzd/rooms/chess.room
178 %{_sysconfdir}/ggzd/rooms/combat.room
179 %{_sysconfdir}/ggzd/rooms/connectx.room
180 %{_sysconfdir}/ggzd/rooms/dots.room
181 %{_sysconfdir}/ggzd/rooms/entry.room
182 %{_sysconfdir}/ggzd/rooms/escape.room
183 %{_sysconfdir}/ggzd/rooms/geekgame.room
184 %{_sysconfdir}/ggzd/rooms/ggzcards-bridge.room
185 %{_sysconfdir}/ggzd/rooms/ggzcards-fortytwo.room
186 %{_sysconfdir}/ggzd/rooms/ggzcards-hearts.room
187 %{_sysconfdir}/ggzd/rooms/ggzcards-lapocha.room
188 %{_sysconfdir}/ggzd/rooms/ggzcards-spades.room
189 %{_sysconfdir}/ggzd/rooms/ggzcards-suaro.room
190 %{_sysconfdir}/ggzd/rooms/ggzcards-sueca.room
191 %{_sysconfdir}/ggzd/rooms/ggzcards-whist.room
192 %{_sysconfdir}/ggzd/rooms/ggzcards.room
193 %{_sysconfdir}/ggzd/rooms/hastings.room
194 %{_sysconfdir}/ggzd/rooms/keepalive.room
195 %{_sysconfdir}/ggzd/rooms/krosswater.room
196 %{_sysconfdir}/ggzd/rooms/muehle.room
197 %{_sysconfdir}/ggzd/rooms/reversi.room
198 %{_sysconfdir}/ggzd/rooms/spades.room
199 %{_sysconfdir}/ggzd/rooms/tictactoe.room
200 %{_sysconfdir}/ggzd/rooms/tuxman.room
201 %{_sysconfdir}/ggzd/rooms/widelands.room
202 %attr(640,root,games) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ggzd/ggzd.conf
203 %{_sysconfdir}/ggzd/ggzd.motd
204 %attr(754,root,root) /etc/rc.d/init.d/ggzd
205 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/ggz-server
206 %dir %{_datadir}/ggz/ggzd
207 %{_datadir}/ggz/ggzd/ggzcards
208 %{_datadir}/ggz/ggzd/hastings1066
209 %{_datadir}/ggz/ggzd/muehle
210 %{_datadir}/ggz/ggzd/tuxmanserv
211 %{_mandir}/man6/ggzd.6*
212 %{_mandir}/man6/ggzduedit.6*
213 %attr(770,root,games) %{_localstatedir}/ggzd
214 %attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_var}/log/ggz-server.log
215
216 %files libs
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/libggzdmod++.so.*.*.*
219 %attr(755,root,root) %ghost %{_libdir}/libggzdmod++.so.1
220 %attr(755,root,root) %{_libdir}/libggzdmod.so.*.*.*
221 %attr(755,root,root) %ghost %{_libdir}/libggzdmod.so.6
222
223 %files devel
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_libdir}/libggzdmod++.so
226 %attr(755,root,root) %{_libdir}/libggzdmod.so
227 %{_libdir}/libggzdmod++.la
228 %{_libdir}/libggzdmod.la
229 %{_libdir}/libggzdmod++.la
230 %{_libdir}/libggzdmod.la
231 %{_includedir}/ggzdmod++
232 %{_includedir}/ggzdmod.h
233 %{_mandir}/man3/ggzdmod.h.3*
234
235 %files static
236 %defattr(644,root,root,755)
237 %{_libdir}/libggzdmod++.a
238 %{_libdir}/libggzdmod.a
This page took 0.040887 seconds and 4 git commands to generate.