]> git.pld-linux.org Git - packages/gflags.git/blob - gflags.spec
- TODO already fixed
[packages/gflags.git] / gflags.spec
1 Summary:        A commandline flags library that allows for distributed flags
2 Summary(pl.UTF-8):      Biblioteka flag linii poleceń pozwalająca na rozproszone flagi
3 Name:           gflags
4 Version:        2.2.1
5 Release:        2
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/gflags/gflags/releases
9 Source0:        https://github.com/schuhschuh/gflags/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  b98e772b4490c84fc5a87681973f75d1
11 Patch0:         %{name}-pc-nothreads.patch
12 URL:            http://gflags.github.io/gflags/
13 BuildRequires:  cmake >= 2.8.12
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  sed >= 4.0
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 gflags is Google's commandline flags library. It differs from other
20 libraries, such as getopt(), in that flag definitions can be scattered
21 around the source code, and not just listed in one place such as
22 main().
23
24 %description -l pl.UTF-8
25 gflags to biblioteka flag linii poleceń stworzona przez Google. Różni
26 się od innych bibliotek, takich jak getopt(), tym, że definicje flag
27 mogą być rozproszone po kodzie źródłowym, a nie wypisane tylko w
28 jednym miejscu, takim jak main().
29
30 %package devel
31 Summary:        Header files for gflags library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gflags
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       libstdc++-devel
36
37 %description devel
38 Header files for gflags library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki gflags.
42
43 %package static
44 Summary:        Static gflags library
45 Summary(pl.UTF-8):      Statyczna biblioteka gflags
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static gflags library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka gflags.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 install -d build
61 cd build
62 %cmake .. \
63         -DBUILD_STATIC_LIBS=ON
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} -C build install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 # disable completeness check incompatible with split packaging
73 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/gflags/gflags-targets.cmake
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS.txt COPYING.txt ChangeLog.txt README.md
84 %attr(755,root,root) %{_bindir}/gflags_completions.sh
85 %attr(755,root,root) %{_libdir}/libgflags.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libgflags.so.2.2
87 %attr(755,root,root) %{_libdir}/libgflags_nothreads.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libgflags_nothreads.so.2.2
89
90 %files devel
91 %defattr(644,root,root,755)
92 # not present in 2.2.0
93 #%doc doc/{index.html,designstyle.css}
94 %attr(755,root,root) %{_libdir}/libgflags.so
95 %attr(755,root,root) %{_libdir}/libgflags_nothreads.so
96 %{_includedir}/gflags
97 %{_pkgconfigdir}/gflags.pc
98 %{_pkgconfigdir}/gflags_nothreads.pc
99 %{_libdir}/cmake/gflags
100
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libgflags.a
104 %{_libdir}/libgflags_nothreads.a
This page took 0.059772 seconds and 3 git commands to generate.