]> git.pld-linux.org Git - packages/gexiv2.git/blob - gexiv2.spec
- updated to 0.10.3
[packages/gexiv2.git] / gexiv2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        GObject-based wrapper around the Exiv2 library
6 Summary(pl.UTF-8):      Oparte na GObject obudowanie biblioteki Exiv2
7 Name:           gexiv2
8 Version:        0.10.3
9 Release:        1
10 License:        GPL v2
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gexiv2/0.10/%{name}-%{version}.tar.xz
13 # Source0-md5:  f255100a009027d4eaa0f075bb79c655
14 URL:            https://wiki.gnome.org/Projects/gexiv2
15 BuildRequires:  exiv2-devel >= 0.21
16 BuildRequires:  glib2-devel >= 1:2.26.1
17 BuildRequires:  gobject-introspection-devel >= 0.10
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:1.5
20 BuildRequires:  m4
21 BuildRequires:  pkgconfig >= 1:0.26
22 BuildRequires:  python >= 2
23 BuildRequires:  python-pygobject3-devel >= 3
24 BuildRequires:  python3 >= 1:3.2
25 BuildRequires:  python3-pygobject3-devel >= 3
26 BuildRequires:  rpmbuild(macros) >= 1.219
27 Requires:       exiv2-libs >= 0.21
28 Requires:       glib2 >= 1:2.26.1
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 gexiv2 is a GObject-based wrapper around the Exiv2 library. It makes
33 the basic features of Exiv2 available to GNOME applications.
34
35 %description -l pl.UTF-8
36 gexiv2 to oparte na GObject obudowanie biblioteki Exiv2. Udostępnia
37 podstawowe możliwości Exiv2 aplikacjom GNOME.
38
39 %package devel
40 Summary:        Header files for gexiv2 library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gexiv2
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       exiv2-devel >= 0.21
45 Requires:       glib2-devel >= 1:2.26.1
46 Requires:       libstdc++-devel
47
48 %description devel
49 Header files for gexiv2 library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki gexiv2.
53
54 %package static
55 Summary:        Static gexiv2 library
56 Summary(pl.UTF-8):      Statyczna biblioteka gexiv2
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static gexiv2 library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka gexiv2.
65
66 %package -n python-gexiv2
67 Summary:        Python 2 binding for gexiv2 library
68 Summary(pl.UTF-8):      Wiązanie Pythona 2 do biblioteki gexiv2
69 Group:          Development/Languages/Python
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       python-pygobject3 >= 3
72
73 %description -n python-gexiv2
74 Python 2 binding for gexiv2 library.
75
76 %description -n python-gexiv2 -l pl.UTF-8
77 Wiązanie Pythona 2 do biblioteki gexiv2.
78
79 %package -n python3-gexiv2
80 Summary:        Python 3 binding for gexiv2 library
81 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki gexiv2
82 Group:          Development/Languages/Python
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       python3-pygobject3 >= 3
85
86 %description -n python3-gexiv2
87 Python 3 binding for gexiv2 library.
88
89 %description -n python3-gexiv2 -l pl.UTF-8
90 Wiązanie Pythona 3 do biblioteki gexiv2.
91
92 %package -n vala-gexiv2
93 Summary:        Vala binding for gexiv2 library
94 Summary(pl.UTF-8):      Wiązanie języka vala do biblioteki gexiv2
95 Group:          Development/Languages
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description -n vala-gexiv2
99 Vala binding for gexiv2 library.
100
101 %description -n vala-gexiv2 -l pl.UTF-8
102 Wiązanie języka vala do biblioteki gexiv2.
103
104 %prep
105 %setup -q
106
107 %build
108 %configure \
109         --enable-introspection \
110         %{?with_static_libs:--enable-static}
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
121 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
122 %py_postclean
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS NEWS README THANKS
133 %attr(755,root,root) %{_libdir}/libgexiv2.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libgexiv2.so.2
135 %{_libdir}/girepository-1.0/GExiv2-0.10.typelib
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libgexiv2.so
140 %{_libdir}/libgexiv2.la
141 %{_datadir}/gir-1.0/GExiv2-0.10.gir
142 %{_includedir}/gexiv2
143 %{_pkgconfigdir}/gexiv2.pc
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libgexiv2.a
149 %endif
150
151 %files -n python-gexiv2
152 %defattr(644,root,root,755)
153 %{py_sitedir}/gi/overrides/GExiv2.py[co]
154
155 %files -n python3-gexiv2
156 %defattr(644,root,root,755)
157 %{py3_sitedir}/gi/overrides/GExiv2.py
158
159 %files -n vala-gexiv2
160 %defattr(644,root,root,755)
161 %{_datadir}/vala/vapi/gexiv2.vapi
This page took 0.057403 seconds and 3 git commands to generate.