]> git.pld-linux.org Git - packages/geos.git/blobdiff - geos.spec
- updated to 3.8.3 (last version with swig bindings)
[packages/geos.git] / geos.spec
index 14e8293b92066ef9d30f224a636a419559de0e37..0a60a7b833340875452edd4316fc5e4700263150 100644 (file)
--- a/geos.spec
+++ b/geos.spec
@@ -1,25 +1,29 @@
-# Conditional build:
-%bcond_without ruby # build without ruby
 #
+# Conditional build:
+%bcond_without ruby    # ruby binding
+
 Summary:       Geometry Engine - Open Source
 Summary(pl.UTF-8):     GEOS - silnik geometryczny z otwartymi źródłami
 Name:          geos
-Version:       3.0.0
-%define        _rc     rc4
-Release:       0.%{_rc}.1
-License:       LGPL
+Version:       3.8.3
+Release:       1
+License:       LGPL v2.1
 Group:         Libraries
-Source0:       http://geos.refractions.net/%{name}-%{version}%{_rc}.tar.bz2
-# Source0-md5: 90d4dba51dd75f8f1f12378e0f910d76
-URL:           http://geos.refractions.net/
+Source0:       http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
+# Source0-md5: 57e4bde34a4f8aabed096e06a2002c4d
+Patch0:                rubydir.patch
+Patch1:                %{name}-x32.patch
+URL:           https://trac.osgeo.org/geos/
+BuildRequires: autoconf >= 2.63
 BuildRequires: automake
-BuildRequires: libstdc++-devel
-BuildRequires: python >= 1:2.5
-BuildRequires: python-devel >= 1:2.5
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: python
+BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.519
 %{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: swig-python >= 1.3.29
-%{?with_ruby:BuildRequires:    swig-ruby >= 1.3.29}
+%{?with_ruby:BuildRequires:    swig-ruby >= 1.3.40-3}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -33,16 +37,16 @@ as well as specific JTS topology functions such as IsValid().
 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
-JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
-wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
-także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
+JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych wg
+"Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a także
+specyficzne dla JTS funkcje topologiczne takie jak IsValid().
 
 %package devel
 Summary:       Header files for GEOS library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki GEOS
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      libstdc++-devel
+Requires:      libstdc++-devel >= 6:4.7
 
 %description devel
 Header files for GEOS library.
@@ -87,10 +91,15 @@ Ruby bindings for Geometry Engine - Open Source.
 Wiązania języka Ruby do biblioteki GEOS.
 
 %prep
-%setup -q -n %{name}-%{version}%{_rc}
+%setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
-cp -f /usr/share/automake/config.* .
+%{__aclocal} -I macros
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
        --enable-python \
        %{?with_ruby:--enable-ruby}
@@ -98,13 +107,15 @@ cp -f /usr/share/automake/config.* .
 %{__make} \
        pkglibdir=%{_libdir}
 
-
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       pkglibdir=%{_libdir}
+       pythondir=%{py_sitescriptdir}
+
+%{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/*.{la,a}}
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
 
 %py_postclean
 
@@ -116,11 +127,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README TODO
-# fixme?:
-%attr(755,root,root) %{_libdir}/libgeos-3.0*.so
-#%attr(755,root,root) %{_libdir}/libgeos.so.*.*.*
+%doc AUTHORS NEWS README.md
+%attr(755,root,root) %{_libdir}/libgeos-%{version}.so
 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
 
 %files devel
 %defattr(644,root,root,755)
@@ -142,10 +152,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %dir %{py_sitedir}/geos
 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
-%{py_sitescriptdir}/geos*
+%{py_sitescriptdir}/geos
+%{py_sitescriptdir}/geos.pth
 
 %if %{with ruby}
 %files -n ruby-geos
 %defattr(644,root,root,755)
-%attr(755,root,root) %{ruby_archdir}/geos.so
+%attr(755,root,root) %{ruby_vendorarchdir}/geos.so
 %endif
This page took 0.086655 seconds and 4 git commands to generate.