]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
14e8293b92066ef9d30f224a636a419559de0e37
[packages/geos.git] / geos.spec
1 # Conditional build:
2 %bcond_without ruby # build without ruby
3 #
4 Summary:        Geometry Engine - Open Source
5 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
6 Name:           geos
7 Version:        3.0.0
8 %define _rc     rc4
9 Release:        0.%{_rc}.1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://geos.refractions.net/%{name}-%{version}%{_rc}.tar.bz2
13 # Source0-md5:  90d4dba51dd75f8f1f12378e0f910d76
14 URL:            http://geos.refractions.net/
15 BuildRequires:  automake
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  python >= 1:2.5
18 BuildRequires:  python-devel >= 1:2.5
19 BuildRequires:  rpm-pythonprov
20 %{?with_ruby:BuildRequires:     ruby-devel}
21 BuildRequires:  swig-python >= 1.3.29
22 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.29}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
27 Topology Suite (JTS). As such, it aims to contain the complete
28 functionality of JTS in C++. This includes all the OpenGIS "Simple
29 Features for SQL" spatial predicate functions and spatial operators,
30 as well as specific JTS topology functions such as IsValid().
31
32 %description -l pl.UTF-8
33 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
34 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
35 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
36 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
37 wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
38 także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
39
40 %package devel
41 Summary:        Header files for GEOS library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       libstdc++-devel
46
47 %description devel
48 Header files for GEOS library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki GEOS.
52
53 %package static
54 Summary:        Static GEOS library
55 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static GEOS library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka GEOS.
64
65 %package -n python-geos
66 Summary:        Python bindings for Geometry Engine - Open Source
67 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
68 Group:          Development/Languages/Python
69 Requires:       %{name} = %{version}-%{release}
70
71 %description -n python-geos
72 Python bindings for Geometry Engine - Open Source.
73
74 %description -n python-geos -l pl.UTF-8
75 Wiązania Pythona do biblioteki GEOS.
76
77 %package -n ruby-geos
78 Summary:        Ruby bindings for Geometry Engine - Open Source
79 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
80 Group:          Development/Languages/Python
81 Requires:       %{name} = %{version}-%{release}
82
83 %description -n ruby-geos
84 Ruby bindings for Geometry Engine - Open Source.
85
86 %description -n ruby-geos -l pl.UTF-8
87 Wiązania języka Ruby do biblioteki GEOS.
88
89 %prep
90 %setup -q -n %{name}-%{version}%{_rc}
91
92 %build
93 cp -f /usr/share/automake/config.* .
94 %configure \
95         --enable-python \
96         %{?with_ruby:--enable-ruby}
97
98 %{__make} \
99         pkglibdir=%{_libdir}
100
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT \
107         pkglibdir=%{_libdir}
108
109 %py_postclean
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README TODO
120 # fixme?:
121 %attr(755,root,root) %{_libdir}/libgeos-3.0*.so
122 #%attr(755,root,root) %{_libdir}/libgeos.so.*.*.*
123 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_bindir}/geos-config
128 %attr(755,root,root) %{_libdir}/libgeos.so
129 %attr(755,root,root) %{_libdir}/libgeos_c.so
130 %{_libdir}/libgeos.la
131 %{_libdir}/libgeos_c.la
132 %{_includedir}/geos
133 %{_includedir}/geos.h
134 %{_includedir}/geos_c.h
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libgeos.a
139 %{_libdir}/libgeos_c.a
140
141 %files -n python-geos
142 %defattr(644,root,root,755)
143 %dir %{py_sitedir}/geos
144 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
145 %{py_sitescriptdir}/geos*
146
147 %if %{with ruby}
148 %files -n ruby-geos
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{ruby_archdir}/geos.so
151 %endif
This page took 0.039233 seconds and 3 git commands to generate.