]> git.pld-linux.org Git - packages/geoclue2.git/blob - geoclue2.spec
- updated to 2.7.0; service uses libsoup3 now
[packages/geoclue2.git] / geoclue2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        A modular geoinformation service
6 Summary(pl.UTF-8):      Modularna usługa geoinformacyjna
7 Name:           geoclue2
8 Version:        2.7.0
9 Release:        1
10 License:        GPL v2+ (programs), LGPL v2.1+ (library)
11 Group:          Applications
12 #Source0Download: https://gitlab.freedesktop.org/geoclue/geoclue/-/tags
13 Source0:        https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/%{version}/geoclue-%{version}.tar.bz2
14 # Source0-md5:  8226cc9d4b2750b6ebdfd59e7815bf2a
15 URL:            https://geoclue.freedesktop.org/
16 BuildRequires:  ModemManager-devel >= 1.6
17 BuildRequires:  avahi-devel >= 0.6.10
18 BuildRequires:  avahi-glib-devel >= 0.6.10
19 BuildRequires:  glib2-devel >= 1:2.44.0
20 BuildRequires:  gobject-introspection-devel >= 0.10
21 BuildRequires:  gtk-doc >= 1.0
22 BuildRequires:  gtk-doc-automake >= 1.0
23 BuildRequires:  intltool >= 0.40.0
24 BuildRequires:  json-glib-devel >= 0.14
25 BuildRequires:  libnotify-devel
26 BuildRequires:  libsoup3-devel >= 3.0.0
27 BuildRequires:  meson >= 0.60.0
28 BuildRequires:  ninja >= 1.5
29 BuildRequires:  pkgconfig >= 1:0.22
30 BuildRequires:  rpm-build >= 4.6
31 BuildRequires:  rpmbuild(macros) >= 1.736
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  vala
34 BuildRequires:  yelp-tools
35 BuildRequires:  xz
36 Requires:       %{name}-libs = %{version}-%{release}
37 Requires:       avahi-libs >= 0.6.10
38 Requires:       avahi-glib >= 0.6.10
39 Requires:       dbus
40 Requires:       json-glib >= 0.14
41 Requires:       libsoup3 >= 3.0.0
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Geoclue is a modular geoinformation service built on top of the D-Bus
46 messaging system. The goal of the Geoclue project is to make creating
47 location-aware applications as simple as possible.
48
49 %description -l pl.UTF-8
50 Geoclue to modularna usługa geoinformacyjna zbudowana w oparciu o
51 system komunikacji D-Bus. Celem projektu jest jak największe
52 ułatwienie tworzenia aplikacji uwzględniających lokalizację.
53
54 %package libs
55 Summary:        Library to interact with Geoclue service
56 Summary(pl.UTF-8):      Biblioteka do współpracy z usługą Geoclue
57 License:        LGPL v2.1+
58 Group:          Libraries
59 Requires:       glib2 >= 1:2.44.0
60
61 %description libs
62 Library to interact with Geoclue service.
63
64 %description libs -l pl.UTF-8
65 Biblioteka do współpracy z usługą Geoclue.
66
67 %package devel
68 Summary:        Development package for geoclue2
69 Summary(pl.UTF-8):      Pakiet programistyczny geoclue2
70 License:        LGPL v2.1+
71 Group:          Development/Libraries
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       glib2-devel >= 1:2.44.0
74
75 %description devel
76 Header files for development with geoclue2.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe do programowania z użyciem geoclue2.
80
81 %package static
82 Summary:        Static geoclue2 library
83 Summary(pl.UTF-8):      Statyczna biblioteka geoclue2
84 License:        LGPL v2.1+
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static geoclue2 library.
90
91 %description static -l pl.UTF-8
92 Statyczna biblioteka geoclue2.
93
94 %package -n vala-geoclue2
95 Summary:        Vala API for geoclue2 library
96 Summary(pl.UTF-8):      Interfejs języka Vala do biblioteki geoclue2
97 License:        LGPL v2.1+
98 Group:          Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100 BuildArch:      noarch
101
102 %description -n vala-geoclue2
103 Vala API for geoclue2 library.
104
105 %description -n vala-geoclue2 -l pl.UTF-8
106 Interfejs języka Vala do biblioteki geoclue2.
107
108 %package apidocs
109 Summary:        API documentation for geoclue2 library
110 Summary(pl.UTF-8):      Dokumentacja API biblioteki geoclue2
111 Group:          Documentation
112 BuildArch:      noarch
113
114 %description apidocs
115 API documentation for geoclue2 library.
116
117 %description apidocs -l pl.UTF-8
118 Dokumentacja API biblioteki geoclue2.
119
120 %prep
121 %setup -q -n geoclue-%{version}
122
123 %build
124 %meson build \
125         %{!?with_static_libs:--default-library=shared} \
126         -Dsystemd-system-unit-dir=%{systemdunitdir}
127
128 # TODO: -Ddbus-srv-user= (nonroot)
129
130 %ninja_build -C build
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %ninja_install -C build
136
137 # resolve conflict with geoclue-apidocs 0.12.x
138 %{__mv} $RPM_BUILD_ROOT%{_gtkdocdir}/geoclue{,-2.0}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   libs -p /sbin/ldconfig
144 %postun libs -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc NEWS README.md
149 %attr(755,root,root) %{_libexecdir}/geoclue
150 %dir %{_sysconfdir}/geoclue
151 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/geoclue/geoclue.conf
152 %{systemdunitdir}/geoclue.service
153 /etc/dbus-1/system.d/org.freedesktop.GeoClue2.conf
154 /etc/dbus-1/system.d/org.freedesktop.GeoClue2.Agent.conf
155 %{_datadir}/dbus-1/system-services/org.freedesktop.GeoClue2.service
156 %{_datadir}/polkit-1/rules.d/org.freedesktop.GeoClue2.rules
157 # demos
158 /etc/xdg/autostart/geoclue-demo-agent.desktop
159 %dir %{_libexecdir}/geoclue-2.0
160 %dir %{_libexecdir}/geoclue-2.0/demos
161 %attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/agent
162 %attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/where-am-i
163 %{_desktopdir}/geoclue-demo-agent.desktop
164 %{_desktopdir}/geoclue-where-am-i.desktop
165 %{_mandir}/man5/geoclue.5*
166
167 %files libs
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libgeoclue-2.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libgeoclue-2.so.0
171 %{_libdir}/girepository-1.0/Geoclue-2.0.typelib
172
173 %files devel
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libgeoclue-2.so
176 %{_includedir}/libgeoclue-2.0
177 %{_datadir}/gir-1.0/Geoclue-2.0.gir
178 %{_pkgconfigdir}/geoclue-2.0.pc
179 %{_pkgconfigdir}/libgeoclue-2.0.pc
180 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.xml
181 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Agent.xml
182 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Client.xml
183 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Location.xml
184 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Manager.xml
185
186 %if %{with static_libs}
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libgeoclue-2.a
190 %endif
191
192 %files -n vala-geoclue2
193 %defattr(644,root,root,755)
194 %{_datadir}/vala/vapi/libgeoclue-2.0.deps
195 %{_datadir}/vala/vapi/libgeoclue-2.0.vapi
196
197 %files apidocs
198 %defattr(644,root,root,755)
199 %{_gtkdocdir}/geoclue-2.0
200 %{_gtkdocdir}/libgeoclue
This page took 0.037194 seconds and 3 git commands to generate.