]> git.pld-linux.org Git - packages/gengetopt.git/blob - gengetopt.spec
- initial PLD release
[packages/gengetopt.git] / gengetopt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        C code generator that generates command line options parsers
7 Summary(pl.UTF-8):      Generator kodu C generujący paser opcji linii poleceń
8 Name:           gengetopt
9 Version:        2.22.1
10 Release:        0.1
11 License:        GPL v3+
12 Group:          Development/Tools
13 Source0:        http://ftp.gnu.org/gnu/gengetopt/%{name}-%{version}.tar.gz
14 # Source0-md5:  3877433c69902a26887ad65c1a2d60eb
15 URL:            http://www.gnu.org/software/gengetopt/
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Gengetopt generates a C function that uses getopt_long function to
20 parse the command line options, to validate them and fills a struct.
21
22 %description -l pl.UTF-8
23 Gengetopt jest to narzędzie generujące kod w języku C, który służy do
24 parsowania opcji przekazanych w wierszu poleceń z użyciem biblioteki
25 getopt. Kod wygenerowany przez gengetopt potrafi obsłużyć zarówno
26 krótkie opcje, jak i długie - sprawdzić poprawność przekazazych
27 argumentów i wypełnić odpowiednie struktury.
28
29 %package examples
30 Summary:        gengetopt examples
31 Summary(pl.UTF-8):      Przykłady gengetopt
32 Group:          Documentation
33 Requires:       %{name} = %{epoch}:%{version}-%{release}
34
35 %description examples
36 Gengetopt examples.
37
38 %description examples -l pl.UTF-8
39 Przykładowe pliki dla gengetopt.
40
41 %prep
42 %setup -q
43
44 %build
45 %{__libtoolize} --force
46 %{__aclocal} -I gl/m4
47 %{__autoconf}
48 %{__autoheader}
49 %{__automake} --add-missing --gnu
50 %configure
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name},%{_datadir}/%{name},%{_infodir},%{_mandir}/man1}
57
58 install src/gengetopt $RPM_BUILD_ROOT%{_bindir}/gengetopt
59 install doc/*.{c,cc,ggo,h} $RPM_BUILD_ROOT%{_examplesdir}/gengetopt
60 install doc/README.example $RPM_BUILD_ROOT%{_examplesdir}/gengetopt
61 install src/gnugetopt.h $RPM_BUILD_ROOT%{_datadir}/gengetopt/gnugetopt.h
62 install src/getopt.c $RPM_BUILD_ROOT%{_datadir}/gengetopt/getopt.c
63 install src/getopt1.c $RPM_BUILD_ROOT%{_datadir}/gengetopt/getopt1.c
64 install doc/gengetopt.info $RPM_BUILD_ROOT%{_infodir}/gengetopt.info
65 install doc/gengetopt.1 $RPM_BUILD_ROOT%{_mandir}/man1/gengetopt.1
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc AUTHORS ChangeLog NEWS README THANKS TODO
73 %attr(755,root,root) %{_bindir}/gengetopt
74 %{_mandir}/man1/gengetopt.1*
75 %{_infodir}/gengetopt.info*
76 %{_datadir}/%{name}
77
78 %files examples
79 %defattr(644,root,root,755)
80 %{_examplesdir}/%{name}
This page took 0.056017 seconds and 4 git commands to generate.