]> git.pld-linux.org Git - packages/gengetopt.git/blob - gengetopt.spec
- updated to 2.23
[packages/gengetopt.git] / gengetopt.spec
1 Summary:        C code generator that generates command line options parsers
2 Summary(pl.UTF-8):      Generator kodu C generujący analizatory opcji linii poleceń
3 Name:           gengetopt
4 Version:        2.23
5 Release:        1
6 License:        GPL v3+
7 Group:          Development/Tools
8 Source0:        https://ftp.gnu.org/gnu/gengetopt/%{name}-%{version}.tar.xz
9 # Source0-md5:  ea165d618640dbdecb42ae4491337965
10 Patch0:         %{name}-info.patch
11 URL:            http://www.gnu.org/software/gengetopt/
12 BuildRequires:  autoconf >= 2.58
13 BuildRequires:  automake
14 BuildRequires:  help2man
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRequires:  tar >= 1:1.22
18 BuildRequires:  texinfo
19 BuildRequires:  xz
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Gengetopt generates a C function that uses getopt_long function to
24 parse the command line options, to validate them and fills a struct.
25
26 %description -l pl.UTF-8
27 Gengetopt jest to narzędzie generujące kod w języku C, wykorzystujący
28 funkcję getopt_long do analizy opcji linii poleceń, sprawdzania ich
29 poprawności i umieszczania ich w strukturze.
30
31 %package examples
32 Summary:        gengetopt examples
33 Summary(pl.UTF-8):      Przykłady do gengetopt
34 Group:          Documentation
35 Requires:       %{name} = %{version}-%{release}
36
37 %description examples
38 Gengetopt examples.
39
40 %description examples -l pl.UTF-8
41 Przykłady do gengetopt.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %build
48 %{__libtoolize}
49 %{__aclocal} -I m4 -I gl/m4
50 %{__autoconf}
51 %{__autoheader}
52 %{__automake} --gnu
53 %configure
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 cp -p doc/*.{c,cc,ggo,h} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -p doc/README.example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 # packaged as %doc
67 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gengetopt
68 # .texi meant just for index.html(?)
69 %{__rm} $RPM_BUILD_ROOT%{_infodir}/index.info
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/postshell
75 -/usr/sbin/fix-info-dir -c %{_infodir}
76
77 %postun -p /sbin/postshell
78 -/usr/sbin/fix-info-dir -c %{_infodir}
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS ChangeLog LICENSE NEWS README THANKS TODO doc/{gengetopt,index}.html
83 %attr(755,root,root) %{_bindir}/gengetopt
84 %{_mandir}/man1/gengetopt.1*
85 %{_infodir}/gengetopt.info*
86 %{_datadir}/%{name}
87
88 %files examples
89 %defattr(644,root,root,755)
90 %{_examplesdir}/%{name}-%{version}
This page took 0.061297 seconds and 4 git commands to generate.