]> git.pld-linux.org Git - packages/gengetopt.git/blob - gengetopt.spec
- fixed %install...
[packages/gengetopt.git] / gengetopt.spec
1 #
2 Summary:        C code generator that generates command line options parsers
3 Summary(pl.UTF-8):      Generator kodu C generujący paser opcji linii poleceń
4 Name:           gengetopt
5 Version:        2.22.1
6 Release:        1
7 License:        GPL v3+
8 Group:          Development/Tools
9 Source0:        http://ftp.gnu.org/gnu/gengetopt/%{name}-%{version}.tar.gz
10 # Source0-md5:  3877433c69902a26887ad65c1a2d60eb
11 URL:            http://www.gnu.org/software/gengetopt/
12 BuildRequires:  autoconf >= 2.58
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Gengetopt generates a C function that uses getopt_long function to
19 parse the command line options, to validate them and fills a struct.
20
21 %description -l pl.UTF-8
22 Gengetopt jest to narzędzie generujące kod w języku C, który służy do
23 parsowania opcji przekazanych w wierszu poleceń z użyciem biblioteki
24 getopt. Kod wygenerowany przez gengetopt potrafi obsłużyć zarówno
25 krótkie opcje, jak i długie - sprawdzić poprawność przekazazych
26 argumentów i wypełnić odpowiednie struktury.
27
28 %package examples
29 Summary:        gengetopt examples
30 Summary(pl.UTF-8):      Przykłady gengetopt
31 Group:          Documentation
32 Requires:       %{name} = %{epoch}:%{version}-%{release}
33
34 %description examples
35 Gengetopt examples.
36
37 %description examples -l pl.UTF-8
38 Przykładowe pliki dla gengetopt.
39
40 %prep
41 %setup -q
42
43 %build
44 %{__libtoolize}
45 %{__aclocal} -I gl/m4
46 %{__autoconf}
47 %{__autoheader}
48 %{__automake} --add-missing --gnu
49 %configure
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version},%{_datadir}/%{name},%{_infodir},%{_mandir}/man1}
56
57 install src/%{name} $RPM_BUILD_ROOT%{_bindir}/gengetopt
58 install doc/*.{c,cc,ggo,h} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59 install doc/README.example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60 install src/gnugetopt.h $RPM_BUILD_ROOT%{_datadir}/%{name}/gnugetopt.h
61 install src/getopt.c $RPM_BUILD_ROOT%{_datadir}/%{name}/getopt.c
62 install src/getopt1.c $RPM_BUILD_ROOT%{_datadir}/%{name}/getopt1.c
63 install doc/gengetopt.info $RPM_BUILD_ROOT%{_infodir}/gengetopt.info
64 install doc/gengetopt.1 $RPM_BUILD_ROOT%{_mandir}/man1/gengetopt.1
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS ChangeLog NEWS README THANKS TODO
72 %attr(755,root,root) %{_bindir}/gengetopt
73 %{_mandir}/man1/gengetopt.1*
74 %{_infodir}/gengetopt.info*
75 %{_datadir}/%{name}
76
77 %files examples
78 %defattr(644,root,root,755)
79 %{_examplesdir}/%{name}-%{version}
This page took 0.035383 seconds and 4 git commands to generate.