]> git.pld-linux.org Git - packages/gengetopt.git/blob - gengetopt.spec
- updated to 2.23
[packages/gengetopt.git] / gengetopt.spec
1 Summary:        C code generator that generates command line options parsers
2 Summary(pl.UTF-8):      Generator kodu C generujący analizatory opcji linii poleceń
3 Name:           gengetopt
4 Version:        2.22.6
5 Release:        1
6 License:        GPL v3+
7 Group:          Development/Tools
8 Source0:        http://ftp.gnu.org/gnu/gengetopt/%{name}-%{version}.tar.gz
9 # Source0-md5:  29749a48dda69277ab969c510597a14e
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-am.patch
12 URL:            http://www.gnu.org/software/gengetopt/
13 BuildRequires:  autoconf >= 2.58
14 BuildRequires:  automake
15 BuildRequires:  help2man
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  texinfo
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Gengetopt generates a C function that uses getopt_long function to
23 parse the command line options, to validate them and fills a struct.
24
25 %description -l pl.UTF-8
26 Gengetopt jest to narzędzie generujące kod w języku C, wykorzystujący
27 funkcję getopt_long do analizy opcji linii poleceń, sprawdzania ich
28 poprawności i umieszczania ich w strukturze.
29
30 %package examples
31 Summary:        gengetopt examples
32 Summary(pl.UTF-8):      Przykłady do gengetopt
33 Group:          Documentation
34 Requires:       %{name} = %{version}-%{release}
35
36 %description examples
37 Gengetopt examples.
38
39 %description examples -l pl.UTF-8
40 Przykłady do gengetopt.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45 %patch1 -p1
46
47 %build
48 %{__libtoolize}
49 %{__aclocal} -I m4 -I gl/m4
50 %{__autoconf}
51 %{__autoheader}
52 %{__automake} --gnu
53 %configure
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 cp -p doc/*.{c,cc,ggo,h} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -p doc/README.example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 # packaged as %doc
67 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gengetopt
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/postshell
73 -/usr/sbin/fix-info-dir -c %{_infodir}
74
75 %postun -p /sbin/postshell
76 -/usr/sbin/fix-info-dir -c %{_infodir}
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS ChangeLog LICENSE NEWS README THANKS TODO doc/{gengetopt,index}.html
81 %attr(755,root,root) %{_bindir}/gengetopt
82 %{_mandir}/man1/gengetopt.1*
83 %{_infodir}/gengetopt.info*
84 %{_datadir}/%{name}
85
86 %files examples
87 %defattr(644,root,root,755)
88 %{_examplesdir}/%{name}-%{version}
This page took 0.099536 seconds and 3 git commands to generate.