]> git.pld-linux.org Git - packages/gem2rpm.git/blame - gem2rpm.spec
up to 0.9.2
[packages/gem2rpm.git] / gem2rpm.spec
CommitLineData
f0d3c1e6 1Summary: Generate rpm specfiles from gems
e8e50a98 2Name: gem2rpm
a0c08b44
ER
3Version: 0.9.2
4Release: 0.8
f0d3c1e6
ER
5License: GPL v2+
6Group: Development/Languages
e8e50a98 7Source0: http://rubygems.org/gems/%{name}-%{version}.gem
a0c08b44 8# Source0-md5: 6988e28332369a79067d45b8c61f2851
f0d3c1e6
ER
9# git clone https://github.com/lutter/gem2rpm.git && cd gem2rpm && git checkout v0.8.1
10# tar czvf gem2rpm-0.8.1-tests.tgz test/
a0c08b44 11Source1: %{name}-0.8.1-tests.tgz
f0d3c1e6 12# Source1-md5: d7d8bc231dc405bbce00f570c89f530e
7d625e4e 13Source2: pld.spec.erb
f51775da 14Patch0: gems.patch
7d625e4e 15Patch1: pld.patch
bf1dd385 16Patch2: style.patch
e8e50a98
ER
17URL: https://github.com/lutter/gem2rpm/
18BuildRequires: rpm-rubyprov
19BuildRequires: rpmbuild(macros) >= 1.656
f0d3c1e6
ER
20Requires: ruby
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Generate source rpms and rpm spec files from a Ruby Gem. The spec file
26tries to follow the gem as closely as possible, and be compliant with
27the Fedora rubygem packaging guidelines
28
29%package doc
30Summary: Documentation for %{name}
31Group: Documentation
32Requires: %{name} = %{version}-%{release}
33
34%description doc
35Documentation for %{name}.
36
37%prep
e8e50a98 38%setup -q
f51775da 39%patch0 -p1
7d625e4e 40%patch1 -p1
bf1dd385 41%patch2 -p1
7d625e4e 42cp -p %{SOURCE2} templates
f0d3c1e6 43
b978c369
ER
44%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
45
f0d3c1e6
ER
46%build
47%if %{with tests}
48testrb -Itest test/
49%endif
50
51%install
52rm -rf $RPM_BUILD_ROOT
53install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
54
55cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
56cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
57
c2e552c8
ER
58install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
59cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
60
f0d3c1e6
ER
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%doc README AUTHORS
67%attr(755,root,root) %{_bindir}/gem2rpm
68%{ruby_rubylibdir}/gem2rpm.rb
69%{ruby_rubylibdir}/gem2rpm
c2e552c8 70%{_datadir}/ruby/templates
f0d3c1e6
ER
71
72%if 0
73%files doc
74%defattr(644,root,root,755)
75%doc %{gem_docdir}
76%doc %{gem_instdir}/README
77%doc %{gem_instdir}/AUTHORS
78%endif
This page took 0.064003 seconds and 4 git commands to generate.