]> git.pld-linux.org Git - packages/gem2rpm.git/blame - gem2rpm.spec
update pld template to be more pldish
[packages/gem2rpm.git] / gem2rpm.spec
CommitLineData
f0d3c1e6 1Summary: Generate rpm specfiles from gems
e8e50a98 2Name: gem2rpm
f0d3c1e6 3Version: 0.8.1
aed41730 4Release: 0.5
f0d3c1e6
ER
5License: GPL v2+
6Group: Development/Languages
e8e50a98 7Source0: http://rubygems.org/gems/%{name}-%{version}.gem
f0d3c1e6
ER
8# Source0-md5: d3c9416f225ae944fd195e69e122d46e
9# git clone https://github.com/lutter/gem2rpm.git && cd gem2rpm && git checkout v0.8.1
10# tar czvf gem2rpm-0.8.1-tests.tgz test/
e8e50a98 11Source1: %{name}-%{version}-tests.tgz
f0d3c1e6 12# Source1-md5: d7d8bc231dc405bbce00f570c89f530e
7d625e4e 13Source2: pld.spec.erb
f51775da 14Patch0: gems.patch
7d625e4e 15Patch1: pld.patch
e8e50a98
ER
16URL: https://github.com/lutter/gem2rpm/
17BuildRequires: rpm-rubyprov
18BuildRequires: rpmbuild(macros) >= 1.656
f0d3c1e6
ER
19Requires: ruby
20BuildArch: noarch
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Generate source rpms and rpm spec files from a Ruby Gem. The spec file
25tries to follow the gem as closely as possible, and be compliant with
26the Fedora rubygem packaging guidelines
27
28%package doc
29Summary: Documentation for %{name}
30Group: Documentation
31Requires: %{name} = %{version}-%{release}
32
33%description doc
34Documentation for %{name}.
35
36%prep
e8e50a98 37%setup -q
f51775da 38%patch0 -p1
7d625e4e
ER
39%patch1 -p1
40cp -p %{SOURCE2} templates
f0d3c1e6
ER
41
42%build
43%if %{with tests}
44testrb -Itest test/
45%endif
46
47%install
48rm -rf $RPM_BUILD_ROOT
49install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
50
51cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
52cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
53
c2e552c8
ER
54install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
55cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
56
f0d3c1e6
ER
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%doc README AUTHORS
63%attr(755,root,root) %{_bindir}/gem2rpm
64%{ruby_rubylibdir}/gem2rpm.rb
65%{ruby_rubylibdir}/gem2rpm
c2e552c8 66%{_datadir}/ruby/templates
f0d3c1e6
ER
67
68%if 0
69%files doc
70%defattr(644,root,root,755)
71%doc %{gem_docdir}
72%doc %{gem_instdir}/README
73%doc %{gem_instdir}/AUTHORS
74%endif
This page took 0.075123 seconds and 4 git commands to generate.