]> git.pld-linux.org Git - packages/gem2rpm.git/blame - ruby-gem2rpm.spec
new, version 0.8.1
[packages/gem2rpm.git] / ruby-gem2rpm.spec
CommitLineData
f0d3c1e6
ER
1%define module gem2rpm
2Summary: Generate rpm specfiles from gems
3Name: ruby-%{module}
4Version: 0.8.1
5Release: 1
6License: GPL v2+
7Group: Development/Languages
8URL: https://github.com/lutter/gem2rpm/
9Source0: http://rubygems.org/gems/%{module}-%{version}.gem
10# Source0-md5: d3c9416f225ae944fd195e69e122d46e
11# git clone https://github.com/lutter/gem2rpm.git && cd gem2rpm && git checkout v0.8.1
12# tar czvf gem2rpm-0.8.1-tests.tgz test/
13Source1: %{module}-%{version}-tests.tgz
14# Source1-md5: d7d8bc231dc405bbce00f570c89f530e
15BuildRequires: ruby
16Requires: ruby
17BuildArch: noarch
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21Generate source rpms and rpm spec files from a Ruby Gem. The spec file
22tries to follow the gem as closely as possible, and be compliant with
23the Fedora rubygem packaging guidelines
24
25%package doc
26Summary: Documentation for %{name}
27Group: Documentation
28Requires: %{name} = %{version}-%{release}
29
30%description doc
31Documentation for %{name}.
32
33%prep
34%setup -qc
35%{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
36find -newer README -o -print | xargs touch --reference %{SOURCE0}
37
38%build
39%if %{with tests}
40testrb -Itest test/
41%endif
42
43%install
44rm -rf $RPM_BUILD_ROOT
45install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
46
47cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
48cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%doc README AUTHORS
56%attr(755,root,root) %{_bindir}/gem2rpm
57%{ruby_rubylibdir}/gem2rpm.rb
58%{ruby_rubylibdir}/gem2rpm
59
60%if 0
61%files doc
62%defattr(644,root,root,755)
63%doc %{gem_docdir}
64%doc %{gem_instdir}/README
65%doc %{gem_instdir}/AUTHORS
66%endif
This page took 0.043402 seconds and 4 git commands to generate.