]> git.pld-linux.org Git - packages/geis.git/blob - geis.spec
rebuild with python 3.10
[packages/geis.git] / geis.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        An implementation of the GEIS (Gesture Engine Interface and Support) interface
6 Name:           geis
7 Version:        2.2.17
8 Release:        6
9 License:        GPL v3/LGPL v3
10 Group:          Libraries
11 Source0:        https://launchpad.net/geis/trunk/%{version}/+download/%{name}-%{version}.tar.xz
12 # Source0-md5:  2ff9d76a3ea5794516bb02c9d1924faf
13 Patch0:         build.patch
14 URL:            https://launchpad.net/geis
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  dbus-devel >= 1.2.16
18 BuildRequires:  frame-devel >= 2.2
19 BuildRequires:  grail-devel >= 3.0.8
20 BuildRequires:  libtool
21 BuildRequires:  libxcb-devel >= 1.6
22 BuildRequires:  python3-devel
23 BuildRequires:  python3-modules
24 BuildRequires:  python3-setuptools > 7.0
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  xorg-lib-libX11-devel
27 BuildRequires:  xorg-lib-libXext-devel
28 BuildRequires:  xorg-lib-libXi-devel >= 1.3
29 Requires(post,postun):  /sbin/ldconfig
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 GEIS is a library for applications and toolkit programmers which
34 provides a consistent platform independent interface for any
35 system-wide input gesture recognition mechanism.
36
37 %package tools
38 Summary:        Test tools for geis library
39 Summary(pl.UTF-8):      Testowe narzędzia biblioteki geis
40 Summary(pl.UTF-8):      Wspólne pliki biblioteki geis
41 Group:          Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description tools
45 Test tools for geis library.
46
47 %description tools -l pl.UTF-8
48 Testowe narzędzia biblioteki geis.
49
50 %package devel
51 Summary:        Header files for geis library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki geis
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 Header files for geis library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki geis.
61
62 %package static
63 Summary:        Static geis library
64 Summary(pl.UTF-8):      Statyczna biblioteka geis
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static geis library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka geis.
73
74 %package -n python3-geis
75 Summary:        Python3 bindings for geis library
76 Summary(pl.UTF-8):      Wiązania python3 dla biblioteki geis
77 Group:          Libraries/Python
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       python3-modules
80
81 %description -n python3-geis
82 Python3 bindings for geis library.
83
84 %description -n python3-geis -l pl.UTF-8
85 Wiązania python3 dla biblioteki geis.
86
87 %package -n geisview
88 Summary:        A tool to view operation of the GEIS API
89 Summary(pl.UTF-8):      Narzędzie do przeglądania działania GEIS API.
90 Group:          Applications
91 Requires:       python3-geis = %{version}-%{release}
92
93 %description -n geisview
94 A tool to view operation of the GEIS API.
95
96 %description -n geisview -l pl.UTF-8
97 Narzędzie do przeglądania działania GEIS API.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102
103 sed -i -e 's#-pedantic##g' configure.ac
104
105 %build
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoconf}
109 %{__automake}
110 %configure \
111         %{!?with_static_libs:--disable-static}
112 %{__make} V=1
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS README
131 %attr(755,root,root) %{_libdir}/libgeis.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libgeis.so.1
133
134 %files tools
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/geistest
137 %attr(755,root,root) %{_bindir}/pygeis
138 %{_mandir}/man1/pygeis.1*
139 %{_mandir}/man1/geistest.1*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libgeis.so
144 %{_includedir}/geis
145 %{_pkgconfigdir}/libgeis.pc
146
147 %if %{with static_libs}
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libgeis.a
151 %endif
152
153 %files -n python3-geis
154 %defattr(644,root,root,755)
155 %{py3_sitedir}/_geis_bindings.so
156 %dir %{py3_sitescriptdir}/geis
157 %{py3_sitescriptdir}/geis/__pycache__
158 %{py3_sitescriptdir}/geis/__init__.py*
159 %{py3_sitescriptdir}/geis/geis_v2.py*
160
161 %files -n geisview
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/geisview
164 %dir %{py3_sitescriptdir}/geisview
165 %{py3_sitescriptdir}/geisview/__pycache__
166 %{py3_sitescriptdir}/geisview/*.py*
167 %{_desktopdir}/geisview.desktop
168 %dir %{_datadir}/geisview
169 %{_datadir}/geisview/filter_definition.ui
170 %{_datadir}/geisview/filter_list.ui
171 %{_datadir}/geisview/geisview.ui
172 %{_pixmapsdir}/geisview32x32.xpm
173 %{_mandir}/man1/geisview.1*
This page took 0.053409 seconds and 3 git commands to generate.