]> git.pld-linux.org Git - packages/gdsl.git/blob - gdsl.spec
- up to 1.4
[packages/gdsl.git] / gdsl.spec
1 Summary:        Generic Data Structures Library
2 Summary(pl.UTF-8):      Biblioteka podstawowych struktur danych
3 Name:           gdsl
4 Version:        1.4
5 Release:        1
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://download.gna.org/gdsl/%{name}-%{version}.tar.gz
9 # Source0-md5:  d72d91d6327ce45ab6103a6e0f84d89a
10 URL:            http://home.gna.org/gdsl/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 GDSL (Generic Data Structures Library) is a portable and
18 OS-independant generic data structures manipulation library fully
19 written in pure ANSI C from scratch, for C programmers. Most common
20 data structures are available with powerful algorithms and hidden
21 implementation. Available structures are lists, queues, stacks, hash
22 tables, binary trees, search binary trees, red-black trees, 2D arrays,
23 and permutations.
24
25 %description -l pl.UTF-8
26 GDSL (Generic Data Structures Library) to przenośna i niezależna od
27 systemu operacyjnego biblioteka operacji na podstawowych strukturach
28 danych, napisana od zera w czystym ANSI C, dla programistów C.
29 Większość ogólnych struktur danych jest dostępna wraz z potężnymi
30 algorytmami i ukrytą implementacją. Dostępne struktury to listy,
31 kolejki, stosy, tablice haszujące, drzewa binarne, drzewa wyszukiwań
32 binarnych, drzewa czerwono-czarne, tablice dwuwymiarowe i permutacje.
33
34 %package devel
35 Summary:        Header files and development documentation for Generic Data Structures Library
36 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki podstawowych struktur danych
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files and development documentation for Generic Data Structures
42 Library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe i dokumentacja do biblioteki podstawowych struktur
46 danych.
47
48 %package static
49 Summary:        Static Generic Data Structures Library
50 Summary(pl.UTF-8):      Statyczna biblioteka podstawowych struktur danych
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static Generic Data Structures Library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka podstawowych struktur danych.
59
60 %prep
61 %setup -q
62
63 %build
64 %{__libtoolize}
65 %{__aclocal}
66 %{__autoconf}
67 %{__automake}
68 %configure
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS ChangeLog NEWS README THANKS TODO
87 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
88
89 %files devel
90 %defattr(644,root,root,755)
91 %doc src/examples/* doc/html/*.html doc/html/*.css doc/html/*.png
92 %attr(755,root,root) %{_bindir}/%{name}-config
93 %attr(755,root,root) %{_libdir}/lib*.so
94 %{_libdir}/lib*.la
95 %dir %{_includedir}/gdsl
96 %{_includedir}/gdsl/*.h
97 %{_includedir}/*.h
98 %{_mandir}/man3/*
99
100 %files static
101 %defattr(644,root,root,755)
102 %{_libdir}/lib*.a
This page took 0.07393 seconds and 3 git commands to generate.