]> git.pld-linux.org Git - packages/gdsl.git/blame - gdsl.spec
- up to 1.4
[packages/gdsl.git] / gdsl.spec
CommitLineData
6342f73f 1Summary: Generic Data Structures Library
3d6608a0 2Summary(pl.UTF-8): Biblioteka podstawowych struktur danych
6342f73f 3Name: gdsl
d6756efd 4Version: 1.4
b9133d69 5Release: 1
6342f73f
PG
6License: GPL v2
7Group: Libraries
ef85a7b8 8Source0: http://download.gna.org/gdsl/%{name}-%{version}.tar.gz
d6756efd 9# Source0-md5: d72d91d6327ce45ab6103a6e0f84d89a
ef85a7b8 10URL: http://home.gna.org/gdsl/
2a682dec 11BuildRequires: autoconf
12BuildRequires: automake
13BuildRequires: libtool
6342f73f
PG
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17GDSL (Generic Data Structures Library) is a portable and
18OS-independant generic data structures manipulation library fully
19written in pure ANSI C from scratch, for C programmers. Most common
20data structures are available with powerful algorithms and hidden
21implementation. Available structures are lists, queues, stacks, hash
22tables, binary trees, search binary trees, red-black trees, 2D arrays,
23and permutations.
24
4ee442af
JR
25%description -l pl.UTF-8
26GDSL (Generic Data Structures Library) to przenośna i niezależna od
5dbaadf6 27systemu operacyjnego biblioteka operacji na podstawowych strukturach
4ee442af
JR
28danych, napisana od zera w czystym ANSI C, dla programistów C.
29Większość ogólnych struktur danych jest dostępna wraz z potężnymi
30algorytmami i ukrytą implementacją. Dostępne struktury to listy,
31kolejki, stosy, tablice haszujące, drzewa binarne, drzewa wyszukiwań
5dbaadf6
JB
32binarnych, drzewa czerwono-czarne, tablice dwuwymiarowe i permutacje.
33
6342f73f
PG
34%package devel
35Summary: Header files and development documentation for Generic Data Structures Library
3d6608a0 36Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki podstawowych struktur danych
6342f73f 37Group: Development/Libraries
ef85a7b8 38Requires: %{name} = %{version}-%{release}
6342f73f
PG
39
40%description devel
41Header files and development documentation for Generic Data Structures
42Library.
43
4ee442af
JR
44%description devel -l pl.UTF-8
45Pliki nagłówkowe i dokumentacja do biblioteki podstawowych struktur
6342f73f
PG
46danych.
47
48%package static
49Summary: Static Generic Data Structures Library
3d6608a0 50Summary(pl.UTF-8): Statyczna biblioteka podstawowych struktur danych
6342f73f 51Group: Development/Libraries
ef85a7b8 52Requires: %{name}-devel = %{version}-%{release}
6342f73f
PG
53
54%description static
55Static Generic Data Structures Library.
56
4ee442af 57%description static -l pl.UTF-8
6342f73f
PG
58Statyczna biblioteka podstawowych struktur danych.
59
60%prep
61%setup -q
6342f73f
PG
62
63%build
2a682dec 64%{__libtoolize}
b4435355 65%{__aclocal}
6342f73f
PG
66%{__autoconf}
67%{__automake}
68%configure
69
70%{__make}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
d9da8627
JB
75%{__make} install \
76 DESTDIR=$RPM_BUILD_ROOT
6342f73f 77
6342f73f
PG
78%clean
79rm -rf $RPM_BUILD_ROOT
80
5dbaadf6
JB
81%post -p /sbin/ldconfig
82%postun -p /sbin/ldconfig
83
6342f73f
PG
84%files
85%defattr(644,root,root,755)
d9da8627
JB
86%doc AUTHORS ChangeLog NEWS README THANKS TODO
87%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
6342f73f
PG
88
89%files devel
90%defattr(644,root,root,755)
d9da8627
JB
91%doc src/examples/* doc/html/*.html doc/html/*.css doc/html/*.png
92%attr(755,root,root) %{_bindir}/%{name}-config
93%attr(755,root,root) %{_libdir}/lib*.so
94%{_libdir}/lib*.la
5dbaadf6 95%dir %{_includedir}/gdsl
6342f73f 96%{_includedir}/gdsl/*.h
b9133d69 97%{_includedir}/*.h
6342f73f
PG
98%{_mandir}/man3/*
99
100%files static
101%defattr(644,root,root,755)
d9da8627 102%{_libdir}/lib*.a
This page took 0.087892 seconds and 4 git commands to generate.