]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- update jvm paths and deps for openjdk11, rel 11
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - MongoCXX (mongo/client/dbclient.h, -lmongoclient -lboost_system -lboost_thread -lboost_regex)
6 # - rasterlite2
7 # - sfcgal >= 1.2.2
8 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9 # - libkml (1.3.0 needed, not released yet)
10 # - wait for newer pcidsk, switch to external again
11 # - csharp, java
12 # - additional, proprietary(?) formats support:
13 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17 #   - MrSID (http://www.lizardtech.com/developer/)
18 #   - LuraTech JP2Lura 
19 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
20 #   - Ingres (--with-ingres=/path)
21 #   - Informix DB (--with-idb)
22 #   - DWGdirect (members only? http://www.opendwg.org/)
23 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24 #   - Teigha DWG/DGN (https://www.opendesign.com/products/drawings?)
25 #
26 # Conditional build:
27 %bcond_without  armadillo       # Armadillo support for faster TPS transform
28 %bcond_without  crnlib          # DDS support via crunch/crnlib
29 %bcond_without  epsilon         # EPSILON wavelet compression support
30 %bcond_without  fyba            # SOSI geodata support using FYBA
31 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
32 %bcond_without  gta             # GTA format support
33 %bcond_without  kea             # KEA format support
34 %bcond_without  mysql           # MySQL DB support
35 %bcond_with     oci             # ORACLE OCI DB and Georaster support
36 %bcond_without  odbc            # ODBC DB support
37 %bcond_without  opencl          # OpenCL (GPU) support
38 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
39 %bcond_with     podofo          # PDF support via podofo instead of poppler
40 %bcond_without  poppler         # PDF support via poppler
41 %bcond_with     rasdaman        # Rasdaman support
42 %bcond_with     spatialite      # SpatiaLite support
43 %bcond_without  xerces          # Xerces support
44 %bcond_without  java            # Java and MDB support
45
46 %if %{with podofo}
47 %undefine       with_poppler
48 %endif
49 Summary:        Geospatial Data Abstraction Library
50 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
51 Name:           gdal
52 Version:        3.0.4
53 Release:        11
54 License:        BSD-like
55 Group:          Libraries
56 Source0:        https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
57 # Source0-md5:  c6bbb5caca06e96bd97a32918e0aa9aa
58 Patch0:         %{name}-perl.patch
59 Patch1:         %{name}-pc.patch
60 Patch2:         %{name}-dds.patch
61 Patch3:         %{name}-rasdaman.patch
62 Patch4:         %{name}-pluginsdir.patch
63 Patch5:         libx32.patch
64 Patch7:         decl.patch
65 Patch8:         %{name}_tirpcinc.patch
66 Patch9:         jasper.patch
67 Patch10:        gcc11.patch
68 URL:            http://www.gdal.org/
69 # 1.x or 2.x supported
70 BuildRequires:  CharLS-devel
71 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
72 %{?with_armadillo:BuildRequires:        armadillo-devel}
73 BuildRequires:  autoconf >= 2.52
74 BuildRequires:  automake
75 BuildRequires:  cfitsio-devel
76 %{?with_crnlib:BuildRequires:   crnlib-devel}
77 BuildRequires:  cryptopp-devel
78 BuildRequires:  curl-devel
79 BuildRequires:  doxygen >= 1.4.2
80 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
81 BuildRequires:  expat-devel >= 1.95.0
82 %{?with_fyba:BuildRequires:     fyba-devel}
83 BuildRequires:  freexl-devel >= 1.0
84 BuildRequires:  gcc >= 6:4.1
85 BuildRequires:  geos-devel >= 3.1.0
86 BuildRequires:  giflib-devel >= 4.0
87 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
88 BuildRequires:  hdf-devel >= 4.2.5
89 BuildRequires:  hdf5-devel
90 BuildRequires:  jasper-devel
91 %{?with_java:BuildRequires:     jdk >= 11}
92 %{?with_java:BuildRequires:     jpackage-utils}
93 BuildRequires:  json-c-devel >= 0.11
94 %{?with_kea:BuildRequires:      kealib-devel}
95 BuildRequires:  libcsf-devel >= 2.0-0.041111.6
96 BuildRequires:  libdap-devel >= 3.10
97 BuildRequires:  libgeotiff-devel >= 1.2.1
98 %{?with_gta:BuildRequires:      libgta-devel}
99 BuildRequires:  libjpeg-devel >= 6b
100 #BuildRequires: libkml-devel >= 1.3.0
101 BuildRequires:  libpng-devel >= 2:1.2.8
102 %{?with_spatialite:BuildRequires:       libspatialite-devel}
103 BuildRequires:  libstdc++-devel
104 BuildRequires:  libtiff-devel >= 4.0
105 BuildRequires:  libtirpc-devel
106 BuildRequires:  libtool
107 BuildRequires:  libuuid-devel
108 BuildRequires:  libwebp-devel
109 BuildRequires:  libxml2-devel >= 2
110 #%{?with_mysql:BuildRequires:   mysql-devel >= 4}
111 %{?with_mysql:BuildRequires:    /usr/bin/mysql_config}
112 BuildRequires:  netcdf-devel >= 4.1
113 BuildRequires:  ogdi-devel >= 3.1
114 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
115 # 8.1.7 for DB support, 10.0.1 for georaster
116 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
117 #BuildRequires: pcidsk-devel > 0.3
118 BuildRequires:  pcre-devel
119 BuildRequires:  perl-devel
120 BuildRequires:  pkgconfig >= 1:0.21
121 %{?with_podofo:BuildRequires:   podofo-devel}
122 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
123 # ensure it's compiled with PQescapeStringConn support
124 BuildRequires:  postgresql-backend-devel >= 8.1.4
125 BuildRequires:  postgresql-devel >= 8.1.4
126 BuildRequires:  proj-devel >= 4
127 BuildRequires:  python-devel >= 1:2.5
128 BuildRequires:  python-numpy-devel >= 1:1.0.0
129 BuildRequires:  python-setuptools
130 BuildRequires:  qhull-devel >= 2012
131 %{?with_rasdaman:BuildRequires: rasdaman-devel}
132 BuildRequires:  rpm-pythonprov
133 BuildRequires:  rpmbuild(macros) >= 1.344
134 BuildRequires:  sed >= 4.0
135 BuildRequires:  sqlite3-devel >= 3.0.0
136 BuildRequires:  swig-perl
137 BuildRequires:  swig-python >= 1.3
138 BuildRequires:  texlive-dvips
139 BuildRequires:  texlive-latex
140 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
141 %{?with_xerces:BuildRequires:   xerces-c-devel >= 3.1.0}
142 BuildRequires:  xz-devel
143 BuildRequires:  zlib-devel >= 1.1.4
144 # for ZSTD compression in TIFF
145 BuildRequires:  zstd-devel
146 Requires:       freexl >= 1.0
147 Requires:       geos >= 3.1.0
148 Requires:       hdf >= 4.2.5
149 Requires:       libgeotiff >= 1.2.1
150 Requires:       libpng >= 2:1.2.8
151 Requires:       libtiff >= 4.0
152 %{?with_openjpeg:Requires:      openjpeg2 >= 2.1.0}
153 Requires:       qhull >= 2012
154 %{?with_xerces:Requires:        xerces-c >= 3.1.0}
155 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
156
157 %description
158 GDAL is a translator library for raster geospatial data formats that
159 is released under an Open Source license. As a library, it presents a
160 single abstract data model to the calling application for all
161 supported formats. The related OGR library (which lives within the
162 GDAL source tree) provides a similar capability for simple features
163 vector data.
164
165 %description -l pl.UTF-8
166 GDAL to biblioteka konwertująca między formatami rastrowych danych
167 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
168 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
169 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
170 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
171 możliwości dla danych wektorowych.
172
173 %package devel
174 Summary:        GDAL library header files
175 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
176 Group:          Development/Libraries
177 Requires:       %{name} = %{version}-%{release}
178 Requires:       CharLS-devel
179 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
180 %{?with_armadillo:Requires:     armadillo-devel}
181 Requires:       cfitsio-devel
182 %{?with_crnlib:Requires:        crnlib-devel}
183 Requires:       cryptopp-devel
184 Requires:       curl-devel
185 %{?with_epsilon:Requires:       epsilon-compressor-devel}
186 %{?with_fyba:Requires:  fyba-devel}
187 Requires:       expat-devel >= 1.95.0
188 Requires:       freexl-devel >= 1.0
189 Requires:       geos-devel >= 3.1.0
190 Requires:       giflib-devel >= 4.0
191 Requires:       hdf-devel >= 4.2.5
192 Requires:       hdf5-devel
193 Requires:       jasper-devel
194 Requires:       json-c-devel >= 0.11
195 %{?with_kea:Requires:   kealib-devel}
196 Requires:       libcsf-devel
197 Requires:       libdap-devel >= 3.10
198 Requires:       libgeotiff-devel >= 1.2.1
199 %{?with_gta:Requires:   libgta-devel}
200 Requires:       libjpeg-devel >= 6b
201 Requires:       libpng-devel >= 2:1.2.8
202 %{?with_spatialite:Requires:    libspatialite-devel}
203 Requires:       libstdc++-devel
204 Requires:       libtiff-devel >= 4.0
205 Requires:       libuuid-devel
206 Requires:       libwebp-devel
207 Requires:       libxml2-devel >= 2
208 %{?with_mysql:Requires: /usr/bin/mysql_config}
209 Requires:       netcdf-devel >= 4
210 Requires:       ogdi-devel >= 3.1
211 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.1.0}
212 #Requires:      pcidsk-devel > 0.3
213 Requires:       pcre-devel
214 %{?with_podofo:Requires:        podofo-devel}
215 %{?with_poppler:Requires:       poppler-devel >= 0.24}
216 Requires:       postgresql-devel
217 Requires:       proj-devel >= 4
218 Requires:       qhull-devel >= 2012
219 %{?with_rasdaman:Requires:      rasdaman-devel}
220 Requires:       sqlite3-devel >= 3.0.0
221 %{?with_odbc:Requires:  unixODBC-devel}
222 %{?with_xerces:Requires:        xerces-c-devel >= 3.1.0}
223 Requires:       xz-devel
224 Requires:       zlib-devel >= 1.1.4
225 Requires:       zstd-devel
226
227 %description devel
228 GDAL library header files.
229
230 %description devel -l pl.UTF-8
231 Pliki nagłówkowe biblioteki GDAL.
232
233 %package static
234 Summary:        GDAL static libraries
235 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
236 Group:          Development/Libraries
237 Requires:       %{name}-devel = %{version}-%{release}
238
239 %description static
240 GDAL static libraries.
241
242 %description static -l pl.UTF-8
243 Statyczne biblioteki GDAL.
244
245 %package -n perl-gdal
246 Summary:        Perl bindings for GDAL
247 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
248 Group:          Development/Languages/Perl
249 Requires:       %{name} = %{version}-%{release}
250
251 %description -n perl-gdal
252 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
253
254 %description -n perl-gdal -l pl.UTF-8
255 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
256
257 %package -n python-gdal
258 Summary:        GDAL Python module
259 Summary(pl.UTF-8):      Moduł Pythona GDAL
260 Group:          Libraries/Python
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       python-libs
263
264 %description -n python-gdal
265 GDAL Python module.
266
267 %description -n python-gdal -l pl.UTF-8
268 Moduł Pythona GDAL.
269
270 %prep
271 %setup -q
272 %patch0 -p1
273 %patch1 -p1
274 %patch2 -p1
275 %patch3 -p1
276 %patch4 -p1
277 %patch5 -p1
278 %patch7 -p1
279 %patch8 -p1
280 %patch9 -p2
281 %patch10 -p2
282
283 # need to regenerate (old ones don't support perl 5.10)
284 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
285
286 # our man path
287 sed -i -e 's#^mandir=.*##g' configure.ac
288
289 %{__rm} -r man
290
291 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
292
293 sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
294           -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
295           -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
296       swig/python/scripts/epsg_tr.py \
297       swig/python/scripts/esri2wkt.py \
298       swig/python/scripts/gcps2vec.py \
299       swig/python/scripts/gcps2wld.py \
300       swig/python/scripts/gdal2tiles.py \
301       swig/python/scripts/gdal2xyz.py \
302       swig/python/scripts/gdal_auth.py \
303       swig/python/scripts/gdal_calc.py \
304       swig/python/scripts/gdal_edit.py \
305       swig/python/scripts/gdal_fillnodata.py \
306       swig/python/scripts/gdal_merge.py \
307       swig/python/scripts/gdal_pansharpen.py \
308       swig/python/scripts/gdal_polygonize.py \
309       swig/python/scripts/gdal_proximity.py \
310       swig/python/scripts/gdal_retile.py \
311       swig/python/scripts/gdal_sieve.py \
312       swig/python/scripts/gdalchksum.py \
313       swig/python/scripts/gdalcompare.py \
314       swig/python/scripts/gdalident.py \
315       swig/python/scripts/gdalimport.py \
316       swig/python/scripts/gdalmove.py \
317       swig/python/scripts/mkgraticule.py \
318       swig/python/scripts/ogrmerge.py \
319       swig/python/scripts/pct2rgb.py \
320       swig/python/scripts/rgb2pct.py
321
322 %build
323 cp -f /usr/share/gettext/config.rpath .
324
325 %ifarch %{x8664}
326 jvm_arch=amd64
327 %endif
328 %ifarch %{ix86}
329 jvm_arch=i386
330 %endif
331 %ifarch x32
332 jvm_arch=x32
333 %endif
334
335 %{__libtoolize}
336 %{__aclocal} -I m4
337 %{__autoconf}
338 %{__autoheader}
339 %configure \
340         --includedir=%{_includedir}/gdal \
341         --datadir=%{_datadir}/gdal \
342         --with-dods-root=/usr \
343         %{?with_armadillo:--with-armadillo} \
344         %{?with_crnlib:--with-dds} \
345         %{?with_epsilon:--with-epsilon} \
346         %{?with_grass:--with-grass} \
347         %{!?with_gta:--without-gta} \
348         --with-hide-internal-symbols \
349         %{?with_java:--with-java=%{java_home}} \
350         --with-liblzma \
351         %{!?with_kea:--without-kea} \
352         %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/lib/server} \
353         %{?with_mysql:--with-mysql} \
354         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
355         %{?with_opencl:--with-opencl} \
356         --with-perl \
357         %{?with_podofo:--with-podofo} \
358         %{?with_poppler:--with-poppler} \
359         --with-python \
360         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
361         %{?with_fyba:--with-sosi} \
362         %{?with_spatialite:--with-spatialite} \
363         --with-sqlite3 \
364         --with-webp \
365         %{?with_xerces:--with-xerces} \
366         --with-xerces-inc=/usr/include \
367         --with-xerces-lib="-lxerces-c" \
368         --without-libgrass
369 #       --with-pcidsk=/usr (needs > 0.3)
370 # csharp builds, but has no configure option nor install target
371
372 # regenerate where needed
373 %{__make} -j1 -C swig/perl generate
374
375 %{__make} \
376         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
377         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
378
379 %{__make} -j1 docs
380
381 %{__make} -j1 man
382
383 %install
384 rm -rf $RPM_BUILD_ROOT
385
386 %{__make} -j1 install install-man \
387         DESTDIR=$RPM_BUILD_ROOT
388
389 # TODO: remove libgdal.la when gdal.pc gets maintained Requires.private/Libs.private list
390
391 rm -rf _html
392 cp -a html _html
393
394 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
395 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
396 %py_postclean
397
398 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
399 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
400 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
401 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
402 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
403
404 %clean
405 rm -rf $RPM_BUILD_ROOT
406
407 %post   -p /sbin/ldconfig
408 %postun -p /sbin/ldconfig
409
410 %files
411 %defattr(644,root,root,755)
412 %doc NEWS PROVENANCE.TXT
413 %attr(755,root,root) %{_bindir}/epsg_tr.py
414 %attr(755,root,root) %{_bindir}/esri2wkt.py
415 %attr(755,root,root) %{_bindir}/gcps2vec.py
416 %attr(755,root,root) %{_bindir}/gcps2wld.py
417 %attr(755,root,root) %{_bindir}/gdal2tiles.py
418 %attr(755,root,root) %{_bindir}/gdal2xyz.py
419 %attr(755,root,root) %{_bindir}/gdaladdo
420 %attr(755,root,root) %{_bindir}/gdal_auth.py
421 %attr(755,root,root) %{_bindir}/gdalbuildvrt
422 %attr(755,root,root) %{_bindir}/gdal_calc.py
423 %attr(755,root,root) %{_bindir}/gdalchksum.py
424 %attr(755,root,root) %{_bindir}/gdalcompare.py
425 %attr(755,root,root) %{_bindir}/gdal_contour
426 %attr(755,root,root) %{_bindir}/gdaldem
427 %attr(755,root,root) %{_bindir}/gdal_edit.py
428 %attr(755,root,root) %{_bindir}/gdalenhance
429 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
430 %attr(755,root,root) %{_bindir}/gdal_grid
431 %attr(755,root,root) %{_bindir}/gdalident.py
432 %attr(755,root,root) %{_bindir}/gdalimport.py
433 %attr(755,root,root) %{_bindir}/gdalinfo
434 %attr(755,root,root) %{_bindir}/gdallocationinfo
435 %attr(755,root,root) %{_bindir}/gdalmanage
436 %attr(755,root,root) %{_bindir}/gdal_merge.py
437 %attr(755,root,root) %{_bindir}/gdalmove.py
438 %attr(755,root,root) %{_bindir}/gdal_pansharpen.py
439 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
440 %attr(755,root,root) %{_bindir}/gdal_proximity.py
441 %attr(755,root,root) %{_bindir}/gdal_rasterize
442 %attr(755,root,root) %{_bindir}/gdal_retile.py
443 %attr(755,root,root) %{_bindir}/gdalserver
444 %attr(755,root,root) %{_bindir}/gdal_sieve.py
445 %attr(755,root,root) %{_bindir}/gdalsrsinfo
446 %attr(755,root,root) %{_bindir}/gdaltindex
447 %attr(755,root,root) %{_bindir}/gdaltransform
448 %attr(755,root,root) %{_bindir}/gdal_translate
449 %attr(755,root,root) %{_bindir}/gdalwarp
450 %attr(755,root,root) %{_bindir}/gnmanalyse
451 %attr(755,root,root) %{_bindir}/gnmmanage
452 %attr(755,root,root) %{_bindir}/mkgraticule.py
453 %attr(755,root,root) %{_bindir}/nearblack
454 %attr(755,root,root) %{_bindir}/ogr2ogr
455 %attr(755,root,root) %{_bindir}/ogrinfo
456 %attr(755,root,root) %{_bindir}/ogrlineref
457 %attr(755,root,root) %{_bindir}/ogrmerge.py
458 %attr(755,root,root) %{_bindir}/ogrtindex
459 %attr(755,root,root) %{_bindir}/pct2rgb.py
460 %attr(755,root,root) %{_bindir}/rgb2pct.py
461 %attr(755,root,root) %{_bindir}/testepsg
462 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
463 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.26
464 %dir %{_libdir}/gdalplugins
465 %{_datadir}/gdal
466 %{_mandir}/man1/gdal2tiles.1*
467 %{_mandir}/man1/gdal_calc.1*
468 %{_mandir}/man1/gdal_contour.1*
469 %{_mandir}/man1/gdal_edit.1*
470 %{_mandir}/man1/gdal_fillnodata.1*
471 %{_mandir}/man1/gdal_grid.1*
472 %{_mandir}/man1/gdal_merge.1*
473 %{_mandir}/man1/gdal_polygonize.1*
474 %{_mandir}/man1/gdal_proximity.1*
475 %{_mandir}/man1/gdal_rasterize.1*
476 %{_mandir}/man1/gdal_retile.1*
477 %{_mandir}/man1/gdal_sieve.1*
478 %{_mandir}/man1/gdal_translate.1*
479 %{_mandir}/man1/gdal_utilities.1*
480 %{_mandir}/man1/gdaladdo.1*
481 %{_mandir}/man1/gdalbuildvrt.1*
482 %{_mandir}/man1/gdalcompare.1*
483 %{_mandir}/man1/gdaldem.1*
484 %{_mandir}/man1/gdalinfo.1*
485 %{_mandir}/man1/gdallocationinfo.1*
486 %{_mandir}/man1/gdalmanage.1*
487 %{_mandir}/man1/gdalmove.1*
488 %{_mandir}/man1/gdalsrsinfo.1*
489 %{_mandir}/man1/gdaltindex.1*
490 %{_mandir}/man1/gdaltransform.1*
491 %{_mandir}/man1/gdalwarp.1*
492 %{_mandir}/man1/nearblack.1*
493 %{_mandir}/man1/ogr2ogr.1*
494 %{_mandir}/man1/ogr_utilities.1*
495 %{_mandir}/man1/ogrinfo.1*
496 %{_mandir}/man1/ogrlineref.1*
497 %{_mandir}/man1/ogrtindex.1*
498 %{_mandir}/man1/pct2rgb.1*
499 %{_mandir}/man1/rgb2pct.1*
500 %{_mandir}/man1/gdal_pansharpen.1*
501 %{_mandir}/man1/gnm_utilities.1*
502 %{_mandir}/man1/gnmanalyse.1*
503 %{_mandir}/man1/gnmmanage.1*
504 %{_mandir}/man1/ogrmerge.1*
505
506 %files devel
507 %defattr(644,root,root,755)
508 %doc _html/*
509 %attr(755,root,root) %{_bindir}/gdal-config
510 %attr(755,root,root) %{_libdir}/libgdal.so
511 %{_libdir}/libgdal.la
512 %{_pkgconfigdir}/gdal.pc
513 %{_includedir}/gdal
514 %{_mandir}/man1/gdal-config.1*
515
516 %files static
517 %defattr(644,root,root,755)
518 %{_libdir}/libgdal.a
519
520 %files -n perl-gdal
521 %defattr(644,root,root,755)
522 %dir %{perl_vendorarch}/Geo
523 %{perl_vendorarch}/Geo/GDAL.pm
524 %dir %{perl_vendorarch}/Geo/GDAL
525 %{perl_vendorarch}/Geo/GDAL/Const.pm
526 %{perl_vendorarch}/Geo/OGR.pm
527 %{perl_vendorarch}/Geo/OSR.pm
528 %dir %{perl_vendorarch}/auto/Geo
529 %dir %{perl_vendorarch}/auto/Geo/GDAL
530 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
531 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
532 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
533 %dir %{perl_vendorarch}/auto/Geo/GNM
534 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
535 %dir %{perl_vendorarch}/auto/Geo/OGR
536 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
537 %dir %{perl_vendorarch}/auto/Geo/OSR
538 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
539 %{_mandir}/man3/Geo::GDAL.3pm*
540 %{perl_vendorarch}/Geo/GNM.pm
541
542 %files -n python-gdal
543 %defattr(644,root,root,755)
544 %{py_sitedir}/gdal.py[co]
545 %{py_sitedir}/gdalconst.py[co]
546 %{py_sitedir}/gdalnumeric.py[co]
547 %{py_sitedir}/ogr.py[co]
548 %{py_sitedir}/osr.py[co]
549 %{py_sitedir}/GDAL-*.egg-info
550 %dir %{py_sitedir}/osgeo
551 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
552 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
553 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
554 %attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
555 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
556 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
557 %{py_sitedir}/osgeo/*.py[co]
This page took 0.095017 seconds and 4 git commands to generate.