]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- added fyba patch (SOSI support with default prefix); enabled SOSI/fyba (+bcond)
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
7 # - libkml (1.3.0 needed, not released yet)
8 # - wait for newer pcidsk, switch to external again
9 # - csharp, java
10 # - additional, proprietary(?) formats support:
11 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
12 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
13 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
14 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
15 #   - MrSID (http://www.lizardtech.com/developer/)
16 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
17 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
18 #   - Ingres (--with-ingres=/path)
19 #   - Informix DB (--with-idb)
20 #   - DWGdirect (members only? http://www.opendwg.org/)
21 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
22 #
23 # Conditional build:
24 %bcond_without  armadillo       # Armadillo support for faster TPS transform
25 %bcond_without  crnlib          # DDS support via crunch/crnlib
26 %bcond_without  epsilon         # EPSILON wavelet compression support
27 %bcond_without  fyba            # SOSI geodata support using FYBA
28 %bcond_with     grass           # GRASS support (note: dependency loop)
29 %bcond_without  gta             # GTA format support
30 %bcond_without  mysql           # MySQL DB support
31 %bcond_with     oci             # ORACLE OCI DB and Georaster support
32 %bcond_without  odbc            # ODBC DB support
33 %bcond_without  opencl          # OpenCL (GPU) support
34 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
35 %bcond_with     podofo          # PDF support via podofo instead of poppler
36 %bcond_without  poppler         # PDF support via poppler
37 %bcond_without  rasdaman        # Rasdaman support
38 %bcond_without  spatialite      # SpatiaLite support
39 %bcond_without  xerces          # Xerces support
40 %bcond_without  java            # Java and MDB support
41 %bcond_without  php             # PHP binding
42 %bcond_without  ruby            # Ruby binding
43
44 %if %{with podofo}
45 %undefine       with_poppler
46 %endif
47 Summary:        Geospatial Data Abstraction Library
48 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
49 Name:           gdal
50 Version:        1.11.0
51 Release:        1
52 License:        BSD-like
53 Group:          Libraries
54 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
55 # Source0-md5:  31f2c4a7230b40e5fdc3cf12a100f96b
56 Patch0:         %{name}-perl.patch
57 Patch1:         %{name}-python_install.patch
58 Patch2:         %{name}-php.patch
59 Patch3:         %{name}-fpic.patch
60 Patch4:         %{name}-format-security.patch
61 Patch5:         %{name}-grass.patch
62 Patch6:         %{name}-sse.patch
63 Patch7:         %{name}-link.patch
64 Patch8:         %{name}-fyba.patch
65 Patch9:         %{name}-dds.patch
66 Patch10:        %{name}-gif.patch
67 Patch11:        %{name}-armadillo.patch
68 Patch12:        %{name}-oci.patch
69 Patch13:        %{name}-rasdaman.patch
70 URL:            http://www.gdal.org/
71 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
72 %{?with_armadillo:BuildRequires:        armadillo-devel}
73 BuildRequires:  autoconf >= 2.52
74 BuildRequires:  automake
75 BuildRequires:  cfitsio-devel
76 %{?with_dds:BuildRequires:      crnlib-devel}
77 BuildRequires:  curl-devel
78 BuildRequires:  doxygen >= 1.4.2
79 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
80 BuildRequires:  expat-devel >= 1.95.0
81 %{?with_fyba:BuildRequires:     fyba-devel}
82 BuildRequires:  freexl-devel >= 1.0
83 BuildRequires:  gcc >= 6:4.1
84 BuildRequires:  geos-devel >= 3.1.0
85 BuildRequires:  giflib-devel >= 4.0
86 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
87 BuildRequires:  hdf-devel >= 4.0
88 BuildRequires:  hdf5-devel
89 BuildRequires:  jasper-devel
90 %{?with_java:BuildRequires:     jdk}
91 %{?with_java:BuildRequires:     jpackage-utils}
92 BuildRequires:  json-c-devel >= 0.11
93 BuildRequires:  libcsf-devel
94 BuildRequires:  libdap-devel >= 3.10
95 BuildRequires:  libgeotiff-devel >= 1.2.1
96 %{?with_gta:BuildRequires:      libgta-devel}
97 BuildRequires:  libjpeg-devel >= 6b
98 #BuildRequires: libkml-devel >= 1.3.0
99 BuildRequires:  libpng-devel >= 2:1.2.8
100 %{?with_spatialite:BuildRequires:       libspatialite-devel}
101 BuildRequires:  libstdc++-devel
102 BuildRequires:  libtiff-devel >= 4.0
103 BuildRequires:  libtool
104 BuildRequires:  libuuid-devel
105 BuildRequires:  libwebp-devel
106 BuildRequires:  libxml2-devel >= 2
107 %{?with_mysql:BuildRequires:    mysql-devel}
108 BuildRequires:  netcdf-devel >= 4.1
109 BuildRequires:  ogdi-devel >= 3.1
110 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
111 # 8.1.7 for DB support, 10.0.1 for georaster
112 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
113 #BuildRequires: pcidsk-devel > 0.3
114 BuildRequires:  perl-devel
115 %{?with_php:BuildRequires:      php-devel}
116 %{?with_podofo:BuildRequires:   podofo-devel}
117 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
118 # ensure it's compiled with PQescapeStringConn support
119 BuildRequires:  postgresql-backend-devel >= 8.1.4
120 BuildRequires:  postgresql-devel >= 8.1.4
121 BuildRequires:  proj-devel >= 4
122 BuildRequires:  python-devel >= 1:2.5
123 BuildRequires:  python-numpy-devel >= 1:1.0.0
124 BuildRequires:  python-setuptools
125 %{?with_rasdaman:BuildRequires: rasdaman-devel}
126 BuildRequires:  rpm-pythonprov
127 %{?with_ruby:BuildRequires:     rpm-rubyprov}
128 BuildRequires:  rpmbuild(macros) >= 1.344
129 %{?with_ruby:BuildRequires:     ruby-devel}
130 BuildRequires:  sed >= 4.0
131 BuildRequires:  sqlite3-devel >= 3.0.0
132 BuildRequires:  swig-perl
133 BuildRequires:  swig-php >= 2.0.12-2
134 BuildRequires:  swig-python >= 1.3
135 %{?with_ruby:BuildRequires:     swig-ruby}
136 BuildRequires:  texlive-dvips
137 BuildRequires:  texlive-latex
138 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
139 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
140 BuildRequires:  xz-devel
141 BuildRequires:  zlib-devel >= 1.1.4
142 Requires:       freexl >= 1.0
143 Requires:       geos >= 3.1.0
144 Requires:       libgeotiff >= 1.2.1
145 Requires:       libpng >= 2:1.2.8
146 Requires:       libtiff >= 4.0
147 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
148
149 %description
150 GDAL is a translator library for raster geospatial data formats that
151 is released under an Open Source license. As a library, it presents a
152 single abstract data model to the calling application for all
153 supported formats. The related OGR library (which lives within the
154 GDAL source tree) provides a similar capability for simple features
155 vector data.
156
157 %description -l pl.UTF-8
158 GDAL to biblioteka konwertująca między formatami rastrowych danych
159 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
160 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
161 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
162 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
163 możliwości dla danych wektorowych.
164
165 %package devel
166 Summary:        GDAL library header files
167 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
168 Group:          Development/Libraries
169 Requires:       %{name} = %{version}-%{release}
170 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
171 %{?with_armadillo:Requires:     armadillo-devel}
172 Requires:       cfitsio-devel
173 %{?with_dds:Requires:   crnlib-devel}
174 Requires:       curl-devel
175 %{?with_epsilon:Requires:       epsilon-compressor-devel}
176 %{?with_fyba:Requires:  fyba-devel}
177 Requires:       expat-devel >= 1.95.0
178 Requires:       freexl-devel >= 1.0
179 Requires:       geos-devel >= 3.1.0
180 Requires:       giflib-devel >= 4.0
181 Requires:       hdf-devel >= 4.0
182 Requires:       hdf5-devel
183 Requires:       jasper-devel
184 Requires:       json-c-devel >= 0.11
185 Requires:       libcsf-devel
186 Requires:       libdap-devel >= 3.10
187 Requires:       libgeotiff-devel >= 1.2.1
188 %{?with_gta:Requires:   libgta-devel}
189 Requires:       libjpeg-devel >= 6b
190 Requires:       libpng-devel >= 2:1.2.8
191 %{?with_spatialite:Requires:    libspatialite-devel}
192 Requires:       libstdc++-devel
193 Requires:       libtiff-devel >= 4.0
194 Requires:       libuuid-devel
195 Requires:       libwebp-devel
196 Requires:       libxml2-devel >= 2
197 %{?with_mysql:Requires: mysql-devel}
198 Requires:       netcdf-devel >= 4
199 Requires:       ogdi-devel >= 3.1
200 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
201 #Requires:      pcidsk-devel > 0.3
202 %{?with_podofo:Requires:        podofo-devel}
203 %{?with_poppler:Requires:       poppler-devel >= 0.24}
204 Requires:       postgresql-devel
205 Requires:       proj-devel >= 4
206 %{?with_rasdaman:Requires:      rasdaman-devel}
207 Requires:       sqlite3-devel >= 3.0.0
208 %{?with_odbc:Requires:  unixODBC-devel}
209 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
210 Requires:       xz-devel
211 Requires:       zlib-devel >= 1.1.4
212
213 %description devel
214 GDAL library header files.
215
216 %description devel -l pl.UTF-8
217 Pliki nagłówkowe biblioteki GDAL.
218
219 %package static
220 Summary:        GDAL static libraries
221 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
222 Group:          Development/Libraries
223 Requires:       %{name}-devel = %{version}-%{release}
224
225 %description static
226 GDAL static libraries.
227
228 %description static -l pl.UTF-8
229 Statyczne biblioteki GDAL.
230
231 %package -n perl-gdal
232 Summary:        Perl bindings for GDAL
233 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
234 Group:          Development/Languages/Perl
235 Requires:       %{name} = %{version}-%{release}
236
237 %description -n perl-gdal
238 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
239
240 %description -n perl-gdal -l pl.UTF-8
241 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
242
243 %package -n php-gdal
244 Summary:        PHP bindings for GDAL library
245 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
246 Group:          Development/Languages/PHP
247 Requires:       %{name} = %{version}-%{release}
248 %{?requires_php_extension}
249
250 %description -n php-gdal
251 PHP bindings for GDAL library
252
253 %description -n php-gdal -l pl.UTF-8
254 Wiązania PHP do biblioteki GDAL.
255
256 %package -n python-gdal
257 Summary:        GDAL Python module
258 Summary(pl.UTF-8):      Moduł Pythona GDAL
259 Group:          Libraries/Python
260 Requires:       %{name} = %{version}-%{release}
261 Requires:       python-libs
262
263 %description -n python-gdal
264 GDAL Python module.
265
266 %description -n python-gdal -l pl.UTF-8
267 Moduł Pythona GDAL.
268
269 %package -n ruby-gdal
270 Summary:        Ruby bindings for GDAL
271 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
272 Group:          Development/Languages
273 Requires:       %{name} = %{version}-%{release}
274
275 %description -n ruby-gdal
276 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
277
278 %description -n ruby-gdal -l pl.UTF-8
279 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
280 osr.
281
282 %prep
283 %setup -q
284 %patch0 -p1
285 %patch1 -p1
286 %patch2 -p1
287 %patch3 -p1
288 %patch4 -p1
289 %patch5 -p1
290 %patch6 -p1
291 %patch7 -p1
292 %patch8 -p1
293 %patch9 -p1
294 %patch10 -p1
295 %patch11 -p1
296 %patch12 -p1
297 %patch13 -p1
298
299 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
300 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
301
302 %{__sed} -i \
303         -e 's/^CC=gcc/CC=%{__cc}/' \
304         -e 's/^CXX=g++/CXX=%{__cxx}/' \
305         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
306         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
307         swig/php/GNUmakefile
308 # Build with fPIC to allow Ruby bindings
309 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
310 # http://trac.osgeo.org/gdal/ticket/1994
311 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
312 # Install Ruby bindings to distribution specific directory
313 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
314
315 # Install Ruby bindings into the proper place
316 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
317 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
318
319 # our man path
320 sed -i -e 's#^mandir=.*##g' configure.in
321
322 %{__rm} -r man
323
324 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
325
326 %build
327 %{__libtoolize}
328 %{__aclocal} -I m4
329 %{__autoconf}
330 %configure \
331         --datadir=%{_datadir}/gdal \
332         --with-dods-root=/usr \
333         %{?with_armadillo:--with-armadillo} \
334         %{?with_crnlib:--with-dds} \
335         %{?with_epsilon:--with-epsilon} \
336         %{?with_grass:--with-grass} \
337         %{!?with_gta:--without-gta} \
338         --with-hide-internal-symbols \
339         %{?with_java:--with-java=%{java_home}} \
340         --with-liblzma \
341         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
342         %{?with_mysql:--with-mysql} \
343         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
344         %{?with_opencl:--with-opencl} \
345         --with-perl \
346         %{?with_php:--with-php} \
347         %{?with_podofo:--with-podofo} \
348         %{?with_poppler:--with-poppler} \
349         --with-python \
350         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
351         %{?with_ruby:--with-ruby} \
352         %{?with_fyba:--with-sosi} \
353         %{?with_spatialite:--with-spatialite} \
354         --with-sqlite3 \
355         --with-webp \
356         %{?with_xerces:--with-xerces} \
357         --with-xerces-inc=/usr/include/xercesc \
358         --with-xerces-lib="-lxerces-c" \
359         --without-libgrass
360 #       --with-pcidsk=/usr (needs > 0.3)
361 # csharp builds, but has no configure option nor install target
362
363 # regenerate where needed
364 %{__make} -j1 -C swig/perl generate
365 %if %{with ruby}
366 %{__make} -j1 -C swig/ruby generate
367 %endif
368
369 %{__make} -j1 \
370         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
371         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
372
373 %{__make} -j1 docs
374
375 %{__make} -j1 man
376
377 %install
378 rm -rf $RPM_BUILD_ROOT
379
380 %{__make} -j1 install install-man \
381         DESTDIR=$RPM_BUILD_ROOT
382
383 rm -rf _html
384 cp -a html _html
385 cp -a ogr/html _html/ogr
386
387 %if %{with php}
388 # missing in make install
389 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
390 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
391 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
392 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
393 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
394 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
395 ; Enable gdal extension module
396 extension=gdal.so
397 extension=gdalconst.so
398 extension=ogr.so
399 extension=osr.so
400 EOF
401 %endif
402
403 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
404 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
405 %py_postclean
406
407 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
408 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
409 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
410 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
411 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
412
413 # some doxygen trash
414 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
415 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
416
417 %clean
418 rm -rf $RPM_BUILD_ROOT
419
420 %post   -p /sbin/ldconfig
421 %postun -p /sbin/ldconfig
422
423 %files
424 %defattr(644,root,root,755)
425 %doc NEWS PROVENANCE.TXT
426 %attr(755,root,root) %{_bindir}/epsg_tr.py
427 %attr(755,root,root) %{_bindir}/esri2wkt.py
428 %attr(755,root,root) %{_bindir}/gcps2vec.py
429 %attr(755,root,root) %{_bindir}/gcps2wld.py
430 %attr(755,root,root) %{_bindir}/gdal2tiles.py
431 %attr(755,root,root) %{_bindir}/gdal2xyz.py
432 %attr(755,root,root) %{_bindir}/gdal_auth.py
433 %attr(755,root,root) %{_bindir}/gdal_contour
434 %attr(755,root,root) %{_bindir}/gdal_calc.py
435 %attr(755,root,root) %{_bindir}/gdal_edit.py
436 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
437 %attr(755,root,root) %{_bindir}/gdal_grid
438 %attr(755,root,root) %{_bindir}/gdal_merge.py
439 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
440 %attr(755,root,root) %{_bindir}/gdal_proximity.py
441 %attr(755,root,root) %{_bindir}/gdal_rasterize
442 %attr(755,root,root) %{_bindir}/gdal_retile.py
443 %attr(755,root,root) %{_bindir}/gdal_sieve.py
444 %attr(755,root,root) %{_bindir}/gdal_translate
445 %attr(755,root,root) %{_bindir}/gdaladdo
446 %attr(755,root,root) %{_bindir}/gdalbuildvrt
447 %attr(755,root,root) %{_bindir}/gdalchksum.py
448 %attr(755,root,root) %{_bindir}/gdalcompare.py
449 %attr(755,root,root) %{_bindir}/gdaldem
450 %attr(755,root,root) %{_bindir}/gdalenhance
451 %attr(755,root,root) %{_bindir}/gdalident.py
452 %attr(755,root,root) %{_bindir}/gdalimport.py
453 %attr(755,root,root) %{_bindir}/gdalinfo
454 %attr(755,root,root) %{_bindir}/gdallocationinfo
455 %attr(755,root,root) %{_bindir}/gdalmanage
456 %attr(755,root,root) %{_bindir}/gdalmove.py
457 %attr(755,root,root) %{_bindir}/gdalserver
458 %attr(755,root,root) %{_bindir}/gdalsrsinfo
459 %attr(755,root,root) %{_bindir}/gdaltindex
460 %attr(755,root,root) %{_bindir}/gdaltransform
461 %attr(755,root,root) %{_bindir}/gdalwarp
462 %attr(755,root,root) %{_bindir}/mkgraticule.py
463 %attr(755,root,root) %{_bindir}/nearblack
464 %attr(755,root,root) %{_bindir}/ogr2ogr
465 %attr(755,root,root) %{_bindir}/ogrinfo
466 %attr(755,root,root) %{_bindir}/ogrlineref
467 %attr(755,root,root) %{_bindir}/ogrtindex
468 %attr(755,root,root) %{_bindir}/pct2rgb.py
469 %attr(755,root,root) %{_bindir}/rgb2pct.py
470 %attr(755,root,root) %{_bindir}/testepsg
471 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
472 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
473 %{_datadir}/gdal
474 %{_mandir}/man1/gdal2tiles.1*
475 %{_mandir}/man1/gdal_calc.1*
476 %{_mandir}/man1/gdal_contour.1*
477 %{_mandir}/man1/gdal_edit.1*
478 %{_mandir}/man1/gdal_fillnodata.1*
479 %{_mandir}/man1/gdal_grid.1*
480 %{_mandir}/man1/gdal_merge.1*
481 %{_mandir}/man1/gdal_polygonize.1*
482 %{_mandir}/man1/gdal_proximity.1*
483 %{_mandir}/man1/gdal_rasterize.1*
484 %{_mandir}/man1/gdal_retile.1*
485 %{_mandir}/man1/gdal_sieve.1*
486 %{_mandir}/man1/gdal_translate.1*
487 %{_mandir}/man1/gdal_utilities.1*
488 %{_mandir}/man1/gdaladdo.1*
489 %{_mandir}/man1/gdalbuildvrt.1*
490 %{_mandir}/man1/gdalcompare.1*
491 %{_mandir}/man1/gdaldem.1*
492 %{_mandir}/man1/gdalinfo.1*
493 %{_mandir}/man1/gdallocationinfo.1*
494 %{_mandir}/man1/gdalmanage.1*
495 %{_mandir}/man1/gdalmove.1*
496 %{_mandir}/man1/gdalsrsinfo.1*
497 %{_mandir}/man1/gdaltindex.1*
498 %{_mandir}/man1/gdaltransform.1*
499 %{_mandir}/man1/gdalwarp.1*
500 %{_mandir}/man1/nearblack.1*
501 %{_mandir}/man1/ogr2ogr.1*
502 %{_mandir}/man1/ogr_utilities.1*
503 %{_mandir}/man1/ogrinfo.1*
504 %{_mandir}/man1/ogrlineref.1*
505 %{_mandir}/man1/ogrtindex.1*
506 %{_mandir}/man1/pct2rgb.1*
507 %{_mandir}/man1/rgb2pct.1*
508
509 %files devel
510 %defattr(644,root,root,755)
511 %doc _html/*
512 %attr(755,root,root) %{_bindir}/gdal-config
513 %attr(755,root,root) %{_libdir}/libgdal.so
514 %{_libdir}/libgdal.la
515 %{_pkgconfigdir}/gdal.pc
516 %{_includedir}/cpl_*.h
517 %{_includedir}/cplkeywordparser.h
518 %{_includedir}/gdal*.h
519 %{_includedir}/gvgcpfit.h
520 %{_includedir}/memdataset.h
521 %{_includedir}/ogr_*.h
522 %{_includedir}/ogrsf_frmts.h
523 %{_includedir}/rawdataset.h
524 %{_includedir}/thinplatespline.h
525 %{_includedir}/vrtdataset.h
526 %{_mandir}/man1/gdal-config.1*
527
528 %files static
529 %defattr(644,root,root,755)
530 %{_libdir}/libgdal.a
531
532 %files -n perl-gdal
533 %defattr(644,root,root,755)
534 %dir %{perl_vendorarch}/Geo
535 %{perl_vendorarch}/Geo/GDAL.pm
536 %dir %{perl_vendorarch}/Geo/GDAL
537 %{perl_vendorarch}/Geo/GDAL/Const.pm
538 %{perl_vendorarch}/Geo/OGR.pm
539 %{perl_vendorarch}/Geo/OSR.pm
540 %dir %{perl_vendorarch}/auto/Geo
541 %dir %{perl_vendorarch}/auto/Geo/GDAL
542 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
543 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
544 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
545 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
546 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
547 %dir %{perl_vendorarch}/auto/Geo/OGR
548 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
549 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
550 %dir %{perl_vendorarch}/auto/Geo/OSR
551 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
552 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
553
554 %if %{with php}
555 %files -n php-gdal
556 %defattr(644,root,root,755)
557 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
558 %attr(755,root,root) %{php_extensiondir}/gdal.so
559 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
560 %attr(755,root,root) %{php_extensiondir}/ogr.so
561 %attr(755,root,root) %{php_extensiondir}/osr.so
562 %endif
563
564 %files -n python-gdal
565 %defattr(644,root,root,755)
566 %{py_sitedir}/gdal.py[co]
567 %{py_sitedir}/gdalconst.py[co]
568 %{py_sitedir}/gdalnumeric.py[co]
569 %{py_sitedir}/ogr.py[co]
570 %{py_sitedir}/osr.py[co]
571 %{py_sitedir}/GDAL-*.egg-info
572 %dir %{py_sitedir}/osgeo
573 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
574 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
575 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
576 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
577 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
578 %{py_sitedir}/osgeo/*.py[co]
579
580 %if %{with ruby}
581 %files -n ruby-gdal
582 %defattr(644,root,root,755)
583 %dir %{ruby_vendorarchdir}/gdal
584 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
585 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
586 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
587 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
588 %endif
This page took 1.236753 seconds and 4 git commands to generate.