]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- release 6
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - spatialite (--with-spatialite; libspatialite: http://www.gaia-gis.it/gaia-sins/)
6 # - freexl (http://www.gaia-gis.it/FreeXL/)
7 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
8 # - armadillo (--with-armadillo; http://arma.sourceforge.net/)
9 # - openjpeg (unreleased post-1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.5)
10 # - libjpeg12 (needs patching to use system one)
11 # - libkml (1.3.0 needed, not released yet)
12 # - wait for newer pcidsk, switch to external again
13 # - csharp, java, mysql
14 # - additional, proprietary(?) formats support:
15 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
16 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
17 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
18 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
19 #   - MrSID (http://www.lizardtech.com/developer/)
20 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
21 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
22 #   - Ingres (--with-ingres=/path)
23 #   - Informix DB
24 #   - DWGdirect (members only? http://www.opendwg.org/)
25 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
26 #   - OpenCL (--with-opencl; no free Linux implementation yet?)
27 #
28 # Conditional build:
29 %bcond_without  epsilon # EPSILON wavelet compression support
30 %bcond_without  gta     # GTA format support
31 %bcond_without  odbc    # disable ODBC DB support
32 %bcond_with     podofo  # PDF support via podofo instead of poppler
33 %bcond_without  poppler # PDF support via poppler
34 %bcond_without  xerces  # disable xerces support
35 %bcond_without  java    # disable Java and MDB support
36 %bcond_without  php     # disable PHP binding
37 %bcond_without  ruby    # disable ruby binding
38 #
39 %if %{with podofo}
40 %undefine       with_poppler
41 %endif
42 Summary:        Geospatial Data Abstraction Library
43 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
44 Name:           gdal
45 Version:        1.9.0
46 Release:        6
47 License:        BSD-like
48 Group:          Libraries
49 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
50 # Source0-md5:  1853f3d8eb5232ae030abe007840cade
51 Patch0:         %{name}-perl.patch
52 Patch1:         %{name}-python_install.patch
53 Patch2:         %{name}-doxy.patch
54 Patch3:         %{name}-sh.patch
55 Patch4:         %{name}-php.patch
56 Patch5:         %{name}-fpic.patch
57 URL:            http://www.gdal.org/
58 BuildRequires:  autoconf >= 2.52
59 BuildRequires:  automake
60 BuildRequires:  cfitsio-devel
61 BuildRequires:  curl-devel
62 BuildRequires:  doxygen >= 1.4.2
63 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
64 BuildRequires:  expat-devel >= 1.95.0
65 BuildRequires:  geos-devel >= 2.2.0
66 BuildRequires:  giflib-devel >= 4.0
67 BuildRequires:  hdf-devel >= 4.0
68 BuildRequires:  hdf5-devel
69 BuildRequires:  jasper-devel
70 %{?with_java:BuildRequires:     jdk}
71 %{?with_java:BuildRequires:     jpackage-utils}
72 BuildRequires:  libcsf-devel
73 BuildRequires:  libdap-devel >= 3.10
74 BuildRequires:  libgeotiff-devel >= 1.2.1
75 %{?with_gta:BuildRequires:      libgta-devel}
76 BuildRequires:  libjpeg-devel >= 6b
77 #BuildRequires: libkml-devel >= 1.3.0
78 BuildRequires:  libpng-devel >= 2:1.2.8
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  libtiff-devel >= 4.0
81 BuildRequires:  libtool
82 BuildRequires:  libuuid-devel
83 BuildRequires:  libwebp-devel
84 BuildRequires:  libxml2-devel
85 BuildRequires:  netcdf-devel >= 4
86 BuildRequires:  ogdi-devel >= 3.1
87 #BuildRequires: pcidsk-devel > 0.3
88 BuildRequires:  perl-devel
89 %{?with_php:BuildRequires:      php-devel}
90 %{?with_podofo:BuildRequires:   podofo-devel}
91 %{?with_poppler:BuildRequires:  poppler-devel}
92 # ensure it's compiled with PQescapeStringConn support
93 BuildRequires:  postgresql-backend-devel >= 8.1.4
94 BuildRequires:  postgresql-devel >= 8.1.4
95 BuildRequires:  proj-devel >= 4
96 BuildRequires:  python-devel >= 1:2.5
97 BuildRequires:  python-numpy-devel >= 1:1.0.0
98 BuildRequires:  python-setuptools
99 BuildRequires:  rpm-pythonprov
100 BuildRequires:  rpmbuild(macros) >= 1.344
101 %{?with_ruby:BuildRequires:     ruby-devel}
102 BuildRequires:  sed >= 4.0
103 BuildRequires:  sqlite3-devel >= 3.0.0
104 BuildRequires:  swig-perl
105 BuildRequires:  swig-python >= 1.3
106 %{?with_ruby:BuildRequires:     swig-ruby}
107 %if "%{pld_release}" == "ti"
108 BuildRequires:  tetex-format-latex
109 BuildRequires:  tetex-dvips
110 %else
111 BuildRequires:  texlive-dvips
112 BuildRequires:  texlive-latex
113 %endif
114 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
115 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
116 BuildRequires:  xz-devel
117 BuildRequires:  zlib-devel >= 1.1.4
118 Requires:       geos >= 2.2.0
119 Requires:       libgeotiff >= 1.2.1
120 Requires:       libpng >= 2:1.2.8
121 Requires:       libtiff >= 4.0
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %description
125 GDAL is a translator library for raster geospatial data formats that
126 is released under an Open Source license. As a library, it presents a
127 single abstract data model to the calling application for all
128 supported formats. The related OGR library (which lives within the
129 GDAL source tree) provides a similar capability for simple features
130 vector data.
131
132 %description -l pl.UTF-8
133 GDAL to biblioteka konwertująca między formatami rastrowych danych
134 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
135 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
136 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
137 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
138 możliwości dla danych wektorowych.
139
140 %package devel
141 Summary:        GDAL library header files
142 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
143 Group:          Development/Libraries
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       cfitsio-devel
146 Requires:       curl-devel
147 %{?with_epsilon:Requires:       epsilon-compressor-devel}
148 Requires:       expat-devel >= 1.95.0
149 Requires:       geos-devel >= 2.2.0
150 Requires:       giflib-devel >= 4.0
151 Requires:       hdf-devel >= 4.0
152 Requires:       hdf5-devel
153 Requires:       jasper-devel
154 Requires:       libcsf-devel
155 Requires:       libdap-devel >= 3.10
156 Requires:       libgeotiff-devel >= 1.2.1
157 %{?with_gta:Requires:   libgta-devel}
158 Requires:       libjpeg-devel >= 6b
159 Requires:       libpng-devel >= 2:1.2.8
160 Requires:       libstdc++-devel
161 Requires:       libtiff-devel >= 4.0
162 Requires:       libuuid-devel
163 Requires:       libwebp-devel
164 Requires:       libxml2-devel
165 Requires:       netcdf-devel >= 4
166 Requires:       ogdi-devel >= 3.1
167 #Requires:      pcidsk-devel > 0.3
168 %{?with_podofo:Requires:        podofo-devel}
169 %{?with_poppler:Requires:       poppler-devel}
170 Requires:       postgresql-devel
171 Requires:       proj-devel >= 4
172 Requires:       sqlite3-devel >= 3.0.0
173 %{?with_odbc:Requires:  unixODBC-devel}
174 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
175 Requires:       xz-devel
176 Requires:       zlib-devel >= 1.1.4
177
178 %description devel
179 GDAL library header files.
180
181 %description devel -l pl.UTF-8
182 Pliki nagłówkowe biblioteki GDAL.
183
184 %package static
185 Summary:        GDAL static libraries
186 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
187 Group:          Development/Libraries
188 Requires:       %{name}-devel = %{version}-%{release}
189
190 %description static
191 GDAL static libraries.
192
193 %description static -l pl.UTF-8
194 Statyczne biblioteki GDAL.
195
196 %package -n perl-gdal
197 Summary:        Perl bindings for GDAL
198 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
199 Group:          Development/Languages/Perl
200 Requires:       %{name} = %{version}-%{release}
201
202 %description -n perl-gdal
203 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
204
205 %description -n perl-gdal -l pl.UTF-8
206 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
207
208 %package -n php-gdal
209 Summary:        PHP bindings for GDAL library
210 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
211 Group:          Development/Languages/PHP
212 Requires:       %{name} = %{version}-%{release}
213 %{?requires_php_extension}
214
215 %description -n php-gdal
216 PHP bindings for GDAL library
217
218 %description -n php-gdal -l pl.UTF-8
219 Wiązania PHP do biblioteki GDAL.
220
221 %package -n python-gdal
222 Summary:        GDAL Python module
223 Summary(pl.UTF-8):      Moduł Pythona GDAL
224 Group:          Libraries/Python
225 Requires:       %{name} = %{version}-%{release}
226 %pyrequires_eq  python-libs
227
228 %description -n python-gdal
229 GDAL Python module.
230
231 %description -n python-gdal -l pl.UTF-8
232 Moduł Pythona GDAL.
233
234 %package -n ruby-gdal
235 Summary:        Ruby bindings for GDAL
236 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
237 Group:          Development/Languages
238 Requires:       %{name} = %{version}-%{release}
239 %{?ruby_mod_ver_requires_eq}
240
241 %description -n ruby-gdal
242 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
243
244 %description -n ruby-gdal -l pl.UTF-8
245 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
246 osr.
247
248 %prep
249 %setup -q
250 %patch0 -p1
251 %patch1 -p1
252 %patch2 -p1
253 %patch3 -p1
254 %patch4 -p1
255 %patch5 -p1
256
257 # need to regenerate (old ones don't support perl 5.10)
258 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
259
260 %{__rm} -r man
261
262 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
263
264 %build
265 %{__libtoolize}
266 %{__aclocal} -I m4
267 %{__autoconf}
268 # disable grass/libgrass here, it can be built from separate gdal-grass package
269 %configure \
270         --datadir=%{_datadir}/gdal \
271         --with-dods-root=/usr \
272         %{?with_epsilon:--with-epsilon} \
273         %{!?with_gta:--without-gta} \
274         --with-hide-internal-symbols \
275         %{?with_java:--with-java=%{java_home}} \
276         --with-liblzma \
277         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
278         --with-perl \
279         %{?with_php:--with-php} \
280         %{?with_podofo:--with-podofo} \
281         %{?with_poppler:--with-poppler} \
282         --with-python \
283         %{?with_ruby:--with-ruby} \
284         --with-sqlite3 \
285         --with-webp \
286         %{?with_xerces:--with-xerces} \
287         --with-xerces-inc=/usr/include/xercesc \
288         --with-xerces-lib="-lxerces-c" \
289         --without-grass \
290         --without-libgrass
291 #       --with-pcidsk=/usr (needs > 0.3)
292 # csharp builds, but has no configure option
293
294 # regenerate where needed
295 %{__make} -j1 -C swig/perl generate
296 %{?with_ruby:%{__make} -j1 -C swig/ruby generate}
297
298 %{__make} -j1
299
300 %{__make} -j1 docs
301
302 %{__make} -j1 man
303
304 %install
305 rm -rf $RPM_BUILD_ROOT
306
307 %{__make} -j1 install install-man \
308         DESTDIR=$RPM_BUILD_ROOT
309
310 rm -rf _html
311 cp -a html _html
312 cp -a ogr/html _html/ogr
313
314 %if %{with php}
315 # missing in make install
316 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
317 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
318 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
319 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
320 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
321 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
322 ; Enable gdal extension module
323 extension=gdal.so
324 extension=gdalconst.so
325 extension=ogr.so
326 extension=osr.so
327 EOF
328 %endif
329
330 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
331 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
332 %py_postclean
333
334 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
335 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
336 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
337 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
338 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
339
340 # some doxygen trash
341 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
342 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
343 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
344
345 %clean
346 rm -rf $RPM_BUILD_ROOT
347
348 %post   -p /sbin/ldconfig
349 %postun -p /sbin/ldconfig
350
351 %files
352 %defattr(644,root,root,755)
353 %doc NEWS PROVENANCE.TXT
354 %attr(755,root,root) %{_bindir}/epsg_tr.py
355 %attr(755,root,root) %{_bindir}/esri2wkt.py
356 %attr(755,root,root) %{_bindir}/gcps2vec.py
357 %attr(755,root,root) %{_bindir}/gcps2wld.py
358 %attr(755,root,root) %{_bindir}/gdal2tiles.py
359 %attr(755,root,root) %{_bindir}/gdal2xyz.py
360 %attr(755,root,root) %{_bindir}/gdal_contour
361 %attr(755,root,root) %{_bindir}/gdal_calc.py
362 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
363 %attr(755,root,root) %{_bindir}/gdal_grid
364 %attr(755,root,root) %{_bindir}/gdal_merge.py
365 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
366 %attr(755,root,root) %{_bindir}/gdal_proximity.py
367 %attr(755,root,root) %{_bindir}/gdal_rasterize
368 %attr(755,root,root) %{_bindir}/gdal_retile.py
369 %attr(755,root,root) %{_bindir}/gdal_sieve.py
370 %attr(755,root,root) %{_bindir}/gdal_translate
371 %attr(755,root,root) %{_bindir}/gdaladdo
372 %attr(755,root,root) %{_bindir}/gdalbuildvrt
373 %attr(755,root,root) %{_bindir}/gdalchksum.py
374 %attr(755,root,root) %{_bindir}/gdaldem
375 %attr(755,root,root) %{_bindir}/gdalenhance
376 %attr(755,root,root) %{_bindir}/gdalident.py
377 %attr(755,root,root) %{_bindir}/gdalimport.py
378 %attr(755,root,root) %{_bindir}/gdalinfo
379 %attr(755,root,root) %{_bindir}/gdallocationinfo
380 %attr(755,root,root) %{_bindir}/gdalmanage
381 %attr(755,root,root) %{_bindir}/gdalsrsinfo
382 %attr(755,root,root) %{_bindir}/gdaltindex
383 %attr(755,root,root) %{_bindir}/gdaltransform
384 %attr(755,root,root) %{_bindir}/gdalwarp
385 %attr(755,root,root) %{_bindir}/mkgraticule.py
386 %attr(755,root,root) %{_bindir}/nearblack
387 %attr(755,root,root) %{_bindir}/ogr2ogr
388 %attr(755,root,root) %{_bindir}/ogrinfo
389 %attr(755,root,root) %{_bindir}/ogrtindex
390 %attr(755,root,root) %{_bindir}/pct2rgb.py
391 %attr(755,root,root) %{_bindir}/rgb2pct.py
392 %attr(755,root,root) %{_bindir}/testepsg
393 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
394 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
395 %{_datadir}/gdal
396 %{_mandir}/man1/gdal2tiles.1*
397 %{_mandir}/man1/gdal_contour.1*
398 %{_mandir}/man1/gdal_fillnodata.1*
399 %{_mandir}/man1/gdal_grid.1*
400 %{_mandir}/man1/gdal_merge.1*
401 %{_mandir}/man1/gdal_rasterize.1*
402 %{_mandir}/man1/gdal_retile.1*
403 %{_mandir}/man1/gdal_sieve.1*
404 %{_mandir}/man1/gdal_translate.1*
405 %{_mandir}/man1/gdal_utilities.1*
406 %{_mandir}/man1/gdaladdo.1*
407 %{_mandir}/man1/gdalbuildvrt.1*
408 %{_mandir}/man1/gdaldem.1*
409 %{_mandir}/man1/gdalinfo.1*
410 %{_mandir}/man1/gdallocationinfo.1*
411 %{_mandir}/man1/gdalsrsinfo.1*
412 %{_mandir}/man1/gdaltindex.1*
413 %{_mandir}/man1/gdaltransform.1*
414 %{_mandir}/man1/gdalwarp.1*
415 %{_mandir}/man1/nearblack.1*
416 %{_mandir}/man1/ogr2ogr.1*
417 %{_mandir}/man1/ogr_utilities.1*
418 %{_mandir}/man1/ogrinfo.1*
419 %{_mandir}/man1/ogrtindex.1*
420 %{_mandir}/man1/pct2rgb.1*
421 %{_mandir}/man1/rgb2pct.1*
422
423 %files devel
424 %defattr(644,root,root,755)
425 %doc _html/*
426 %attr(755,root,root) %{_bindir}/gdal-config
427 %attr(755,root,root) %{_libdir}/libgdal.so
428 %{_libdir}/libgdal.la
429 %{_includedir}/cpl_*.h
430 %{_includedir}/cplkeywordparser.h
431 %{_includedir}/gdal*.h
432 %{_includedir}/gvgcpfit.h
433 %{_includedir}/memdataset.h
434 %{_includedir}/ogr_*.h
435 %{_includedir}/ogrsf_frmts.h
436 %{_includedir}/rawdataset.h
437 %{_includedir}/thinplatespline.h
438 %{_includedir}/vrtdataset.h
439 %{_mandir}/man1/gdal-config.1*
440
441 %files static
442 %defattr(644,root,root,755)
443 %{_libdir}/libgdal.a
444
445 %files -n perl-gdal
446 %defattr(644,root,root,755)
447 %dir %{perl_vendorarch}/Geo
448 %{perl_vendorarch}/Geo/GDAL.pm
449 %dir %{perl_vendorarch}/Geo/GDAL
450 %{perl_vendorarch}/Geo/GDAL/Const.pm
451 %{perl_vendorarch}/Geo/OGR.pm
452 %{perl_vendorarch}/Geo/OSR.pm
453 %dir %{perl_vendorarch}/auto/Geo
454 %dir %{perl_vendorarch}/auto/Geo/GDAL
455 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
456 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
457 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
458 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
459 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
460 %dir %{perl_vendorarch}/auto/Geo/OGR
461 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
462 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
463 %dir %{perl_vendorarch}/auto/Geo/OSR
464 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
465 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
466
467 %if %{with php}
468 %files -n php-gdal
469 %defattr(644,root,root,755)
470 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
471 %attr(755,root,root) %{php_extensiondir}/gdal.so
472 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
473 %attr(755,root,root) %{php_extensiondir}/ogr.so
474 %attr(755,root,root) %{php_extensiondir}/osr.so
475 %endif
476
477 %files -n python-gdal
478 %defattr(644,root,root,755)
479 %{py_sitedir}/gdal.py[co]
480 %{py_sitedir}/gdalconst.py[co]
481 %{py_sitedir}/gdalnumeric.py[co]
482 %{py_sitedir}/ogr.py[co]
483 %{py_sitedir}/osr.py[co]
484 %{py_sitedir}/GDAL-*.egg-info
485 %dir %{py_sitedir}/osgeo
486 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
487 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
488 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
489 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
490 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
491 %{py_sitedir}/osgeo/*.py[co]
492
493 %if %{with ruby}
494 %files -n ruby-gdal
495 %defattr(644,root,root,755)
496 %dir %{ruby_sitearchdir}/gdal
497 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
498 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
499 %attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
500 %attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
501 %endif
This page took 0.084894 seconds and 4 git commands to generate.