]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- release 5
[packages/gdal.git] / gdal.spec
1 # TODO: csharp, java, mysql
2 #       use external pcidsk (http://home.gdal.org/projects/pcidsk/)?
3 #
4 # Conditional build:
5 %bcond_without  odbc    # disable odbc support
6 %bcond_without  xerces  # disable xerces support
7 %bcond_without  ruby    # disable ruby support
8 #
9 Summary:        Geospatial Data Abstraction Library
10 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
11 Name:           gdal
12 Version:        1.7.2
13 Release:        5
14 License:        BSD-like
15 Group:          Libraries
16 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
17 # Source0-md5:  05351f8cb61761ae579667e24a297fe6
18 Patch0:         %{name}-perl.patch
19 Patch1:         %{name}-ruby.patch
20 Patch2:         %{name}-asneeded.patch
21 Patch3:         %{name}-python_install.patch
22 Patch4:         %{name}-libdap.patch
23 URL:            http://www.gdal.org/
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 BuildRequires:  cfitsio-devel
27 BuildRequires:  doxygen
28 BuildRequires:  expat-devel >= 1.95.0
29 BuildRequires:  geos-devel >= 2.2
30 BuildRequires:  giflib-devel >= 4.0
31 BuildRequires:  hdf-devel >= 4.0
32 BuildRequires:  hdf5-devel
33 BuildRequires:  jasper-devel
34 BuildRequires:  libcsf-devel
35 BuildRequires:  libdap-devel >= 3.10
36 BuildRequires:  libgeotiff-devel >= 1.2.1
37 BuildRequires:  libjpeg-devel >= 6b
38 BuildRequires:  libpng-devel >= 2:1.2.8
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtiff-devel >= 3.6.0
41 BuildRequires:  libtool
42 BuildRequires:  netcdf-devel
43 BuildRequires:  ogdi-devel >= 3.1
44 BuildRequires:  perl-devel
45 BuildRequires:  postgresql-backend-devel
46 BuildRequires:  postgresql-devel
47 BuildRequires:  proj-devel
48 BuildRequires:  python-devel >= 1:2.5
49 BuildRequires:  python-numpy-devel >= 1:1.0.0
50 BuildRequires:  rpm-pythonprov
51 %{?with_ruby:BuildRequires:     ruby-devel}
52 BuildRequires:  sqlite3-devel >= 3
53 BuildRequires:  swig-perl
54 BuildRequires:  swig-python >= 1.3
55 %{?with_ruby:BuildRequires:     swig-ruby}
56 %if "%{pld_release}" == "ti"
57 BuildRequires:  tetex-format-latex
58 BuildRequires:  tetex-dvips
59 %else
60 BuildRequires:  texlive-dvips
61 BuildRequires:  texlive-latex
62 %endif
63 %{?with_odbc:BuildRequires:     unixODBC-devel}
64 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.2.0}
65 BuildRequires:  zlib-devel >= 1.1.4
66 Requires:       geos >= 2.2
67 Requires:       libgeotiff >= 1.2.1
68 Requires:       libpng >= 2:1.2.8
69 Requires:       libtiff >= 3.6.0
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 GDAL is a translator library for raster geospatial data formats that
74 is released under an Open Source license. As a library, it presents a
75 single abstract data model to the calling application for all
76 supported formats. The related OGR library (which lives within the
77 GDAL source tree) provides a similar capability for simple features
78 vector data.
79
80 %description -l pl.UTF-8
81 GDAL to biblioteka konwertująca między formatami rastrowych danych
82 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
83 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
84 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
85 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
86 możliwości dla danych wektorowych.
87
88 %package devel
89 Summary:        GDAL library header files
90 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
91 Group:          Development/Libraries
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       cfitsio-devel
94 Requires:       expat-devel >= 1.95.0
95 Requires:       geos-devel >= 2.2
96 Requires:       giflib-devel
97 Requires:       hdf-devel >= 4.0
98 Requires:       hdf5-devel
99 Requires:       jasper-devel
100 Requires:       libcsf-devel
101 Requires:       libdap-devel >= 3.10
102 Requires:       libgeotiff-devel >= 1.2.1
103 Requires:       libjpeg-devel
104 Requires:       libpng-devel >= 2:1.2.8
105 Requires:       libstdc++-devel
106 Requires:       libtiff-devel >= 3.6.0
107 Requires:       netcdf-devel
108 Requires:       ogdi-devel >= 3.1
109 Requires:       postgresql-devel
110 Requires:       sqlite3-devel >= 3
111 %{?with_odbc:Requires:  unixODBC-devel}
112 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
113
114 %description devel
115 GDAL library header files.
116
117 %description devel -l pl.UTF-8
118 Pliki nagłówkowe biblioteki GDAL.
119
120 %package static
121 Summary:        GDAL static libraries
122 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
123 Group:          Development/Libraries
124 Requires:       %{name}-devel = %{version}-%{release}
125
126 %description static
127 GDAL static libraries.
128
129 %description static -l pl.UTF-8
130 Statyczne biblioteki GDAL.
131
132 %package -n perl-gdal
133 Summary:        Perl bindings for GDAL
134 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
135 Group:          Development/Languages/Perl
136 Requires:       %{name} = %{version}-%{release}
137
138 %description -n perl-gdal
139 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
140
141 %description -n perl-gdal -l pl.UTF-8
142 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
143
144 %package -n python-gdal
145 Summary:        GDAL Python module
146 Summary(pl.UTF-8):      Moduł Pythona GDAL
147 Group:          Libraries/Python
148 Requires:       %{name} = %{version}-%{release}
149 %pyrequires_eq  python-libs
150
151 %description -n python-gdal
152 GDAL Python module.
153
154 %description -n python-gdal -l pl.UTF-8
155 Moduł Pythona GDAL.
156
157 %package -n ruby-gdal
158 Summary:        Ruby bindings for GDAL
159 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
160 Group:          Development/Languages
161 Requires:       %{name} = %{version}-%{release}
162 %{?ruby_mod_ver_requires_eq}
163
164 %description -n ruby-gdal
165 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
166
167 %description -n ruby-gdal -l pl.UTF-8
168 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
169 osr.
170
171 %prep
172 %setup -q
173 %patch0 -p1
174 %patch1 -p1
175 %patch2 -p1
176 %patch3 -p1
177 %patch4 -p1
178
179 # need to regenerate (old ones don't support perl 5.10)
180 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
181 # includes updated for Ruby 1.9
182 %{__rm} swig/ruby/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
183
184 %{__rm} -r man
185
186 %build
187 # $PYTHON_INCLUDES is set only with --with-ogpython, but we have --with-python,
188 # and $PYTHON_INCLUDES is needed to detect numpy properly
189 export PYTHON_INCLUDES=-I%{py_incdir}
190
191 %{__libtoolize}
192 cp -f /usr/share/automake/config.* .
193 %{__aclocal} -I m4
194 %{__autoconf}
195 # disable grass/libgrass here, it can be built from separate gdal-grass package
196 %configure \
197         --datadir=%{_datadir}/gdal \
198         --with-dods-root=/usr \
199         --with-hide-internal-symbols \
200         --with-perl \
201         --with-python \
202         %{?with_ruby:--with-ruby} \
203         --with-sqlite3 \
204         %{?with_xerces:--with-xerces} \
205         --with-xerces-inc=/usr/include/xercesc \
206         --with-xerces-lib="-lxerces-c" \
207         --without-grass \
208         --without-libgrass
209 # --with-php needs Zend API update
210 # java broken, no configure option
211 # csharp builds, but has no configure option
212
213 # regenerate where needed
214 %{__make} -j1 -C swig/perl generate
215 %{?with_ruby:%{__make} -j1 -C swig/ruby generate}
216
217 %{__make} -j1
218
219 %{__make} -j1 docs
220
221 %{__make} -j1 man
222
223 %install
224 rm -rf $RPM_BUILD_ROOT
225
226 %{__make} -j1 install install-man \
227         DESTDIR=$RPM_BUILD_ROOT
228
229 rm -rf _html
230 cp -a html _html
231 cp -a ogr/html _html/ogr
232
233 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
234 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
235 %py_postclean
236
237 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
238 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
239 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
240 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
241 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
242
243 # some doxygen trash
244 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL.dox
245 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL/Const.dox
246 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OGR.dox
247 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OSR.dox
248
249 %if %{with ruby}
250 %{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/gdal/*.la
251 %endif
252
253 %clean
254 rm -rf $RPM_BUILD_ROOT
255
256 %post   -p /sbin/ldconfig
257 %postun -p /sbin/ldconfig
258
259 %files
260 %defattr(644,root,root,755)
261 %doc NEWS PROVENANCE.TXT
262 %attr(755,root,root) %{_bindir}/epsg_tr.py
263 %attr(755,root,root) %{_bindir}/esri2wkt.py
264 %attr(755,root,root) %{_bindir}/gcps2vec.py
265 %attr(755,root,root) %{_bindir}/gcps2wld.py
266 %attr(755,root,root) %{_bindir}/gdal2tiles.py
267 %attr(755,root,root) %{_bindir}/gdal2xyz.py
268 %attr(755,root,root) %{_bindir}/gdal_contour
269 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
270 %attr(755,root,root) %{_bindir}/gdal_grid
271 %attr(755,root,root) %{_bindir}/gdal_merge.py
272 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
273 %attr(755,root,root) %{_bindir}/gdal_proximity.py
274 %attr(755,root,root) %{_bindir}/gdal_rasterize
275 %attr(755,root,root) %{_bindir}/gdal_retile.py
276 %attr(755,root,root) %{_bindir}/gdal_sieve.py
277 %attr(755,root,root) %{_bindir}/gdal_translate
278 %attr(755,root,root) %{_bindir}/gdaladdo
279 %attr(755,root,root) %{_bindir}/gdalbuildvrt
280 %attr(755,root,root) %{_bindir}/gdalchksum.py
281 %attr(755,root,root) %{_bindir}/gdaldem
282 %attr(755,root,root) %{_bindir}/gdalenhance
283 %attr(755,root,root) %{_bindir}/gdalident.py
284 %attr(755,root,root) %{_bindir}/gdalimport.py
285 %attr(755,root,root) %{_bindir}/gdalinfo
286 %attr(755,root,root) %{_bindir}/gdalmanage
287 %attr(755,root,root) %{_bindir}/gdaltindex
288 %attr(755,root,root) %{_bindir}/gdaltransform
289 %attr(755,root,root) %{_bindir}/gdalwarp
290 %attr(755,root,root) %{_bindir}/mkgraticule.py
291 %attr(755,root,root) %{_bindir}/nearblack
292 %attr(755,root,root) %{_bindir}/ogr2ogr
293 %attr(755,root,root) %{_bindir}/ogrinfo
294 %attr(755,root,root) %{_bindir}/ogrtindex
295 %attr(755,root,root) %{_bindir}/pct2rgb.py
296 %attr(755,root,root) %{_bindir}/rgb2pct.py
297 %attr(755,root,root) %{_bindir}/testepsg
298 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
299 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
300 %{_datadir}/gdal
301 %{_mandir}/man1/gdal2tiles.1*
302 %{_mandir}/man1/gdal_contour.1*
303 %{_mandir}/man1/gdal_fillnodata.1*
304 %{_mandir}/man1/gdal_grid.1*
305 %{_mandir}/man1/gdal_merge.1*
306 %{_mandir}/man1/gdal_rasterize.1*
307 %{_mandir}/man1/gdal_retile.1*
308 %{_mandir}/man1/gdal_sieve.1*
309 %{_mandir}/man1/gdal_translate.1*
310 %{_mandir}/man1/gdal_utilities.1*
311 %{_mandir}/man1/gdaladdo.1*
312 %{_mandir}/man1/gdalbuildvrt.1*
313 %{_mandir}/man1/gdaldem.1*
314 %{_mandir}/man1/gdalinfo.1*
315 %{_mandir}/man1/gdaltindex.1*
316 %{_mandir}/man1/gdaltransform.1*
317 %{_mandir}/man1/gdalwarp.1*
318 %{_mandir}/man1/nearblack.1*
319 %{_mandir}/man1/ogr2ogr.1*
320 %{_mandir}/man1/ogr_utilities.1*
321 %{_mandir}/man1/ogrinfo.1*
322 %{_mandir}/man1/ogrtindex.1*
323 %{_mandir}/man1/pct2rgb.1*
324 %{_mandir}/man1/rgb2pct.1*
325
326 %files devel
327 %defattr(644,root,root,755)
328 %doc _html/*
329 %attr(755,root,root) %{_bindir}/gdal-config
330 %attr(755,root,root) %{_libdir}/libgdal.so
331 %{_libdir}/libgdal.la
332 %{_includedir}/cpl_*.h
333 %{_includedir}/cplkeywordparser.h
334 %{_includedir}/gdal*.h
335 %{_includedir}/gvgcpfit.h
336 %{_includedir}/memdataset.h
337 %{_includedir}/ogr_*.h
338 %{_includedir}/ogrsf_frmts.h
339 %{_includedir}/rawdataset.h
340 %{_includedir}/thinplatespline.h
341 %{_includedir}/vrtdataset.h
342 %{_mandir}/man1/gdal-config.1*
343
344 %files static
345 %defattr(644,root,root,755)
346 %{_libdir}/libgdal.a
347
348 %files -n perl-gdal
349 %defattr(644,root,root,755)
350 %dir %{perl_vendorarch}/Geo
351 %{perl_vendorarch}/Geo/GDAL.pm
352 %dir %{perl_vendorarch}/Geo/GDAL
353 %{perl_vendorarch}/Geo/GDAL/Const.pm
354 %{perl_vendorarch}/Geo/OGR.pm
355 %{perl_vendorarch}/Geo/OSR.pm
356 %dir %{perl_vendorarch}/auto/Geo
357 %dir %{perl_vendorarch}/auto/Geo/GDAL
358 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
359 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
360 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
361 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
362 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
363 %dir %{perl_vendorarch}/auto/Geo/OGR
364 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
365 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
366 %dir %{perl_vendorarch}/auto/Geo/OSR
367 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
368 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
369
370 %files -n python-gdal
371 %defattr(644,root,root,755)
372 %{py_sitedir}/gdal.py[co]
373 %{py_sitedir}/gdalconst.py[co]
374 %{py_sitedir}/gdalnumeric.py[co]
375 %{py_sitedir}/ogr.py[co]
376 %{py_sitedir}/osr.py[co]
377 %{py_sitedir}/GDAL-*.egg-info
378 %dir %{py_sitedir}/osgeo
379 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
380 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
381 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
382 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
383 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
384 %{py_sitedir}/osgeo/*.py[co]
385
386 %if %{with ruby}
387 %files -n ruby-gdal
388 %defattr(644,root,root,755)
389 %dir %{ruby_sitearchdir}/gdal
390 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
391 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
392 %attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
393 %attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
394 %endif
This page took 0.077616 seconds and 4 git commands to generate.