]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- cxx.patch for compilation fix, rel 2
[packages/gdal.git] / gdal.spec
1 #
2 # TODO:
3 # - consider using GRASS (or GDAL in GRASS? build trap possible)
4 #
5 Summary:        Geospatial Data Abstraction Library
6 Summary(pl):    Biblioteka abstrakcji danych dotycz±cych powierzchni Ziemi
7 Name:           gdal
8 Version:        1.2.3
9 Release:        2
10 License:        BSD-like
11 Group:          Libraries
12 Source0:        ftp://ftp.remotesensing.org/pub/gdal/%{name}-%{version}.tar.gz
13 # Source0-md5:  6fe5b737e3ab323a34dea7578cc7fc9b
14 Patch0:         %{name}-pgsql.patch
15 Patch1:         %{name}-DESTDIR.patch
16 Patch2:         %{name}-cxx.patch
17 URL:            http://www.remotesensing.org/gdal/
18 BuildRequires:  autoconf
19 BuildRequires:  cfitsio-devel
20 BuildRequires:  doxygen
21 BuildRequires:  hdf-devel >= 4.0
22 BuildRequires:  jasper-devel
23 BuildRequires:  libgeotiff-devel >= 1.2.1
24 BuildRequires:  libjpeg-devel >= 6b
25 BuildRequires:  libpng-devel >= 1.0.6
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtiff-devel >= 3.6.0
28 BuildRequires:  libungif-devel >= 4.0
29 BuildRequires:  netcdf-devel
30 BuildRequires:  ogdi-devel >= 3.1
31 BuildRequires:  postgresql-devel
32 BuildRequires:  postgresql-backend-devel
33 BuildRequires:  python-devel
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  unixODBC-devel
36 BuildRequires:  xerces-c-devel >= 2.2.0
37 BuildRequires:  zlib-devel >= 1.1.4
38 Requires:       libgeotiff >= 1.2.1
39 Requires:       libtiff >= 3.6.0
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 GDAL is a translator library for raster geospatial data formats that
44 is released under an Open Source license. As a library, it presents a
45 single abstract data model to the calling application for all
46 supported formats. The related OGR library (which lives within the
47 GDAL source tree) provides a similar capability for simple features
48 vector data.
49
50 %description -l pl
51 GDAL to biblioteka konwertuj±ca miêdzy formatami rastrowych danych
52 dotycz±cych powierzchni Ziemi, udostêpniona na licencji Open Source.
53 Jako biblioteka udostêpnia aplikacjom jeden abstrakcyjny model danych
54 do wszystkich obs³ugiwanych formatów. Powi±zana z ni± biblioteka OGR
55 (której ¼ród³a s± do³±czone do drzewa ¼róde³ GDAL) daje podobne
56 mo¿liwo¶ci dla danych wektorowych.
57
58 %package devel
59 Summary:        GDAL library header files
60 Summary(pl):    Pliki nag³ówkowe biblioteki GDAL
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       cfitsio-devel
64 Requires:       hdf-devel >= 4.0
65 Requires:       jasper-devel
66 Requires:       libgeotiff-devel >= 1.2.1
67 Requires:       libjpeg-devel
68 Requires:       libpng-devel >= 1.0.6
69 Requires:       libstdc++-devel
70 Requires:       libtiff-devel >= 3.6.0
71 Requires:       libungif-devel
72 Requires:       netcdf-devel
73 Requires:       ogdi-devel >= 3.1
74 Requires:       postgresql-devel
75 Requires:       unixODBC-devel
76 Requires:       xerces-c-devel >= 2.2.0
77
78 %description devel
79 GDAL library header files.
80
81 %description devel -l pl
82 Pliki nag³ówkowe biblioteki GDAL.
83
84 %package static
85 Summary:        GDAL static libraries
86 Summary(pl):    Statyczne biblioteki GDAL
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 GDAL static libraries.
92
93 %description static -l pl
94 Statyczne biblioteki GDAL.
95
96 %package -n python-gdal
97 Summary:        GDAL Python module
98 Summary(pl):    Modu³ Pythona GDAL
99 Group:          Libraries/Python
100 Requires:       %{name} = %{version}-%{release}
101 %pyrequires_eq  python-libs
102
103 %description -n python-gdal
104 GDAL Python module.
105
106 %description -n python-gdal -l pl
107 Modu³ Pythona GDAL.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114
115 %{__perl} -pi -e "s@lib/python@%{_lib}/python@" aclocal.m4
116
117 %build
118 %{__autoconf}
119 %configure \
120         --datadir=%{_datadir}/gdal \
121         --with-pymoddir=%{py_sitedir} \
122         --with-xerces \
123         --with-xerces-inc=/usr/include/xercesc \
124         --with-xerces-lib="-lxerces-c" \
125         --without-grass
126
127 %{__make}
128
129 %{__make} docs
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 mv -f ogr/html html/org
138
139 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc ChangeLog NEWS
150 %attr(755,root,root) %{_bindir}/*
151 %exclude %{_bindir}/gdal-config
152 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
153 %{_datadir}/gdal
154 %{_mandir}/man1/*
155 %exclude %{_mandir}/man1/gdal-config.1*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %doc html/*
160 %attr(755,root,root) %{_bindir}/gdal-config
161 %attr(755,root,root) %{_libdir}/libgdal.so
162 %{_libdir}/libgdal.la
163 %{_includedir}/*.h
164 %{_mandir}/man1/gdal-config.1*
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/*.a
169
170 %files -n python-gdal
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
173 %{py_sitedir}/*.py
This page took 0.040898 seconds and 4 git commands to generate.