]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- updated to 1.2.1, added gcc patch
[packages/gdal.git] / gdal.spec
1 #
2 # TODO:
3 # - consider using GRASS (or GDAL in GRASS? build trap possible)
4 #
5 %include        /usr/lib/rpm/macros.python
6 Summary:        Geospatial Data Abstraction Library
7 Summary(pl):    Biblioteka abstrakcji danych dotycz±cych powierzchni Ziemi
8 Name:           gdal
9 Version:        1.2.1
10 Release:        1
11 License:        BSD-like
12 Group:          Libraries
13 Source0:        ftp://ftp.remotesensing.org/pub/gdal/%{name}-%{version}.tar.gz
14 # Source0-md5:  31f454e8f456bc6973ff652108b5f5e6
15 Patch0:         %{name}-pgsql.patch
16 Patch1:         %{name}-DESTDIR.patch
17 Patch2:         %{name}-gcc.patch
18 URL:            http://www.remotesensing.org/gdal/
19 BuildRequires:  autoconf
20 BuildRequires:  cfitsio-devel
21 BuildRequires:  doxygen
22 BuildRequires:  hdf-devel >= 4.0
23 BuildRequires:  jasper-devel
24 BuildRequires:  libgeotiff-devel >= 1.2.1
25 BuildRequires:  libjpeg-devel >= 6b
26 BuildRequires:  libpng-devel >= 1.0.6
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel >= 3.6.0
29 BuildRequires:  libungif-devel >= 4.0
30 BuildRequires:  netcdf-devel
31 BuildRequires:  ogdi-devel >= 3.1
32 BuildRequires:  postgresql-devel
33 BuildRequires:  postgresql-backend-devel
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  unixODBC-devel
37 BuildRequires:  xerces-c-devel >= 2.2.0
38 BuildRequires:  zlib-devel >= 1.1.4
39 Requires:       libgeotiff >= 1.2.1
40 Requires:       libtiff >= 3.6.0
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GDAL is a translator library for raster geospatial data formats that
45 is released under an Open Source license. As a library, it presents a
46 single abstract data model to the calling application for all
47 supported formats. The related OGR library (which lives within the
48 GDAL source tree) provides a similar capability for simple features
49 vector data.
50
51 %description -l pl
52 GDAL to biblioteka konwertuj±ca miêdzy formatami rastrowych danych
53 dotycz±cych powierzchni Ziemi, udostêpniona na licencji Open Source.
54 Jako biblioteka udostêpnia aplikacjom jeden abstrakcyjny model danych
55 do wszystkich obs³ugiwanych formatów. Powi±zana z nia biblioteka OGR
56 (której ¼ród³a s± do³±czone do drzewa ¼róde³ GDAL) daje podobne
57 mo¿liwo¶ci dla danych wektorowych.
58
59 %package devel
60 Summary:        GDAL library header files
61 Summary(pl):    Pliki nag³ówkowe biblioteki GDAL
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       cfitsio-devel
65 Requires:       hdf-devel >= 4.0
66 Requires:       jasper-devel
67 Requires:       libgeotiff-devel >= 1.2.1
68 Requires:       libjpeg-devel
69 Requires:       libpng-devel >= 1.0.6
70 Requires:       libstdc++-devel
71 Requires:       libtiff-devel >= 3.6.0
72 Requires:       libungif-devel
73 Requires:       netcdf-devel
74 Requires:       ogdi-devel >= 3.1
75 Requires:       postgresql-devel
76 Requires:       unixODBC-devel
77 Requires:       xerces-c-devel >= 2.2.0
78
79 %description devel
80 GDAL library header files.
81
82 %description devel -l pl
83 Pliki nag³ówkowe biblioteki GDAL.
84
85 %package static
86 Summary:        GDAL static libraries
87 Summary(pl):    Statyczne biblioteki GDAL
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 GDAL static libraries.
93
94 %description static -l pl
95 Statyczne biblioteki GDAL.
96
97 %package -n python-gdal
98 Summary:        GDAL Python module
99 Summary(pl):    Modu³ Pythona GDAL
100 Group:          Libraries/Python
101 Requires:       %{name} = %{version}-%{release}
102
103 %description -n python-gdal
104 GDAL Python module.
105
106 %description -n python-gdal -l pl
107 Modu³ Pythona GDAL.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114
115 %{__perl} -pi -e "s@lib/python@%{_lib}/python@" aclocal.m4
116
117 %build
118 %{__autoconf}
119 %configure \
120         --datadir=%{_datadir}/gdal \
121         --with-pymoddir=%{py_sitedir} \
122         --with-xerces \
123         --with-xerces-inc=/usr/include/xercesc \
124         --with-xerces-lib="-lxerces-c" \
125         --without-grass
126
127 %{__make}
128
129 %{__make} docs
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 mv -f ogr/html html/org
138
139 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc ChangeLog NEWS
150 %attr(755,root,root) %{_bindir}/*
151 %exclude %{_bindir}/gdal-config
152 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
153 %{_datadir}/gdal
154 %{_mandir}/man1/*
155 %exclude %{_mandir}/man1/gdal-config.1*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %doc html/*
160 %attr(755,root,root) %{_bindir}/gdal-config
161 %attr(755,root,root) %{_libdir}/libgdal.so
162 %{_libdir}/libgdal.la
163 %{_includedir}/*.h
164 %{_mandir}/man1/gdal-config.1*
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/*.a
169
170 %files -n python-gdal
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
173 %{py_sitedir}/*.py
This page took 0.080561 seconds and 3 git commands to generate.