]> git.pld-linux.org Git - packages/gdal.git/blame_incremental - gdal.spec
- release 4
[packages/gdal.git] / gdal.spec
... / ...
CommitLineData
1# TODO: csharp, java, mysql
2#
3# Conditional build:
4%bcond_without odbc # disable odbc support
5%bcond_without xerces # disable xerces support
6%bcond_without ruby # disable ruby support
7#
8Summary: Geospatial Data Abstraction Library
9Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
10Name: gdal
11Version: 1.7.2
12Release: 4
13License: BSD-like
14Group: Libraries
15Source0: ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
16# Source0-md5: 05351f8cb61761ae579667e24a297fe6
17Patch0: %{name}-perl.patch
18Patch1: %{name}-ruby.patch
19Patch2: %{name}-asneeded.patch
20Patch3: %{name}-python_install.patch
21URL: http://www.gdal.org/
22BuildRequires: autoconf >= 2.52
23BuildRequires: automake
24BuildRequires: cfitsio-devel
25BuildRequires: doxygen
26BuildRequires: expat-devel >= 1.95.0
27BuildRequires: geos-devel >= 2.0
28BuildRequires: giflib-devel >= 4.0
29BuildRequires: hdf-devel >= 4.0
30BuildRequires: hdf5-devel
31BuildRequires: jasper-devel
32BuildRequires: libcsf-devel
33BuildRequires: libdap-devel >= 3.5
34BuildRequires: libgeotiff-devel >= 1.2.1
35BuildRequires: libjpeg-devel >= 6b
36BuildRequires: libpng-devel >= 2:1.2.8
37BuildRequires: libstdc++-devel
38BuildRequires: libtiff-devel >= 3.6.0
39BuildRequires: libtool
40BuildRequires: netcdf-devel
41BuildRequires: ogdi-devel >= 3.1
42BuildRequires: perl-devel
43BuildRequires: postgresql-backend-devel
44BuildRequires: postgresql-devel
45BuildRequires: proj-devel
46BuildRequires: python-devel >= 1:2.5
47BuildRequires: python-numpy-devel >= 1:1.0.0
48BuildRequires: rpm-pythonprov
49%{?with_ruby:BuildRequires: ruby-devel}
50BuildRequires: sqlite3-devel >= 3
51BuildRequires: swig-perl
52BuildRequires: swig-python >= 1.3
53%{?with_ruby:BuildRequires: swig-ruby}
54%if "%{pld_release}" == "ti"
55BuildRequires: tetex-format-latex
56BuildRequires: tetex-dvips
57%else
58BuildRequires: texlive-dvips
59BuildRequires: texlive-latex
60%endif
61%{?with_odbc:BuildRequires: unixODBC-devel}
62%{?with_xerces:BuildRequires: xerces-c-devel >= 2.2.0}
63BuildRequires: zlib-devel >= 1.1.4
64Requires: geos >= 2.0
65Requires: libgeotiff >= 1.2.1
66Requires: libpng >= 2:1.2.8
67Requires: libtiff >= 3.6.0
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70%description
71GDAL is a translator library for raster geospatial data formats that
72is released under an Open Source license. As a library, it presents a
73single abstract data model to the calling application for all
74supported formats. The related OGR library (which lives within the
75GDAL source tree) provides a similar capability for simple features
76vector data.
77
78%description -l pl.UTF-8
79GDAL to biblioteka konwertująca między formatami rastrowych danych
80dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
81Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
82do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
83(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
84możliwości dla danych wektorowych.
85
86%package devel
87Summary: GDAL library header files
88Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
89Group: Development/Libraries
90Requires: %{name} = %{version}-%{release}
91Requires: cfitsio-devel
92Requires: expat-devel >= 1.95.0
93Requires: geos-devel >= 2.0
94Requires: giflib-devel
95Requires: hdf-devel >= 4.0
96Requires: hdf5-devel
97Requires: jasper-devel
98Requires: libcsf-devel
99Requires: libdap-devel >= 3.5
100Requires: libgeotiff-devel >= 1.2.1
101Requires: libjpeg-devel
102Requires: libpng-devel >= 2:1.2.8
103Requires: libstdc++-devel
104Requires: libtiff-devel >= 3.6.0
105Requires: netcdf-devel
106Requires: ogdi-devel >= 3.1
107Requires: postgresql-devel
108Requires: sqlite3-devel >= 3
109%{?with_odbc:Requires: unixODBC-devel}
110%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
111
112%description devel
113GDAL library header files.
114
115%description devel -l pl.UTF-8
116Pliki nagłówkowe biblioteki GDAL.
117
118%package static
119Summary: GDAL static libraries
120Summary(pl.UTF-8): Statyczne biblioteki GDAL
121Group: Development/Libraries
122Requires: %{name}-devel = %{version}-%{release}
123
124%description static
125GDAL static libraries.
126
127%description static -l pl.UTF-8
128Statyczne biblioteki GDAL.
129
130%package -n perl-gdal
131Summary: Perl bindings for GDAL
132Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
133Group: Development/Languages/Perl
134Requires: %{name} = %{version}-%{release}
135
136%description -n perl-gdal
137Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
138
139%description -n perl-gdal -l pl.UTF-8
140Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
141
142%package -n python-gdal
143Summary: GDAL Python module
144Summary(pl.UTF-8): Moduł Pythona GDAL
145Group: Libraries/Python
146Requires: %{name} = %{version}-%{release}
147%pyrequires_eq python-libs
148
149%description -n python-gdal
150GDAL Python module.
151
152%description -n python-gdal -l pl.UTF-8
153Moduł Pythona GDAL.
154
155%package -n ruby-gdal
156Summary: Ruby bindings for GDAL
157Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
158Group: Development/Languages
159Requires: %{name} = %{version}-%{release}
160%{?ruby_mod_ver_requires_eq}
161
162%description -n ruby-gdal
163Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
164
165%description -n ruby-gdal -l pl.UTF-8
166Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
167osr.
168
169%prep
170%setup -q
171%patch0 -p1
172%patch1 -p1
173%patch2 -p1
174%patch3 -p1
175
176# need to regenerate (old ones don't support perl 5.10)
177rm swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
178# includes updated for Ruby 1.9
179rm swig/ruby/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
180
181rm -rf man
182
183%build
184# $PYTHON_INCLUDES is set only with --with-ogpython, but we have --with-python,
185# and $PYTHON_INCLUDES is needed to detect numpy properly
186export PYTHON_INCLUDES=-I%{py_incdir}
187
188%{__libtoolize}
189cp -f /usr/share/automake/config.* .
190%{__aclocal} -I m4
191%{__autoconf}
192# disable grass/libgrass here, it can be built from separate gdal-grass package
193%configure \
194 --datadir=%{_datadir}/gdal \
195 --with-dods-root=/usr \
196 --with-hide-internal-symbols \
197 --with-perl \
198 --with-python \
199 %{?with_ruby:--with-ruby} \
200 --with-sqlite3 \
201 %{?with_xerces:--with-xerces} \
202 --with-xerces-inc=/usr/include/xercesc \
203 --with-xerces-lib="-lxerces-c" \
204 --without-grass \
205 --without-libgrass
206# --with-php needs Zend API update
207# java broken, no configure option
208# csharp builds, but has no configure option
209
210# regenerate where needed
211%{__make} -j1 -C swig/perl generate
212%{__make} -j1 -C swig/ruby generate
213
214%{__make} -j1
215
216%{__make} -j1 docs
217
218%{__make} -j1 man
219
220%install
221rm -rf $RPM_BUILD_ROOT
222
223%{__make} -j1 install install-man \
224 DESTDIR=$RPM_BUILD_ROOT
225
226rm -rf _html
227cp -a html _html
228cp -a ogr/html _html/ogr
229
230%py_comp $RPM_BUILD_ROOT%{py_sitedir}
231%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
232%py_postclean
233
234%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
235%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
236%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
237%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
238%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
239
240# some doxygen trash
241%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL.dox
242%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL/Const.dox
243%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OGR.dox
244%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OSR.dox
245
246%if %{with ruby}
247%{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/gdal/*.la
248%endif
249
250%clean
251rm -rf $RPM_BUILD_ROOT
252
253%post -p /sbin/ldconfig
254%postun -p /sbin/ldconfig
255
256%files
257%defattr(644,root,root,755)
258%doc NEWS PROVENANCE.TXT
259%attr(755,root,root) %{_bindir}/*
260%exclude %{_bindir}/gdal-config
261%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
262%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
263%{_datadir}/gdal
264%{_mandir}/man1/*
265%exclude %{_mandir}/man1/gdal-config.1*
266
267%files devel
268%defattr(644,root,root,755)
269%doc _html/*
270%attr(755,root,root) %{_bindir}/gdal-config
271%attr(755,root,root) %{_libdir}/libgdal.so
272%{_libdir}/libgdal.la
273%{_includedir}/*.h
274%{_mandir}/man1/gdal-config.1*
275
276%files static
277%defattr(644,root,root,755)
278%{_libdir}/libgdal.a
279
280%files -n perl-gdal
281%defattr(644,root,root,755)
282%dir %{perl_vendorarch}/Geo
283%{perl_vendorarch}/Geo/GDAL.pm
284%dir %{perl_vendorarch}/Geo/GDAL
285%{perl_vendorarch}/Geo/GDAL/Const.pm
286%{perl_vendorarch}/Geo/OGR.pm
287%{perl_vendorarch}/Geo/OSR.pm
288%dir %{perl_vendorarch}/auto/Geo
289%dir %{perl_vendorarch}/auto/Geo/GDAL
290%{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
291%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
292%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
293%{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
294%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
295%dir %{perl_vendorarch}/auto/Geo/OGR
296%{perl_vendorarch}/auto/Geo/OGR/OGR.bs
297%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
298%dir %{perl_vendorarch}/auto/Geo/OSR
299%{perl_vendorarch}/auto/Geo/OSR/OSR.bs
300%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
301
302%files -n python-gdal
303%defattr(644,root,root,755)
304%{py_sitedir}/gdal.py[co]
305%{py_sitedir}/gdalconst.py[co]
306%{py_sitedir}/gdalnumeric.py[co]
307%{py_sitedir}/ogr.py[co]
308%{py_sitedir}/osr.py[co]
309%{py_sitedir}/GDAL-*.egg-info
310%dir %{py_sitedir}/osgeo
311%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
312%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
313%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
314%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
315%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
316%{py_sitedir}/osgeo/*.py[co]
317
318%if %{with ruby}
319%files -n ruby-gdal
320%defattr(644,root,root,755)
321%dir %{ruby_sitearchdir}/gdal
322%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
323%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
324%attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
325%attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
326%endif
This page took 0.024785 seconds and 4 git commands to generate.