]> git.pld-linux.org Git - packages/gdal.git/blame_incremental - gdal.spec
Release 21 (by relup.sh)
[packages/gdal.git] / gdal.spec
... / ...
CommitLineData
1# TODO:
2# - be reasonable about devel dependencies - you do not need all of them to
3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
5# - MongoCXX (mongo/client/dbclient.h, -lmongoclient -lboost_system -lboost_thread -lboost_regex)
6# - rasterlite2
7# - sfcgal >= 1.2.2
8# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9# - libkml (1.3.0 needed, not released yet)
10# - wait for newer pcidsk, switch to external again
11# - csharp, java
12# - additional, proprietary(?) formats support:
13# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17# - MrSID (http://www.lizardtech.com/developer/)
18# - LuraTech JP2Lura
19# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
20# - Ingres (--with-ingres=/path)
21# - Informix DB (--with-idb)
22# - DWGdirect (members only? http://www.opendwg.org/)
23# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24# - Teigha DWG/DGN (https://www.opendesign.com/products/drawings?)
25#
26# Conditional build:
27%bcond_without armadillo # Armadillo support for faster TPS transform
28%bcond_without crnlib # DDS support via crunch/crnlib
29%bcond_without epsilon # EPSILON wavelet compression support
30%bcond_without fyba # SOSI geodata support using FYBA
31%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
32%bcond_without gta # GTA format support
33%bcond_without kea # KEA format support
34%bcond_without mysql # MySQL DB support
35%bcond_with oci # ORACLE OCI DB and Georaster support
36%bcond_without odbc # ODBC DB support
37%bcond_without opencl # OpenCL (GPU) support
38%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
39%bcond_with podofo # PDF support via podofo instead of poppler
40%bcond_without poppler # PDF support via poppler
41%bcond_with rasdaman # Rasdaman support
42%bcond_with spatialite # SpatiaLite support
43%bcond_without xerces # Xerces support
44%bcond_without java # Java and MDB support
45
46%if %{with podofo}
47%undefine with_poppler
48%endif
49
50%{?use_default_jdk}
51
52Summary: Geospatial Data Abstraction Library
53Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
54Name: gdal
55Version: 3.0.4
56Release: 21
57License: BSD-like
58Group: Libraries
59Source0: https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
60# Source0-md5: c6bbb5caca06e96bd97a32918e0aa9aa
61Patch0: %{name}-perl.patch
62Patch1: %{name}-pc.patch
63Patch2: %{name}-dds.patch
64Patch3: %{name}-rasdaman.patch
65Patch4: %{name}-pluginsdir.patch
66Patch5: libx32.patch
67Patch6: %{name}-poppler.patch
68Patch7: decl.patch
69Patch8: %{name}_tirpcinc.patch
70Patch9: jasper.patch
71Patch10: gcc11.patch
72URL: http://www.gdal.org/
73# 1.x or 2.x supported
74BuildRequires: CharLS-devel
75%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
76%{?with_armadillo:BuildRequires: armadillo-devel}
77BuildRequires: autoconf >= 2.52
78BuildRequires: automake
79BuildRequires: cfitsio-devel
80%{?with_crnlib:BuildRequires: crnlib-devel}
81BuildRequires: cryptopp-devel
82BuildRequires: curl-devel
83BuildRequires: doxygen >= 1.4.2
84%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
85BuildRequires: expat-devel >= 1.95.0
86%{?with_fyba:BuildRequires: fyba-devel}
87BuildRequires: freexl-devel >= 1.0
88BuildRequires: gcc >= 6:4.1
89BuildRequires: geos-devel >= 3.1.0
90BuildRequires: giflib-devel >= 4.0
91%{?with_grass:BuildRequires: grass-devel >= 6.4}
92BuildRequires: hdf-devel >= 4.2.5
93BuildRequires: hdf5-devel
94BuildRequires: jasper-devel
95%{?with_java:%buildrequires_jdk}
96%{?with_java:BuildRequires: jpackage-utils}
97BuildRequires: json-c-devel >= 0.11
98%{?with_kea:BuildRequires: kealib-devel}
99BuildRequires: libcsf-devel >= 2.0-0.041111.6
100BuildRequires: libdap-devel >= 3.10
101BuildRequires: libgeotiff-devel >= 1.2.1
102%{?with_gta:BuildRequires: libgta-devel}
103BuildRequires: libjpeg-devel >= 6b
104#BuildRequires: libkml-devel >= 1.3.0
105BuildRequires: libpng-devel >= 2:1.2.8
106%{?with_spatialite:BuildRequires: libspatialite-devel}
107BuildRequires: libstdc++-devel
108BuildRequires: libtiff-devel >= 4.0
109BuildRequires: libtirpc-devel
110BuildRequires: libtool
111BuildRequires: libuuid-devel
112BuildRequires: libwebp-devel
113BuildRequires: libxml2-devel >= 2
114#%{?with_mysql:BuildRequires: mysql-devel >= 4}
115%{?with_mysql:BuildRequires: /usr/bin/mysql_config}
116BuildRequires: netcdf-devel >= 4.1
117BuildRequires: ogdi-devel >= 3.1
118%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
119# 8.1.7 for DB support, 10.0.1 for georaster
120%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
121#BuildRequires: pcidsk-devel > 0.3
122BuildRequires: pcre-devel
123BuildRequires: perl-devel
124BuildRequires: pkgconfig >= 1:0.21
125%{?with_podofo:BuildRequires: podofo-devel}
126%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
127# ensure it's compiled with PQescapeStringConn support
128BuildRequires: postgresql-backend-devel >= 8.1.4
129BuildRequires: postgresql-devel >= 8.1.4
130BuildRequires: proj-devel >= 4
131BuildRequires: python-devel >= 1:2.5
132BuildRequires: python-numpy-devel >= 1:1.0.0
133BuildRequires: python-setuptools
134BuildRequires: qhull-devel >= 2012
135%{?with_rasdaman:BuildRequires: rasdaman-devel}
136BuildRequires: rpm-pythonprov
137BuildRequires: rpmbuild(macros) >= 2.021
138BuildRequires: sed >= 4.0
139BuildRequires: sqlite3-devel >= 3.0.0
140BuildRequires: swig-perl
141BuildRequires: swig-python >= 1.3
142BuildRequires: texlive-dvips
143BuildRequires: texlive-latex
144%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
145%{?with_xerces:BuildRequires: xerces-c-devel >= 3.1.0}
146BuildRequires: xz-devel
147BuildRequires: zlib-devel >= 1.1.4
148# for ZSTD compression in TIFF
149BuildRequires: zstd-devel
150%{?with_java:Requires: %{?use_jdk:%{use_jdk}-jre-base}%{!?use_jdk:jre}}
151Requires: freexl >= 1.0
152Requires: geos >= 3.1.0
153Requires: hdf >= 4.2.5
154Requires: libgeotiff >= 1.2.1
155Requires: libpng >= 2:1.2.8
156Requires: libtiff >= 4.0
157%{?with_openjpeg:Requires: openjpeg2 >= 2.1.0}
158Requires: qhull >= 2012
159%{?with_xerces:Requires: xerces-c >= 3.1.0}
160BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
161
162%description
163GDAL is a translator library for raster geospatial data formats that
164is released under an Open Source license. As a library, it presents a
165single abstract data model to the calling application for all
166supported formats. The related OGR library (which lives within the
167GDAL source tree) provides a similar capability for simple features
168vector data.
169
170%description -l pl.UTF-8
171GDAL to biblioteka konwertująca między formatami rastrowych danych
172dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
173Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
174do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
175(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
176możliwości dla danych wektorowych.
177
178%package devel
179Summary: GDAL library header files
180Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
181Group: Development/Libraries
182Requires: %{name} = %{version}-%{release}
183Requires: CharLS-devel
184%{?with_opencl:Requires: OpenCL-devel >= 1.0}
185%{?with_armadillo:Requires: armadillo-devel}
186Requires: cfitsio-devel
187%{?with_crnlib:Requires: crnlib-devel}
188Requires: cryptopp-devel
189Requires: curl-devel
190%{?with_epsilon:Requires: epsilon-compressor-devel}
191%{?with_fyba:Requires: fyba-devel}
192Requires: expat-devel >= 1.95.0
193Requires: freexl-devel >= 1.0
194Requires: geos-devel >= 3.1.0
195Requires: giflib-devel >= 4.0
196Requires: hdf-devel >= 4.2.5
197Requires: hdf5-devel
198Requires: jasper-devel
199Requires: json-c-devel >= 0.11
200%{?with_kea:Requires: kealib-devel}
201Requires: libcsf-devel
202Requires: libdap-devel >= 3.10
203Requires: libgeotiff-devel >= 1.2.1
204%{?with_gta:Requires: libgta-devel}
205Requires: libjpeg-devel >= 6b
206Requires: libpng-devel >= 2:1.2.8
207%{?with_spatialite:Requires: libspatialite-devel}
208Requires: libstdc++-devel
209Requires: libtiff-devel >= 4.0
210Requires: libuuid-devel
211Requires: libwebp-devel
212Requires: libxml2-devel >= 2
213%{?with_mysql:Requires: /usr/bin/mysql_config}
214Requires: netcdf-devel >= 4
215Requires: ogdi-devel >= 3.1
216%{?with_openjpeg:Requires: openjpeg2-devel >= 2.1.0}
217#Requires: pcidsk-devel > 0.3
218Requires: pcre-devel
219%{?with_podofo:Requires: podofo-devel}
220%{?with_poppler:Requires: poppler-devel >= 0.24}
221Requires: postgresql-devel
222Requires: proj-devel >= 4
223Requires: qhull-devel >= 2012
224%{?with_rasdaman:Requires: rasdaman-devel}
225Requires: sqlite3-devel >= 3.0.0
226%{?with_odbc:Requires: unixODBC-devel}
227%{?with_xerces:Requires: xerces-c-devel >= 3.1.0}
228Requires: xz-devel
229Requires: zlib-devel >= 1.1.4
230Requires: zstd-devel
231
232%description devel
233GDAL library header files.
234
235%description devel -l pl.UTF-8
236Pliki nagłówkowe biblioteki GDAL.
237
238%package static
239Summary: GDAL static libraries
240Summary(pl.UTF-8): Statyczne biblioteki GDAL
241Group: Development/Libraries
242Requires: %{name}-devel = %{version}-%{release}
243
244%description static
245GDAL static libraries.
246
247%description static -l pl.UTF-8
248Statyczne biblioteki GDAL.
249
250%package -n perl-gdal
251Summary: Perl bindings for GDAL
252Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
253Group: Development/Languages/Perl
254Requires: %{name} = %{version}-%{release}
255
256%description -n perl-gdal
257Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
258
259%description -n perl-gdal -l pl.UTF-8
260Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
261
262%package -n python-gdal
263Summary: GDAL Python module
264Summary(pl.UTF-8): Moduł Pythona GDAL
265Group: Libraries/Python
266Requires: %{name} = %{version}-%{release}
267Requires: python-libs
268
269%description -n python-gdal
270GDAL Python module.
271
272%description -n python-gdal -l pl.UTF-8
273Moduł Pythona GDAL.
274
275%prep
276%setup -q
277%patch0 -p1
278%patch1 -p1
279%patch2 -p1
280%patch3 -p1
281%patch4 -p1
282%patch5 -p1
283%patch6 -p1
284%patch7 -p1
285%patch8 -p1
286%patch9 -p2
287%patch10 -p2
288
289# need to regenerate (old ones don't support perl 5.10)
290%{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
291
292# our man path
293sed -i -e 's#^mandir=.*##g' configure.ac
294
295%{__rm} -r man
296
297%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
298
299sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
300 -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
301 -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
302 swig/python/scripts/epsg_tr.py \
303 swig/python/scripts/esri2wkt.py \
304 swig/python/scripts/gcps2vec.py \
305 swig/python/scripts/gcps2wld.py \
306 swig/python/scripts/gdal2tiles.py \
307 swig/python/scripts/gdal2xyz.py \
308 swig/python/scripts/gdal_auth.py \
309 swig/python/scripts/gdal_calc.py \
310 swig/python/scripts/gdal_edit.py \
311 swig/python/scripts/gdal_fillnodata.py \
312 swig/python/scripts/gdal_merge.py \
313 swig/python/scripts/gdal_pansharpen.py \
314 swig/python/scripts/gdal_polygonize.py \
315 swig/python/scripts/gdal_proximity.py \
316 swig/python/scripts/gdal_retile.py \
317 swig/python/scripts/gdal_sieve.py \
318 swig/python/scripts/gdalchksum.py \
319 swig/python/scripts/gdalcompare.py \
320 swig/python/scripts/gdalident.py \
321 swig/python/scripts/gdalimport.py \
322 swig/python/scripts/gdalmove.py \
323 swig/python/scripts/mkgraticule.py \
324 swig/python/scripts/ogrmerge.py \
325 swig/python/scripts/pct2rgb.py \
326 swig/python/scripts/rgb2pct.py
327
328%build
329cp -f /usr/share/gettext/config.rpath .
330
331%if %{with java}
332%ifarch %{x8664}
333jvm_arch=amd64
334%endif
335%ifarch %{ix86}
336jvm_arch=i386
337%endif
338%ifarch x32
339jvm_arch=x32
340%endif
341%ifarch aarch64
342jvm_arch=aarch64
343%endif
344%ifarch %{arm}
345jvm_arch=aarch32
346%endif
347for jvm_type in server client; do
348 for dir in lib jre/lib/$jvm_arch; do
349 if [ -f "%{java_home}/$dir/$jvm_type/libjvm.so" ]; then
350 jvm_lib="%{java_home}/$dir/$jvm_type"
351 break
352 fi
353 done
354done
355%endif
356
357%{__libtoolize}
358%{__aclocal} -I m4
359%{__autoconf}
360%{__autoheader}
361%configure \
362 --includedir=%{_includedir}/gdal \
363 --datadir=%{_datadir}/gdal \
364 --with-dods-root=/usr \
365 %{?with_armadillo:--with-armadillo} \
366 %{?with_crnlib:--with-dds} \
367 %{?with_epsilon:--with-epsilon} \
368 %{?with_grass:--with-grass} \
369 %{!?with_gta:--without-gta} \
370 --with-hide-internal-symbols \
371 %{?with_java:--with-java=%{java_home}} \
372 --with-liblzma \
373 %{!?with_kea:--without-kea} \
374 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib="$jvm_lib"} \
375 %{?with_mysql:--with-mysql} \
376 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
377 %{?with_opencl:--with-opencl} \
378 --with-perl \
379 %{?with_podofo:--with-podofo} \
380 %{?with_poppler:--with-poppler} \
381 --with-python \
382 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
383 %{?with_fyba:--with-sosi} \
384 %{?with_spatialite:--with-spatialite} \
385 --with-sqlite3 \
386 --with-webp \
387 %{?with_xerces:--with-xerces} \
388 --with-xerces-inc=/usr/include \
389 --with-xerces-lib="-lxerces-c" \
390 --without-libgrass
391# --with-pcidsk=/usr (needs > 0.3)
392# csharp builds, but has no configure option nor install target
393
394# regenerate where needed
395%{__make} -j1 -C swig/perl generate
396
397%{__make} \
398 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
399 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
400
401%{__make} -j1 docs
402
403%{__make} -j1 man
404
405%install
406rm -rf $RPM_BUILD_ROOT
407
408%{__make} -j1 install install-man \
409 DESTDIR=$RPM_BUILD_ROOT
410
411# TODO: remove libgdal.la when gdal.pc gets maintained Requires.private/Libs.private list
412
413rm -rf _html
414cp -a html _html
415
416%py_comp $RPM_BUILD_ROOT%{py_sitedir}
417%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
418%py_postclean
419
420%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
421%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
422%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
423%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
424%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
425
426%clean
427rm -rf $RPM_BUILD_ROOT
428
429%post -p /sbin/ldconfig
430%postun -p /sbin/ldconfig
431
432%files
433%defattr(644,root,root,755)
434%doc NEWS PROVENANCE.TXT
435%attr(755,root,root) %{_bindir}/epsg_tr.py
436%attr(755,root,root) %{_bindir}/esri2wkt.py
437%attr(755,root,root) %{_bindir}/gcps2vec.py
438%attr(755,root,root) %{_bindir}/gcps2wld.py
439%attr(755,root,root) %{_bindir}/gdal2tiles.py
440%attr(755,root,root) %{_bindir}/gdal2xyz.py
441%attr(755,root,root) %{_bindir}/gdaladdo
442%attr(755,root,root) %{_bindir}/gdal_auth.py
443%attr(755,root,root) %{_bindir}/gdalbuildvrt
444%attr(755,root,root) %{_bindir}/gdal_calc.py
445%attr(755,root,root) %{_bindir}/gdalchksum.py
446%attr(755,root,root) %{_bindir}/gdalcompare.py
447%attr(755,root,root) %{_bindir}/gdal_contour
448%attr(755,root,root) %{_bindir}/gdaldem
449%attr(755,root,root) %{_bindir}/gdal_edit.py
450%attr(755,root,root) %{_bindir}/gdalenhance
451%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
452%attr(755,root,root) %{_bindir}/gdal_grid
453%attr(755,root,root) %{_bindir}/gdalident.py
454%attr(755,root,root) %{_bindir}/gdalimport.py
455%attr(755,root,root) %{_bindir}/gdalinfo
456%attr(755,root,root) %{_bindir}/gdallocationinfo
457%attr(755,root,root) %{_bindir}/gdalmanage
458%attr(755,root,root) %{_bindir}/gdal_merge.py
459%attr(755,root,root) %{_bindir}/gdalmove.py
460%attr(755,root,root) %{_bindir}/gdal_pansharpen.py
461%attr(755,root,root) %{_bindir}/gdal_polygonize.py
462%attr(755,root,root) %{_bindir}/gdal_proximity.py
463%attr(755,root,root) %{_bindir}/gdal_rasterize
464%attr(755,root,root) %{_bindir}/gdal_retile.py
465%attr(755,root,root) %{_bindir}/gdalserver
466%attr(755,root,root) %{_bindir}/gdal_sieve.py
467%attr(755,root,root) %{_bindir}/gdalsrsinfo
468%attr(755,root,root) %{_bindir}/gdaltindex
469%attr(755,root,root) %{_bindir}/gdaltransform
470%attr(755,root,root) %{_bindir}/gdal_translate
471%attr(755,root,root) %{_bindir}/gdalwarp
472%attr(755,root,root) %{_bindir}/gnmanalyse
473%attr(755,root,root) %{_bindir}/gnmmanage
474%attr(755,root,root) %{_bindir}/mkgraticule.py
475%attr(755,root,root) %{_bindir}/nearblack
476%attr(755,root,root) %{_bindir}/ogr2ogr
477%attr(755,root,root) %{_bindir}/ogrinfo
478%attr(755,root,root) %{_bindir}/ogrlineref
479%attr(755,root,root) %{_bindir}/ogrmerge.py
480%attr(755,root,root) %{_bindir}/ogrtindex
481%attr(755,root,root) %{_bindir}/pct2rgb.py
482%attr(755,root,root) %{_bindir}/rgb2pct.py
483%attr(755,root,root) %{_bindir}/testepsg
484%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
485%attr(755,root,root) %ghost %{_libdir}/libgdal.so.26
486%dir %{_libdir}/gdalplugins
487%{_datadir}/gdal
488%{_mandir}/man1/gdal2tiles.1*
489%{_mandir}/man1/gdal_calc.1*
490%{_mandir}/man1/gdal_contour.1*
491%{_mandir}/man1/gdal_edit.1*
492%{_mandir}/man1/gdal_fillnodata.1*
493%{_mandir}/man1/gdal_grid.1*
494%{_mandir}/man1/gdal_merge.1*
495%{_mandir}/man1/gdal_polygonize.1*
496%{_mandir}/man1/gdal_proximity.1*
497%{_mandir}/man1/gdal_rasterize.1*
498%{_mandir}/man1/gdal_retile.1*
499%{_mandir}/man1/gdal_sieve.1*
500%{_mandir}/man1/gdal_translate.1*
501%{_mandir}/man1/gdal_utilities.1*
502%{_mandir}/man1/gdaladdo.1*
503%{_mandir}/man1/gdalbuildvrt.1*
504%{_mandir}/man1/gdalcompare.1*
505%{_mandir}/man1/gdaldem.1*
506%{_mandir}/man1/gdalinfo.1*
507%{_mandir}/man1/gdallocationinfo.1*
508%{_mandir}/man1/gdalmanage.1*
509%{_mandir}/man1/gdalmove.1*
510%{_mandir}/man1/gdalsrsinfo.1*
511%{_mandir}/man1/gdaltindex.1*
512%{_mandir}/man1/gdaltransform.1*
513%{_mandir}/man1/gdalwarp.1*
514%{_mandir}/man1/nearblack.1*
515%{_mandir}/man1/ogr2ogr.1*
516%{_mandir}/man1/ogr_utilities.1*
517%{_mandir}/man1/ogrinfo.1*
518%{_mandir}/man1/ogrlineref.1*
519%{_mandir}/man1/ogrtindex.1*
520%{_mandir}/man1/pct2rgb.1*
521%{_mandir}/man1/rgb2pct.1*
522%{_mandir}/man1/gdal_pansharpen.1*
523%{_mandir}/man1/gnm_utilities.1*
524%{_mandir}/man1/gnmanalyse.1*
525%{_mandir}/man1/gnmmanage.1*
526%{_mandir}/man1/ogrmerge.1*
527
528%files devel
529%defattr(644,root,root,755)
530%doc _html/*
531%attr(755,root,root) %{_bindir}/gdal-config
532%attr(755,root,root) %{_libdir}/libgdal.so
533%{_libdir}/libgdal.la
534%{_pkgconfigdir}/gdal.pc
535%{_includedir}/gdal
536%{_mandir}/man1/gdal-config.1*
537
538%files static
539%defattr(644,root,root,755)
540%{_libdir}/libgdal.a
541
542%files -n perl-gdal
543%defattr(644,root,root,755)
544%dir %{perl_vendorarch}/Geo
545%{perl_vendorarch}/Geo/GDAL.pm
546%dir %{perl_vendorarch}/Geo/GDAL
547%{perl_vendorarch}/Geo/GDAL/Const.pm
548%{perl_vendorarch}/Geo/OGR.pm
549%{perl_vendorarch}/Geo/OSR.pm
550%dir %{perl_vendorarch}/auto/Geo
551%dir %{perl_vendorarch}/auto/Geo/GDAL
552%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
553%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
554%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
555%dir %{perl_vendorarch}/auto/Geo/GNM
556%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
557%dir %{perl_vendorarch}/auto/Geo/OGR
558%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
559%dir %{perl_vendorarch}/auto/Geo/OSR
560%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
561%{_mandir}/man3/Geo::GDAL.3pm*
562%{perl_vendorarch}/Geo/GNM.pm
563
564%files -n python-gdal
565%defattr(644,root,root,755)
566%{py_sitedir}/gdal.py[co]
567%{py_sitedir}/gdalconst.py[co]
568%{py_sitedir}/gdalnumeric.py[co]
569%{py_sitedir}/ogr.py[co]
570%{py_sitedir}/osr.py[co]
571%{py_sitedir}/GDAL-*.egg-info
572%dir %{py_sitedir}/osgeo
573%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
574%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
575%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
576%attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
577%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
578%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
579%{py_sitedir}/osgeo/*.py[co]
This page took 0.054731 seconds and 5 git commands to generate.