]> git.pld-linux.org Git - packages/gdal.git/blame_incremental - gdal.spec
- release 10 (by relup.sh)
[packages/gdal.git] / gdal.spec
... / ...
CommitLineData
1# TODO:
2# - be reasonable about devel dependencies - you do not need all of them to
3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
5# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
6# - libkml (1.3.0 needed, not released yet)
7# - wait for newer pcidsk, switch to external again
8# - csharp, java
9# - additional, proprietary(?) formats support:
10# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14# - MrSID (http://www.lizardtech.com/developer/)
15# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
16# - Ingres (--with-ingres=/path)
17# - Informix DB (--with-idb)
18# - DWGdirect (members only? http://www.opendwg.org/)
19# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
20#
21# Conditional build:
22%bcond_without armadillo # Armadillo support for faster TPS transform
23%bcond_without crnlib # DDS support via crunch/crnlib
24%bcond_without epsilon # EPSILON wavelet compression support
25%bcond_without fyba # SOSI geodata support using FYBA
26%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
27%bcond_without gta # GTA format support
28%bcond_without mysql # MySQL DB support
29%bcond_with oci # ORACLE OCI DB and Georaster support
30%bcond_without odbc # ODBC DB support
31%bcond_without opencl # OpenCL (GPU) support
32%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
33%bcond_with podofo # PDF support via podofo instead of poppler
34%bcond_without poppler # PDF support via poppler
35%bcond_without rasdaman # Rasdaman support
36%bcond_without spatialite # SpatiaLite support
37%bcond_without xerces # Xerces support
38%bcond_without java # Java and MDB support
39%bcond_without php # PHP binding
40%bcond_without ruby # Ruby binding
41
42%if %{with podofo}
43%undefine with_poppler
44%endif
45%if 0%{!?php_name:1}
46%define php_name php55
47%endif
48Summary: Geospatial Data Abstraction Library
49Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
50Name: gdal
51Version: 1.11.2
52Release: 10
53License: BSD-like
54Group: Libraries
55Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
56# Source0-md5: 90221810dd9ca656ee23d434d4266ef6
57Patch0: %{name}-perl.patch
58Patch1: %{name}-python_install.patch
59Patch2: %{name}-php.patch
60Patch3: %{name}-fpic.patch
61Patch4: %{name}-format-security.patch
62Patch5: %{name}-grass.patch
63Patch6: %{name}-sse.patch
64Patch7: %{name}-link.patch
65Patch8: %{name}-fyba.patch
66Patch9: %{name}-dds.patch
67Patch11: %{name}-armadillo.patch
68Patch12: %{name}-rasdaman.patch
69Patch13: %{name}-pluginsdir.patch
70Patch14: poppler-0.31.patch
71URL: http://www.gdal.org/
72%{?with_php:BuildRequires: %{php_name}-devel}
73%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
74%{?with_armadillo:BuildRequires: armadillo-devel}
75BuildRequires: autoconf >= 2.52
76BuildRequires: automake
77BuildRequires: cfitsio-devel
78%{?with_crnlib:BuildRequires: crnlib-devel}
79BuildRequires: curl-devel
80BuildRequires: doxygen >= 1.4.2
81%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
82BuildRequires: expat-devel >= 1.95.0
83%{?with_fyba:BuildRequires: fyba-devel}
84BuildRequires: freexl-devel >= 1.0
85BuildRequires: gcc >= 6:4.1
86BuildRequires: geos-devel >= 3.1.0
87BuildRequires: giflib-devel >= 4.0
88%{?with_grass:BuildRequires: grass-devel >= 6.4}
89BuildRequires: hdf-devel >= 4.0
90BuildRequires: hdf5-devel
91BuildRequires: jasper-devel
92%{?with_java:BuildRequires: jdk}
93%{?with_java:BuildRequires: jpackage-utils}
94BuildRequires: json-c-devel >= 0.11
95BuildRequires: libcsf-devel
96BuildRequires: libdap-devel >= 3.10
97BuildRequires: libgeotiff-devel >= 1.2.1
98%{?with_gta:BuildRequires: libgta-devel}
99BuildRequires: libjpeg-devel >= 6b
100#BuildRequires: libkml-devel >= 1.3.0
101BuildRequires: libpng-devel >= 2:1.2.8
102%{?with_spatialite:BuildRequires: libspatialite-devel}
103BuildRequires: libstdc++-devel
104BuildRequires: libtiff-devel >= 4.0
105BuildRequires: libtool
106BuildRequires: libuuid-devel
107BuildRequires: libwebp-devel
108BuildRequires: libxml2-devel >= 2
109%{?with_mysql:BuildRequires: mysql-devel}
110BuildRequires: netcdf-devel >= 4.1
111BuildRequires: ogdi-devel >= 3.1
112%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
113# 8.1.7 for DB support, 10.0.1 for georaster
114%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
115#BuildRequires: pcidsk-devel > 0.3
116BuildRequires: perl-devel
117%{?with_podofo:BuildRequires: podofo-devel}
118%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
119# ensure it's compiled with PQescapeStringConn support
120BuildRequires: postgresql-backend-devel >= 8.1.4
121BuildRequires: postgresql-devel >= 8.1.4
122BuildRequires: proj-devel >= 4
123BuildRequires: python-devel >= 1:2.5
124BuildRequires: python-numpy-devel >= 1:1.0.0
125BuildRequires: python-setuptools
126%{?with_rasdaman:BuildRequires: rasdaman-devel}
127BuildRequires: rpm-pythonprov
128%{?with_ruby:BuildRequires: rpm-rubyprov}
129BuildRequires: rpmbuild(macros) >= 1.344
130%{?with_ruby:BuildRequires: ruby-devel}
131BuildRequires: sed >= 4.0
132BuildRequires: sqlite3-devel >= 3.0.0
133BuildRequires: swig-perl
134BuildRequires: swig-php >= 2.0.12-2
135BuildRequires: swig-python >= 1.3
136%{?with_ruby:BuildRequires: swig-ruby}
137BuildRequires: texlive-dvips
138BuildRequires: texlive-latex
139%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
140%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
141BuildRequires: xz-devel
142BuildRequires: zlib-devel >= 1.1.4
143Requires: freexl >= 1.0
144Requires: geos >= 3.1.0
145Requires: libgeotiff >= 1.2.1
146Requires: libpng >= 2:1.2.8
147Requires: libtiff >= 4.0
148BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
149
150%description
151GDAL is a translator library for raster geospatial data formats that
152is released under an Open Source license. As a library, it presents a
153single abstract data model to the calling application for all
154supported formats. The related OGR library (which lives within the
155GDAL source tree) provides a similar capability for simple features
156vector data.
157
158%description -l pl.UTF-8
159GDAL to biblioteka konwertująca między formatami rastrowych danych
160dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
161Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
162do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
163(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
164możliwości dla danych wektorowych.
165
166%package devel
167Summary: GDAL library header files
168Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
169Group: Development/Libraries
170Requires: %{name} = %{version}-%{release}
171%{?with_opencl:Requires: OpenCL-devel >= 1.0}
172%{?with_armadillo:Requires: armadillo-devel}
173Requires: cfitsio-devel
174%{?with_crnlib:Requires: crnlib-devel}
175Requires: curl-devel
176%{?with_epsilon:Requires: epsilon-compressor-devel}
177%{?with_fyba:Requires: fyba-devel}
178Requires: expat-devel >= 1.95.0
179Requires: freexl-devel >= 1.0
180Requires: geos-devel >= 3.1.0
181Requires: giflib-devel >= 4.0
182Requires: hdf-devel >= 4.0
183Requires: hdf5-devel
184Requires: jasper-devel
185Requires: json-c-devel >= 0.11
186Requires: libcsf-devel
187Requires: libdap-devel >= 3.10
188Requires: libgeotiff-devel >= 1.2.1
189%{?with_gta:Requires: libgta-devel}
190Requires: libjpeg-devel >= 6b
191Requires: libpng-devel >= 2:1.2.8
192%{?with_spatialite:Requires: libspatialite-devel}
193Requires: libstdc++-devel
194Requires: libtiff-devel >= 4.0
195Requires: libuuid-devel
196Requires: libwebp-devel
197Requires: libxml2-devel >= 2
198%{?with_mysql:Requires: mysql-devel}
199Requires: netcdf-devel >= 4
200Requires: ogdi-devel >= 3.1
201%{?with_openjpeg:Requires: openjpeg2-devel >= 2.0.0-2}
202#Requires: pcidsk-devel > 0.3
203%{?with_podofo:Requires: podofo-devel}
204%{?with_poppler:Requires: poppler-devel >= 0.24}
205Requires: postgresql-devel
206Requires: proj-devel >= 4
207%{?with_rasdaman:Requires: rasdaman-devel}
208Requires: sqlite3-devel >= 3.0.0
209%{?with_odbc:Requires: unixODBC-devel}
210%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
211Requires: xz-devel
212Requires: zlib-devel >= 1.1.4
213
214%description devel
215GDAL library header files.
216
217%description devel -l pl.UTF-8
218Pliki nagłówkowe biblioteki GDAL.
219
220%package static
221Summary: GDAL static libraries
222Summary(pl.UTF-8): Statyczne biblioteki GDAL
223Group: Development/Libraries
224Requires: %{name}-devel = %{version}-%{release}
225
226%description static
227GDAL static libraries.
228
229%description static -l pl.UTF-8
230Statyczne biblioteki GDAL.
231
232%package -n perl-gdal
233Summary: Perl bindings for GDAL
234Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
235Group: Development/Languages/Perl
236Requires: %{name} = %{version}-%{release}
237
238%description -n perl-gdal
239Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
240
241%description -n perl-gdal -l pl.UTF-8
242Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
243
244%package -n %{php_name}-gdal
245Summary: PHP bindings for GDAL library
246Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
247Group: Development/Languages/PHP
248Requires: %{name} = %{version}-%{release}
249%{?requires_php_extension}
250
251%description -n %{php_name}-gdal
252PHP bindings for GDAL library
253
254%description -n %{php_name}-gdal -l pl.UTF-8
255Wiązania PHP do biblioteki GDAL.
256
257%package -n python-gdal
258Summary: GDAL Python module
259Summary(pl.UTF-8): Moduł Pythona GDAL
260Group: Libraries/Python
261Requires: %{name} = %{version}-%{release}
262Requires: python-libs
263
264%description -n python-gdal
265GDAL Python module.
266
267%description -n python-gdal -l pl.UTF-8
268Moduł Pythona GDAL.
269
270%package -n ruby-gdal
271Summary: Ruby bindings for GDAL
272Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
273Group: Development/Languages
274Requires: %{name} = %{version}-%{release}
275
276%description -n ruby-gdal
277Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
278
279%description -n ruby-gdal -l pl.UTF-8
280Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
281osr.
282
283%prep
284%setup -q
285%patch0 -p1
286%patch1 -p1
287%patch2 -p1
288%patch3 -p1
289%patch4 -p1
290%patch5 -p1
291%patch6 -p1
292%patch7 -p1
293%patch8 -p1
294%patch9 -p1
295%patch11 -p1
296%patch12 -p1
297%patch13 -p1
298%patch14 -p1
299
300# need to regenerate (old ones don't support perl 5.10 or php 5.5)
301%{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
302
303%{__sed} -i \
304 -e 's/^CC=gcc/CC=%{__cc}/' \
305 -e 's/^CXX=g++/CXX=%{__cxx}/' \
306 -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
307 -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
308 swig/php/GNUmakefile
309# Build with fPIC to allow Ruby bindings
310# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
311# http://trac.osgeo.org/gdal/ticket/1994
312sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
313# Install Ruby bindings to distribution specific directory
314sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
315
316# Install Ruby bindings into the proper place
317sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
318sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
319
320# our man path
321sed -i -e 's#^mandir=.*##g' configure.in
322
323%{__rm} -r man
324
325%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
326
327%build
328%ifarch %{x8664}
329jvm_arch=amd64
330%endif
331%ifarch %{ix86}
332jvm_arch=i386
333%endif
334%ifarch x32
335jvm_arch=x32
336%endif
337
338%{__libtoolize}
339%{__aclocal} -I m4
340%{__autoconf}
341%{__autoheader}
342%configure \
343 --includedir=%{_includedir}/gdal \
344 --datadir=%{_datadir}/gdal \
345 --with-dods-root=/usr \
346 %{?with_armadillo:--with-armadillo} \
347 %{?with_crnlib:--with-dds} \
348 %{?with_epsilon:--with-epsilon} \
349 %{?with_grass:--with-grass} \
350 %{!?with_gta:--without-gta} \
351 --with-hide-internal-symbols \
352 %{?with_java:--with-java=%{java_home}} \
353 --with-liblzma \
354 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
355 %{?with_mysql:--with-mysql} \
356 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
357 %{?with_opencl:--with-opencl} \
358 --with-perl \
359 %{?with_php:--with-php} \
360 %{?with_podofo:--with-podofo} \
361 %{?with_poppler:--with-poppler} \
362 --with-python \
363 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
364 %{?with_ruby:--with-ruby} \
365 %{?with_fyba:--with-sosi} \
366 %{?with_spatialite:--with-spatialite} \
367 --with-sqlite3 \
368 --with-webp \
369 %{?with_xerces:--with-xerces} \
370 --with-xerces-inc=/usr/include/xercesc \
371 --with-xerces-lib="-lxerces-c" \
372 --without-libgrass
373# --with-pcidsk=/usr (needs > 0.3)
374# csharp builds, but has no configure option nor install target
375
376# regenerate where needed
377%{__make} -j1 -C swig/perl generate
378%if %{with ruby}
379%{__make} -j1 -C swig/ruby generate
380%endif
381
382%{__make} -j1 \
383 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
384 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
385
386%{__make} -j1 docs
387
388%{__make} -j1 man
389
390%install
391rm -rf $RPM_BUILD_ROOT
392
393%{__make} -j1 install install-man \
394 DESTDIR=$RPM_BUILD_ROOT
395
396rm -rf _html
397cp -a html _html
398cp -a ogr/html _html/ogr
399
400%if %{with php}
401# missing in make install
402install -d $RPM_BUILD_ROOT%{php_extensiondir}
403install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
404install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
405install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
406install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
407install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
408cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
409; Enable gdal extension modules
410extension=gdal.so
411extension=gdalconst.so
412extension=ogr.so
413extension=osr.so
414EOF
415%endif
416
417%py_comp $RPM_BUILD_ROOT%{py_sitedir}
418%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
419%py_postclean
420
421%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
422%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
423%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
424%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
425%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
426
427# some doxygen trash
428%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
429%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
430
431%clean
432rm -rf $RPM_BUILD_ROOT
433
434%post -p /sbin/ldconfig
435%postun -p /sbin/ldconfig
436
437%files
438%defattr(644,root,root,755)
439%doc NEWS PROVENANCE.TXT
440%attr(755,root,root) %{_bindir}/epsg_tr.py
441%attr(755,root,root) %{_bindir}/esri2wkt.py
442%attr(755,root,root) %{_bindir}/gcps2vec.py
443%attr(755,root,root) %{_bindir}/gcps2wld.py
444%attr(755,root,root) %{_bindir}/gdal2tiles.py
445%attr(755,root,root) %{_bindir}/gdal2xyz.py
446%attr(755,root,root) %{_bindir}/gdal_auth.py
447%attr(755,root,root) %{_bindir}/gdal_contour
448%attr(755,root,root) %{_bindir}/gdal_calc.py
449%attr(755,root,root) %{_bindir}/gdal_edit.py
450%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
451%attr(755,root,root) %{_bindir}/gdal_grid
452%attr(755,root,root) %{_bindir}/gdal_merge.py
453%attr(755,root,root) %{_bindir}/gdal_polygonize.py
454%attr(755,root,root) %{_bindir}/gdal_proximity.py
455%attr(755,root,root) %{_bindir}/gdal_rasterize
456%attr(755,root,root) %{_bindir}/gdal_retile.py
457%attr(755,root,root) %{_bindir}/gdal_sieve.py
458%attr(755,root,root) %{_bindir}/gdal_translate
459%attr(755,root,root) %{_bindir}/gdaladdo
460%attr(755,root,root) %{_bindir}/gdalbuildvrt
461%attr(755,root,root) %{_bindir}/gdalchksum.py
462%attr(755,root,root) %{_bindir}/gdalcompare.py
463%attr(755,root,root) %{_bindir}/gdaldem
464%attr(755,root,root) %{_bindir}/gdalenhance
465%attr(755,root,root) %{_bindir}/gdalident.py
466%attr(755,root,root) %{_bindir}/gdalimport.py
467%attr(755,root,root) %{_bindir}/gdalinfo
468%attr(755,root,root) %{_bindir}/gdallocationinfo
469%attr(755,root,root) %{_bindir}/gdalmanage
470%attr(755,root,root) %{_bindir}/gdalmove.py
471%attr(755,root,root) %{_bindir}/gdalserver
472%attr(755,root,root) %{_bindir}/gdalsrsinfo
473%attr(755,root,root) %{_bindir}/gdaltindex
474%attr(755,root,root) %{_bindir}/gdaltransform
475%attr(755,root,root) %{_bindir}/gdalwarp
476%attr(755,root,root) %{_bindir}/mkgraticule.py
477%attr(755,root,root) %{_bindir}/nearblack
478%attr(755,root,root) %{_bindir}/ogr2ogr
479%attr(755,root,root) %{_bindir}/ogrinfo
480%attr(755,root,root) %{_bindir}/ogrlineref
481%attr(755,root,root) %{_bindir}/ogrtindex
482%attr(755,root,root) %{_bindir}/pct2rgb.py
483%attr(755,root,root) %{_bindir}/rgb2pct.py
484%attr(755,root,root) %{_bindir}/testepsg
485%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
486%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
487%dir %{_libdir}/gdalplugins
488%{_datadir}/gdal
489%{_mandir}/man1/gdal2tiles.1*
490%{_mandir}/man1/gdal_calc.1*
491%{_mandir}/man1/gdal_contour.1*
492%{_mandir}/man1/gdal_edit.1*
493%{_mandir}/man1/gdal_fillnodata.1*
494%{_mandir}/man1/gdal_grid.1*
495%{_mandir}/man1/gdal_merge.1*
496%{_mandir}/man1/gdal_polygonize.1*
497%{_mandir}/man1/gdal_proximity.1*
498%{_mandir}/man1/gdal_rasterize.1*
499%{_mandir}/man1/gdal_retile.1*
500%{_mandir}/man1/gdal_sieve.1*
501%{_mandir}/man1/gdal_translate.1*
502%{_mandir}/man1/gdal_utilities.1*
503%{_mandir}/man1/gdaladdo.1*
504%{_mandir}/man1/gdalbuildvrt.1*
505%{_mandir}/man1/gdalcompare.1*
506%{_mandir}/man1/gdaldem.1*
507%{_mandir}/man1/gdalinfo.1*
508%{_mandir}/man1/gdallocationinfo.1*
509%{_mandir}/man1/gdalmanage.1*
510%{_mandir}/man1/gdalmove.1*
511%{_mandir}/man1/gdalsrsinfo.1*
512%{_mandir}/man1/gdaltindex.1*
513%{_mandir}/man1/gdaltransform.1*
514%{_mandir}/man1/gdalwarp.1*
515%{_mandir}/man1/nearblack.1*
516%{_mandir}/man1/ogr2ogr.1*
517%{_mandir}/man1/ogr_utilities.1*
518%{_mandir}/man1/ogrinfo.1*
519%{_mandir}/man1/ogrlineref.1*
520%{_mandir}/man1/ogrtindex.1*
521%{_mandir}/man1/pct2rgb.1*
522%{_mandir}/man1/rgb2pct.1*
523
524%files devel
525%defattr(644,root,root,755)
526%doc _html/*
527%attr(755,root,root) %{_bindir}/gdal-config
528%attr(755,root,root) %{_libdir}/libgdal.so
529%{_libdir}/libgdal.la
530%{_pkgconfigdir}/gdal.pc
531%{_includedir}/gdal
532%{_mandir}/man1/gdal-config.1*
533
534%files static
535%defattr(644,root,root,755)
536%{_libdir}/libgdal.a
537
538%files -n perl-gdal
539%defattr(644,root,root,755)
540%dir %{perl_vendorarch}/Geo
541%{perl_vendorarch}/Geo/GDAL.pm
542%dir %{perl_vendorarch}/Geo/GDAL
543%{perl_vendorarch}/Geo/GDAL/Const.pm
544%{perl_vendorarch}/Geo/OGR.pm
545%{perl_vendorarch}/Geo/OSR.pm
546%dir %{perl_vendorarch}/auto/Geo
547%dir %{perl_vendorarch}/auto/Geo/GDAL
548%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
549%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
550%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
551%dir %{perl_vendorarch}/auto/Geo/OGR
552%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
553%dir %{perl_vendorarch}/auto/Geo/OSR
554%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
555
556%if %{with php}
557%files -n %{php_name}-gdal
558%defattr(644,root,root,755)
559%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
560%attr(755,root,root) %{php_extensiondir}/gdal.so
561%attr(755,root,root) %{php_extensiondir}/gdalconst.so
562%attr(755,root,root) %{php_extensiondir}/ogr.so
563%attr(755,root,root) %{php_extensiondir}/osr.so
564%endif
565
566%files -n python-gdal
567%defattr(644,root,root,755)
568%{py_sitedir}/gdal.py[co]
569%{py_sitedir}/gdalconst.py[co]
570%{py_sitedir}/gdalnumeric.py[co]
571%{py_sitedir}/ogr.py[co]
572%{py_sitedir}/osr.py[co]
573%{py_sitedir}/GDAL-*.egg-info
574%dir %{py_sitedir}/osgeo
575%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
576%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
577%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
578%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
579%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
580%{py_sitedir}/osgeo/*.py[co]
581
582%if %{with ruby}
583%files -n ruby-gdal
584%defattr(644,root,root,755)
585%dir %{ruby_vendorarchdir}/gdal
586%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
587%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
588%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
589%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
590%endif
This page took 0.097314 seconds and 4 git commands to generate.