]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
fixes
[packages/gcc.git] / gcc.spec
1 %define         STDC_VERSION    3.0.0
2 %define         GCJ_VERSION     3.0.0
3 %define         snap            20010319
4 Summary:        GNU Compiler Collection
5 Summary(pl):    Kolekcja kompilatorów GNU
6 Name:           gcc
7 Version:        3.0
8 Release:        0.%{snap}
9 License:        GPL
10 Group:          Development/Languages
11 Group(de):      Entwicklung/Sprachen
12 Group(pl):      Programowanie/Jêzyki
13 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/%{release}/%{name}-%{snap}.tar.gz
14 Patch0:         %{name}-disableshared.patch
15 BuildRequires:  bison
16 BuildRequires:  texinfo
17 BuildRequires:  zlib-devel
18 BuildRequires:  fileutils >= 4.0.41
19 BuildRequires:  autoconf
20 Requires:       binutils >= 2.9.1.0.25
21 Requires:       cpp = %{version}
22 URL:            http://gcc.gnu.org/
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A compiler aimed at integrating all the optimizations and features
27 necessary for a high-performance and stable development environment.
28
29 %description -l pl
30 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
31 wyprodukowania szybkiego i stablinego kodu wynikowego.
32
33 %package c++
34 Summary:        C++ support for gcc
35 Summary(fr):    Support C++ pour le compilateur gcc
36 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
37 Summary(tr):    gcc için C++ desteði
38 Group:          Development/Languages
39 Group(de):      Entwicklung/Sprachen
40 Group(pl):      Programowanie/Jêzyki
41 Obsoletes:      egcc-c++
42 Obsoletes:      egcs-c++
43
44 %description c++
45 This package adds C++ support to the GNU C compiler. It includes
46 support for most of the current C++ specification, including templates
47 and exception handling. It does not include a standard C++ library,
48 which is available separately.
49
50 %description -l de c++
51 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
52 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
53 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
54 sie ist getrennt erhältlich.
55
56 %description -l fr c++
57 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
58 support pour la plupart des spécifications actuelles de C++, dont les
59 modéles et la gestion des exceptions. Il ne comprend pas une
60 bibliothéque C++ standard, qui est disponible séparément.
61
62 %description -l pl c++
63 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
64 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
65 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
66
67 %description -l tr c++
68 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
69 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
70 C++ kitaplýðý bu pakette yer almaz.
71
72 %package objc
73 Summary:        Objective C support for gcc
74 Summary(de):    Objektive C-Unterstützung für gcc
75 Summary(fr):    Gestion d'Objective C pour gcc
76 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
77 Summary(tr):    gcc için Objective C desteði
78 Group:          Development/Languages
79 Group(de):      Entwicklung/Sprachen
80 Group(pl):      Programowanie/Jêzyki
81 Obsoletes:      egcc-objc
82 Obsoletes:      egcs-objc
83
84 %description objc
85 This package adds Objective C support to the GNU C compiler. Objective
86 C is a object oriented derivative of the C language, mainly used on
87 systems running NeXTSTEP. This package does not include the standard
88 objective C object library.
89
90 %description -l de objc
91 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
92 Objective C ist ein objektorientiertes Derivat von C, das zur
93 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
94 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
95
96 %description -l fr objc
97 Ce package ajoute un support Objective C au compilateur C GNU.
98 L'Objective C est un langage orienté objetdérivé du langage C,
99 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
100 pas la bibliothéque Objective C standard.
101
102 %description -l pl objc
103 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
104 pakiecie nie ma jeszcze bibliotek C-obj.
105
106 %description -l tr objc
107 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
108 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
109 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
110 kitaplýðý bu pakette yer almaz.
111
112 %package g77
113 Summary:        Fortran 77 support for gcc
114 Summary(pl):    Wspomaganie Fortran 77 dla gcc
115 Group:          Development/Languages
116 Group(de):      Entwicklung/Sprachen
117 Group(pl):      Programowanie/Jêzyki
118 Obsoletes:      egcs-g77
119
120 %description g77
121 This apckage adds support for compiling Fortran 77 programs with the
122 GNU compiler.
123
124 %description -l pl g77
125 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
126 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
127
128 %package chill
129 Summary:        CHILL support for gcc
130 Summary(pl):    Wspomoganie CHILL dla gcc
131 Group:          Development/Languages
132 Group(de):      Entwicklung/Sprachen
133 Group(pl):      Programowanie/Jêzyki
134 Requires:       %{name} = %{version}
135
136 %description chill
137 This package adds support for compiling CHILL programs with the GNU
138 compiler.
139
140 Chill is the "CCITT High-Level Language", where CCITT is the old name
141 for what is now ITU, the International Telecommunications Union. It is
142 is language in the Modula2 family, and targets many of the same
143 applications as Ada (especially large embedded systems). Chill was
144 never used much in the United States, but is still being used in
145 Europe, Brazil, Korea, and other places.
146
147 %package java
148 Summary:        Java support for gcc
149 Summary(pl):    Wspomoganie Java dla gcc
150 Group:          Development/Languages
151 Group(de):      Entwicklung/Sprachen
152 Group(pl):      Programowanie/Jêzyki
153 Requires:       %{name} = %{version}
154 Requires:       libgcj >= 2.95.1
155
156 %description java
157 This package adds experimental support for compiling Java(tm) programs
158 and bytecode into native code. To use this you will also need the
159 libgcj package.
160
161 %description -l pl java
162 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak
163 i do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc przeprowadziæ
164 kompilacjê.
165
166 %package -n libgcj
167 Summary:        Java Class Libraries
168 Summary(pl):    Biblioteki Klas Javy
169 Group:          Libraries
170 Version:        %{GCJ_VERSION}
171 Requires:       zlib
172
173 %description -n libgcj
174 Java Class Libraries
175
176 %description -n libgcj -l pl
177 Biblioteki Klass Javy
178
179 %package -n libgcj-devel
180 Summary:        Development files for Java Class Libraries
181 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
182 Group:          Development/Libraries
183 Group(de):      Entwicklung/Libraries
184 Group(fr):      Development/Librairies
185 Group(pl):      Programowanie/Biblioteki
186 Version:        %{GCJ_VERSION}
187 Requires:       libgcj = %{GCJ_VERSION}
188 Requires:       %{name}-java
189
190 %description -n libgcj-devel
191 Development files for Java Class Libraries
192
193 %description -n libgcj-devel -l pl
194 Pliki nag³ówkowe dla Bibliotek Klass Javy
195
196 %package -n libgcj-static
197 Summary:        Static Java Class Libraries
198 Summary(pl):    Statyczne Biblioteki Klass Javy
199 Group:          Development/Libraries
200 Group(de):      Entwicklung/Libraries
201 Group(fr):      Development/Librairies
202 Group(pl):      Programowanie/Biblioteki
203 Version:        %{GCJ_VERSION}
204 Requires:       libstdc++-devel = %{GCJ_VERSION}
205
206 %description -n libgcj-static
207 Static Java Class Libraries
208
209 %description -l pl -n libgcj-static
210 Statyczne Biblioteki Klass Javy
211
212 %package -n libstdc++
213 Summary:        GNU c++ library
214 Summary(pl):    Biblioteki GNU C++ 
215 Group:          Libraries
216 Group(de):      Libraries
217 Group(fr):      Librairies
218 Group(pl):      Biblioteki
219 Version:        %{STDC_VERSION}
220 Obsoletes:      libg++
221
222 %description -n libstdc++
223 This is the GNU implementation of the standard C++ libraries, along
224 with additional GNU tools. This package includes the shared libraries
225 necessary to run C++ applications.
226
227 %description -l de -n libstdc++
228 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
229 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
230 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
231
232 %description -l fr -n libstdc++
233 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
234 des outils GNU supplémentaires. Ce package comprend les librairies
235 partagées nécessaires à l'exécution d'application C++.
236
237 %description -l pl -n libstdc++  
238 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
239 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
240 uruchomienia aplikacji napisanych w C++.
241
242 %description -l tr -n libstdc++
243 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
244 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
245
246 %package -n libstdc++-devel
247 Summary:        Header files and libraries for C++ development
248 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
249 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
250 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
251 Group:          Development/Libraries
252 Group(de):      Entwicklung/Libraries
253 Group(fr):      Development/Librairies
254 Group(pl):      Programowanie/Biblioteki
255 Version:        %{STDC_VERSION}
256 Requires:       libstdc++ = %{STDC_VERSION}
257 Requires:       %{name}-c++
258 Obsoletes:      libg++-devel
259
260 %description -n libstdc++-devel
261 This is the GNU implementation of the standard C++ libraries. This
262 package includes the header files and libraries needed for C++
263 development.
264
265 %description -l pl -n libstdc++-devel
266 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
267 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
268 programowaniu w jêzyku C++.
269
270 %package -n libstdc++-static
271 Summary:        Static c++ standard library
272 Summary(pl):    Biblioeka statyczna c++
273 Group:          Development/Libraries
274 Group(de):      Entwicklung/Libraries
275 Group(fr):      Development/Librairies
276 Group(pl):      Programowanie/Biblioteki
277 Version:        %{STDC_VERSION}
278 Requires:       libstdc++-devel = %{STDC_VERSION}
279
280 %description -n libstdc++-static
281 Static c++ standard library.
282
283 %description -l pl -n libstdc++-static
284 Biblioteka statyczna C++.
285
286 %package -n cpp
287 Summary:        The C Pre Processor
288 Summary(pl):    Preprocesor C
289 Group:          Development/Languages
290 Group(de):      Entwicklung/Sprachen
291 Group(pl):      Programowanie/Jêzyki
292 Obsoletes:      egcs-cpp
293
294 %description -n cpp
295 The C preprocessor is a "macro processor" that is used automatically
296 by the C compiler to transform your program before actual compilation.
297 It is called a macro processor because it allows you to define
298 "macros", which are brief abbreviations for longer constructs.
299
300 The C preprocessor provides four separate facilities that you can use
301 as you see fit:
302
303 - Inclusion of header files. These are files of declarations that can
304   be substituted into your program.
305 - Macro expansion. You can define "macros", which are abbreviations
306   for arbitrary fragments of C code, and then the C preprocessor will
307   replace the macros with their definitions throughout the program.
308 - Conditional compilation. Using special preprocessing directives, you
309   can include or exclude parts of the program according to various
310   conditions.
311 - Line control. If you use a program to combine or rearrange source
312   files into an intermediate file which is then compiled, you can use
313   line control to inform the compiler of where each source line
314   originally came from.
315
316 %description -l pl -n cpp
317 Przeprocesor C jest "makro procesorem" który jest automatycznie
318 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
319 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
320 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
321 d³ugich konstrukcji w jêzyku C.
322
323 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
324
325 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
326   deklaracji polecenia do³±czenia innego pliku.
327 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
328   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
329   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
330 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
331   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
332   fragmenty obrabianego strumienia tekstów.
333 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
334   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
335   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
336   odpowiada fragment pliku wynikowego.
337
338 %prep
339 %setup -q -n %{name}-%{snap}
340 %patch0 -p1
341
342 %build
343 cd gcc && autoconf; cd ..
344 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
345
346 CFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS}" \
347 CXXFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS}" \
348 TEXCONFIG=false ../configure \
349         --prefix=%{_prefix} \
350         --infodir=%{_infodir} \
351         --mandir=%{_mandir} \
352         --enable-shared \
353 %ifarch sparc
354         --with-cpu=sparc \
355 %endif
356 %ifarch sparc64
357         --with-cpu=ultrasparc \
358 %endif
359         --enable-threads=posix \
360         --enable-haifa \
361         --enable-languages="c,gcov,c++,java,f77" \
362         --enable-long-long \
363         --enable-namespaces \
364         --enable-multilib \
365         --with-gnu-as \
366         --with-gnu-ld \
367         --with-system-zlib \
368         --without-x \
369         --disable-nls \
370         %{_target_platform}
371 # --enable-languages=objc
372 # temporary disabled (objc doesn't build right now)
373
374 PATH=$PATH:/sbin:%{_sbindir}
375
376 cd ..
377 %{__make} -C obj-%{_target_platform} bootstrap-lean \
378         LDFLAGS_FOR_TARGET="%{!?debug:-s}" \
379         mandir=%{_mandir} \
380         infodir=%{_infodir}
381
382 %install
383 rm -rf $RPM_BUILD_ROOT
384 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
385
386 cd obj-%{_target_platform}
387 PATH=$PATH:/sbin:%{_sbindir}
388
389 %{__make} install \
390         prefix=$RPM_BUILD_ROOT%{_prefix} \
391         mandir=$RPM_BUILD_ROOT%{_mandir} \
392         infodir=$RPM_BUILD_ROOT%{_infodir}
393
394 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
395
396 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
397
398 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
399
400 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
401
402 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
403
404 gzip -9nf ../READ* ../ChangeLog ../gcc/ch/chill.brochure
405
406 %post
407 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
408
409 %postun
410 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
411
412 %post g77
413 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
414
415 %postun g77
416 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
417
418 %post chill
419 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
420
421 %postun chill
422 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
423
424 %post -n cpp
425 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
426
427 %postun -n cpp
428 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
429
430 %post   -p /sbin/ldconfig -n libstdc++
431 %postun -p /sbin/ldconfig -n libstdc++
432
433 %clean
434 rm -rf $RPM_BUILD_ROOT
435
436 %files
437 %defattr(644,root,root,755)
438 %doc READ* ChangeLog.gz
439 %dir %{_libdir}/gcc-lib
440 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
441 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
442 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
443 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
444 %attr(755,root,root) %{_bindir}/gcc
445 %attr(755,root,root) %{_bindir}/gccbug
446 %attr(755,root,root) %{_bindir}/gcov
447 %attr(755,root,root) %{_bindir}/cc
448
449 %{_mandir}/man1/gcc.1*
450 %{_mandir}/man1/gcov.1*
451 %{_infodir}/gcc*
452
453 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
454 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
455 #%ifnarch alpha
456 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
457 #%endif
458 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
459 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
460
461 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
462 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
463 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
464 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
465 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
466 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
467 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
468 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
469 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
470
471 %files c++
472 %defattr(644,root,root,755)
473 %{_mandir}/man1/g++.1.gz
474 %attr(755,root,root) %{_bindir}/g++
475 %attr(755,root,root) %{_bindir}/c++
476 %attr(755,root,root) %{_bindir}/c++filt
477 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
478 %attr(755,root,root) %{_libdir}/libsupc++.la
479 %{_libdir}/libsupc++.a
480 %{_infodir}/c-tree*
481 %{_infodir}/g++int*
482
483 %ifarch temporary_disabled_does_not_compile
484 %files objc
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
487 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
488 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
489 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
490 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
491 %endif
492
493 %files g77
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_bindir}/g77
496 %attr(755,root,root) %{_bindir}/f77
497 %{_infodir}/g77*
498 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
499 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
500 %{_mandir}/man1/g77.1*
501 %{_mandir}/man1/f77.1*
502 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
503
504 %ifarch no_longer_supported_by_gcc_team
505 %files chill
506 %defattr(644,root,root,755)
507 %doc gcc/ch/chill.brochure.gz
508
509 %attr(755,root,root) %{_bindir}/chill
510 %{_infodir}/chill*
511 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
512 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
513 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
514 %endif
515
516 %files java
517 %defattr(644,root,root,755)
518 %attr(755,root,root) %{_bindir}/gcj*
519 %attr(755,root,root) %{_bindir}/gij
520 %attr(755,root,root) %{_bindir}/jcf-dump
521 %attr(755,root,root) %{_bindir}/jv-*
522 %attr(755,root,root) %{_bindir}/fastjar
523 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
524 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
525 %{_infodir}/gcj*
526
527 %files -n libgcj
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
530
531 %files -n libgcj-devel
532 %defattr(644,root,root,755)
533 %{_includedir}/java
534 %{_includedir}/gcj
535 %{_includedir}/j*.h
536 %{_includedir}/gnu/*
537 %{_libdir}/lib*cj.spec
538 %{_datadir}/libgcj.jar
539 %attr(755,root,root) %{_libdir}/lib*cj*.la
540 %attr(755,root,root) %{_libdir}/lib*cj*.so
541
542 %files -n libgcj-static
543 %defattr(644,root,root,755)
544 %{_libdir}/lib*cj*.a
545
546 %files -n libstdc++
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
549
550 %files -n libstdc++-devel
551 %defattr(644,root,root,755)
552 %{_includedir}/g++*
553 %{_prefix}/%{_target_cpu}*
554 %attr(755,root,root) %{_libdir}/libstdc++.so
555
556 %files -n libstdc++-static
557 %defattr(644,root,root,755)
558 %attr(644,root,root) %{_libdir}/libstdc++.a
559
560 %files -n cpp
561 %defattr(644,root,root,755)
562 %attr(755,root,root) /lib/cpp
563 %attr(755,root,root) %{_bindir}/cpp
564 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
565 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
566 %{_mandir}/man1/cpp.1*
567 %{_infodir}/cpp*
This page took 0.435808 seconds and 3 git commands to generate.