]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
- updated to 3.0.1
[packages/gcc.git] / gcc.spec
1 %define         GCC_VERSION     3.0.1
2 %define         STDC_VERSION    3.0.1
3 %define         GCJ_VERSION     3.0.1
4 Summary:        GNU Compiler Collection
5 Summary(pl):    Kolekcja kompilatorów GNU
6 Name:           gcc
7 Version:        %{GCC_VERSION}
8 Release:        0.1
9 License:        GPL
10 Group:          Development/Languages
11 Group(de):      Entwicklung/Sprachen
12 Group(pl):      Programowanie/Jêzyki
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
14 Patch0:         gcc-DESTDIR.patch
15 BuildRequires:  bison
16 BuildRequires:  texinfo
17 BuildRequires:  zlib-devel
18 BuildRequires:  fileutils >= 4.0.41
19 BuildRequires:  autoconf
20 Requires:       binutils >= 2.9.1.0.25
21 Requires:       cpp = %{version}
22 URL:            http://gcc.gnu.org/
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _slibdir        /lib
26
27 %description
28 A compiler aimed at integrating all the optimizations and features
29 necessary for a high-performance and stable development environment.
30
31 %description -l pl
32 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
33 wyprodukowania szybkiego i stablinego kodu wynikowego.
34
35 %package c++
36 Summary:        C++ support for gcc
37 Summary(fr):    Support C++ pour le compilateur gcc
38 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
39 Summary(tr):    gcc için C++ desteði
40 Group:          Development/Languages
41 Group(de):      Entwicklung/Sprachen
42 Group(pl):      Programowanie/Jêzyki
43 Obsoletes:      egcc-c++
44 Obsoletes:      egcs-c++
45
46 %description c++
47 This package adds C++ support to the GNU C compiler. It includes
48 support for most of the current C++ specification, including templates
49 and exception handling. It does not include a standard C++ library,
50 which is available separately.
51
52 %description -l de c++
53 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
54 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
55 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
56 sie ist getrennt erhältlich.
57
58 %description -l fr c++
59 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
60 support pour la plupart des spécifications actuelles de C++, dont les
61 modéles et la gestion des exceptions. Il ne comprend pas une
62 bibliothéque C++ standard, qui est disponible séparément.
63
64 %description -l pl c++
65 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
66 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
67 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
68
69 %description -l tr c++
70 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
71 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
72 C++ kitaplýðý bu pakette yer almaz.
73
74 %package objc
75 Summary:        Objective C support for gcc
76 Summary(de):    Objektive C-Unterstützung für gcc
77 Summary(fr):    Gestion d'Objective C pour gcc
78 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
79 Summary(tr):    gcc için Objective C desteði
80 Group:          Development/Languages
81 Group(de):      Entwicklung/Sprachen
82 Group(pl):      Programowanie/Jêzyki
83 Obsoletes:      egcc-objc
84 Obsoletes:      egcs-objc
85
86 %description objc
87 This package adds Objective C support to the GNU C compiler. Objective
88 C is a object oriented derivative of the C language, mainly used on
89 systems running NeXTSTEP. This package does not include the standard
90 objective C object library.
91
92 %description -l de objc
93 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
94 Objective C ist ein objektorientiertes Derivat von C, das zur
95 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
96 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
97
98 %description -l fr objc
99 Ce package ajoute un support Objective C au compilateur C GNU.
100 L'Objective C est un langage orienté objetdérivé du langage C,
101 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
102 pas la bibliothéque Objective C standard.
103
104 %description -l pl objc
105 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
106 pakiecie nie ma jeszcze bibliotek C-obj.
107
108 %description -l tr objc
109 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
110 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
111 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
112 kitaplýðý bu pakette yer almaz.
113
114 %package g77
115 Summary:        Fortran 77 support for gcc
116 Summary(pl):    Wspomaganie Fortran 77 dla gcc
117 Group:          Development/Languages
118 Group(de):      Entwicklung/Sprachen
119 Group(pl):      Programowanie/Jêzyki
120 Obsoletes:      egcs-g77
121
122 %description g77
123 This apckage adds support for compiling Fortran 77 programs with the
124 GNU compiler.
125
126 %description -l pl g77
127 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
128 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
129
130 %package chill
131 Summary:        CHILL support for gcc
132 Summary(pl):    Wspomoganie CHILL dla gcc
133 Group:          Development/Languages
134 Group(de):      Entwicklung/Sprachen
135 Group(pl):      Programowanie/Jêzyki
136 Requires:       %{name} = %{version}
137
138 %description chill
139 This package adds support for compiling CHILL programs with the GNU
140 compiler.
141
142 Chill is the "CCITT High-Level Language", where CCITT is the old name
143 for what is now ITU, the International Telecommunications Union. It is
144 is language in the Modula2 family, and targets many of the same
145 applications as Ada (especially large embedded systems). Chill was
146 never used much in the United States, but is still being used in
147 Europe, Brazil, Korea, and other places.
148
149 %package java
150 Summary:        Java support for gcc
151 Summary(pl):    Wspomoganie Java dla gcc
152 Group:          Development/Languages
153 Group(de):      Entwicklung/Sprachen
154 Group(pl):      Programowanie/Jêzyki
155 Requires:       %{name} = %{version}
156 Requires:       libgcj >= 3.0.0
157
158 %description java
159 This package adds experimental support for compiling Java(tm) programs
160 and bytecode into native code. To use this you will also need the
161 libgcj package.
162
163 %description -l pl java
164 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
165 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
166 przeprowadziæ kompilacjê.
167
168 %package -n libgcj
169 Summary:        Java Class Libraries
170 Summary(pl):    Biblioteki Klas Javy
171 Group:          Libraries
172 Group(de):      Libraries
173 Group(es):      Bibliotecas
174 Group(fr):      Librairies
175 Group(pl):      Biblioteki
176 Version:        %{GCJ_VERSION}
177 Epoch:          2
178 Requires:       zlib
179
180 %description -n libgcj
181 Java Class Libraries
182
183 %description -n libgcj -l pl
184 Biblioteki Klass Javy
185
186 %package -n libgcj-devel
187 Summary:        Development files for Java Class Libraries
188 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
189 Group:          Development/Libraries
190 Group(de):      Entwicklung/Libraries
191 Group(fr):      Development/Librairies
192 Group(pl):      Programowanie/Biblioteki
193 Version:        %{GCJ_VERSION}
194 Epoch:          2
195 Requires:       libgcj = %{GCJ_VERSION}
196 Requires:       %{name}-java
197
198 %description -n libgcj-devel
199 Development files for Java Class Libraries
200
201 %description -n libgcj-devel -l pl
202 Pliki nag³ówkowe dla Bibliotek Klass Javy
203
204 %package -n libgcj-static
205 Summary:        Static Java Class Libraries
206 Summary(pl):    Statyczne Biblioteki Klass Javy
207 Group:          Development/Libraries
208 Group(de):      Entwicklung/Libraries
209 Group(fr):      Development/Librairies
210 Group(pl):      Programowanie/Biblioteki
211 Version:        %{GCJ_VERSION}
212 Epoch:          2
213 Requires:       libstdc++-devel = %{GCJ_VERSION}
214
215 %description -n libgcj-static
216 Static Java Class Libraries
217
218 %description -l pl -n libgcj-static
219 Statyczne Biblioteki Klass Javy
220
221 %package -n libstdc++
222 Summary:        GNU c++ library
223 Summary(pl):    Biblioteki GNU C++ 
224 Group:          Libraries
225 Group(de):      Libraries
226 Group(es):      Bibliotecas
227 Group(fr):      Librairies
228 Group(pl):      Biblioteki
229 Version:        %{STDC_VERSION}
230 Obsoletes:      libg++
231
232 %description -n libstdc++
233 This is the GNU implementation of the standard C++ libraries, along
234 with additional GNU tools. This package includes the shared libraries
235 necessary to run C++ applications.
236
237 %description -l de -n libstdc++
238 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
239 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
240 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
241
242 %description -l fr -n libstdc++
243 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
244 des outils GNU supplémentaires. Ce package comprend les librairies
245 partagées nécessaires à l'exécution d'application C++.
246
247 %description -l pl -n libstdc++  
248 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
249 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
250 uruchomienia aplikacji napisanych w C++.
251
252 %description -l tr -n libstdc++
253 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
254 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
255
256 %package -n libstdc++-devel
257 Summary:        Header files and libraries for C++ development
258 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
259 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
260 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
261 Group:          Development/Libraries
262 Group(de):      Entwicklung/Libraries
263 Group(fr):      Development/Librairies
264 Group(pl):      Programowanie/Biblioteki
265 Version:        %{STDC_VERSION}
266 Requires:       libstdc++ = %{STDC_VERSION}
267 Requires:       %{name}-c++
268 Obsoletes:      libg++-devel
269
270 %description -n libstdc++-devel
271 This is the GNU implementation of the standard C++ libraries. This
272 package includes the header files and libraries needed for C++
273 development.
274
275 %description -l pl -n libstdc++-devel
276 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
277 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
278 programowaniu w jêzyku C++.
279
280 %package -n libstdc++-static
281 Summary:        Static c++ standard library
282 Summary(pl):    Biblioteka statyczna c++
283 Group:          Development/Libraries
284 Group(de):      Entwicklung/Libraries
285 Group(fr):      Development/Librairies
286 Group(pl):      Programowanie/Biblioteki
287 Version:        %{STDC_VERSION}
288 Requires:       libstdc++-devel = %{STDC_VERSION}
289
290 %description -n libstdc++-static
291 Static c++ standard library.
292
293 %description -l pl -n libstdc++-static
294 Biblioteka statyczna C++.
295
296 %package -n libgcc
297 Summary:        Shared gcc library
298 Summary(pl):    Biblioteka gcc
299 Group:          Libraries
300 Group(de):      Libraries
301 Group(fr):      Librairies
302 Group(pl):      Biblioteki
303 Version:        %{version}
304
305 %description -n libgcc
306 Shared gcc library.
307
308 %description -l pl -n libgcc
309 Biblioteka dynamiczna gcc.
310
311 %package -n cpp
312 Summary:        The C Pre Processor
313 Summary(pl):    Preprocesor C
314 Group:          Development/Languages
315 Group(de):      Entwicklung/Sprachen
316 Group(pl):      Programowanie/Jêzyki
317 Version:        %{version}
318 Obsoletes:      egcs-cpp
319 Obsoletes:      gcc-cpp
320
321 %description -n cpp
322 The C preprocessor is a "macro processor" that is used automatically
323 by the C compiler to transform your program before actual compilation.
324 It is called a macro processor because it allows you to define
325 "macros", which are brief abbreviations for longer constructs.
326
327 The C preprocessor provides four separate facilities that you can use
328 as you see fit:
329
330 - Inclusion of header files. These are files of declarations that can
331   be substituted into your program.
332 - Macro expansion. You can define "macros", which are abbreviations
333   for arbitrary fragments of C code, and then the C preprocessor will
334   replace the macros with their definitions throughout the program.
335 - Conditional compilation. Using special preprocessing directives, you
336   can include or exclude parts of the program according to various
337   conditions.
338 - Line control. If you use a program to combine or rearrange source
339   files into an intermediate file which is then compiled, you can use
340   line control to inform the compiler of where each source line
341   originally came from.
342
343 %description -l pl -n cpp
344 Przeprocesor C jest "makro procesorem" który jest automatycznie
345 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
346 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
347 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
348 d³ugich konstrukcji w jêzyku C.
349
350 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
351
352 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
353   deklaracji polecenia do³±czenia innego pliku.
354 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
355   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
356   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
357 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
358   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
359   fragmenty obrabianego strumienia tekstów.
360 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
361   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
362   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
363   odpowiada fragment pliku wynikowego.
364
365 %prep
366 %setup -q -n %{name}-%{GCC_VERSION}
367 %patch0 -p1
368
369 %build
370 # cd gcc && autoconf; cd ..
371 # autoconf is not needed!
372 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
373
374 CFLAGS="%{rpmcflags}" \
375 CXXFLAGS="%{rpmcflags}" \
376 TEXCONFIG=false ../configure \
377         --prefix=%{_prefix} \
378         --infodir=%{_infodir} \
379         --mandir=%{_mandir} \
380         --enable-shared \
381 %ifarch sparc
382         --with-cpu=sparc \
383 %endif
384 %ifarch sparc64
385         --with-cpu=ultrasparc \
386 %endif
387         --enable-threads=posix \
388         --enable-haifa \
389         --enable-languages="c,c++,f77,gcov,java,objc" \
390         --enable-long-long \
391         --enable-namespaces \
392         --enable-multilib \
393         --with-gnu-as \
394         --with-gnu-ld \
395         --with-system-zlib \
396         --with-slibdir=%{_slibdir} \
397         --without-x \
398         %{_target_platform}
399
400 PATH=$PATH:/sbin:%{_sbindir}
401
402 cd ..
403 %{__make} -C obj-%{_target_platform} bootstrap-lean \
404         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
405         mandir=%{_mandir} \
406         infodir=%{_infodir}
407
408 %install
409 rm -rf $RPM_BUILD_ROOT
410 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
411
412 cd obj-%{_target_platform}
413 PATH=$PATH:/sbin:%{_sbindir}
414
415 %{__make} install \
416         prefix=$RPM_BUILD_ROOT%{_prefix} \
417         mandir=$RPM_BUILD_ROOT%{_mandir} \
418         infodir=$RPM_BUILD_ROOT%{_infodir} \
419         DESTDIR=$RPM_BUILD_ROOT
420
421 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
422
423 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
424
425 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
426
427 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
428  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/ ; \
429  ln -sf ../../../${LIBSTDC} libstdc++.so)
430
431 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
432         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
433
434 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
435
436 gzip -9nf ../READ* ../ChangeLog
437
438 %post
439 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
440
441 %postun
442 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
443
444 %post g77
445 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
446
447 %postun g77
448 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
449
450 %post chill
451 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
452
453 %postun chill
454 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
455
456 %post -n cpp
457 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
458
459 %postun -n cpp
460 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
461
462 %post   -p /sbin/ldconfig -n libgcc
463 %postun -p /sbin/ldconfig -n libgcc
464 %post   -p /sbin/ldconfig -n libstdc++
465 %postun -p /sbin/ldconfig -n libstdc++
466 %post   -p /sbin/ldconfig -n libgcj
467 %postun -p /sbin/ldconfig -n libgcj
468
469 %clean
470 rm -rf $RPM_BUILD_ROOT
471
472 %files
473 %defattr(644,root,root,755)
474 %doc READ* ChangeLog.gz
475 %dir %{_libdir}/gcc-lib
476 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
477 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
478 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
479 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
480 %attr(755,root,root) %{_bindir}/gcc
481 %attr(755,root,root) %{_bindir}/gccbug
482 %attr(755,root,root) %{_bindir}/gcov
483 %attr(755,root,root) %{_bindir}/cc
484
485 %{_mandir}/man1/gcc.1*
486 %{_mandir}/man1/gcov.1*
487 %{_infodir}/gcc*
488
489 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
490 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
491 #%ifnarch alpha
492 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
493 #%endif
494 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
495 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
496
497 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
498 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
499 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
500 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
501 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
502 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
503 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
504 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
505 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
506
507 %files c++
508 %defattr(644,root,root,755)
509 %{_mandir}/man1/g++.1.gz
510 %attr(755,root,root) %{_bindir}/g++
511 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
512 %attr(755,root,root) %{_bindir}/c++
513 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
514 %attr(755,root,root) %{_bindir}/c++filt
515 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
516 %attr(755,root,root) %{_libdir}/libsupc++.la
517 %{_libdir}/libsupc++.a
518
519 %files objc
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
522 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
523 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
524 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
525 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
526
527 %files g77
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_bindir}/g77
530 %attr(755,root,root) %{_bindir}/f77
531 %{_infodir}/g77*
532 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
533 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
534 %{_mandir}/man1/g77.1*
535 %{_mandir}/man1/f77.1*
536 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
537
538 %ifarch no_longer_supported_by_gcc_team
539 %files chill
540 %defattr(644,root,root,755)
541 %doc gcc/ch/chill.brochure.gz
542
543 %attr(755,root,root) %{_bindir}/chill
544 %{_infodir}/chill*
545 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
546 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
547 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
548 %endif
549
550 %files java
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_bindir}/gcj*
553 %attr(755,root,root) %{_bindir}/gij
554 %attr(755,root,root) %{_bindir}/jcf-dump
555 %attr(755,root,root) %{_bindir}/jv-*
556 %attr(755,root,root) %{_bindir}/jar
557 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
558 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
559 %{_infodir}/gcj*
560
561 %files -n libgcj
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_bindir}/addr2name.awk
564 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
565
566 %files -n libgcj-devel
567 %defattr(644,root,root,755)
568 %{_includedir}/java
569 %{_includedir}/gcj
570 %{_includedir}/j*.h
571 %{_includedir}/gnu/*
572 %{_libdir}/lib*cj.spec
573 %{_datadir}/libgcj.jar
574 %attr(755,root,root) %{_libdir}/lib*cj*.la
575 %attr(755,root,root) %{_libdir}/lib*cj*.so
576
577 %files -n libgcj-static
578 %defattr(644,root,root,755)
579 %{_libdir}/lib*cj*.a
580
581 %files -n libstdc++
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
584
585 %files -n libstdc++-devel
586 %defattr(644,root,root,755)
587 %{_includedir}/g++*
588 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
589
590 %files -n libstdc++-static
591 %defattr(644,root,root,755)
592 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
593
594 %files -n libgcc
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_slibdir}/lib*.so*
597
598 %files -n cpp
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_slibdir}/cpp
601 %attr(755,root,root) %{_bindir}/cpp
602 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
603 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
604 %{_mandir}/man1/cpp.1*
605 %{_infodir}/cpp*
This page took 0.091968 seconds and 3 git commands to generate.