]> git.pld-linux.org Git - packages/gcc.git/blob - gcc.spec
- update epoch
[packages/gcc.git] / gcc.spec
1 #
2 # Conditional build:
3 # _without_ada  - build without ADA support
4 # _without_java - build without Java support
5 #
6 %define         DASHED_SNAP     20021111        
7 %define         SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
8 %define         GCC_VERSION     3.2.1
9 %define         KSI_VERSION     pre55
10 %define         EPOCH           4
11
12 Summary:        GNU Compiler Collection
13 Summary(pl):    Kolekcja kompilatorów GNU
14 Name:           gcc
15 Version:        %{GCC_VERSION}
16 Release:        0.pre.2
17 Epoch:          %{EPOCH}
18 License:        GPL
19 Group:          Development/Languages
20 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}-%{SNAP}.tar.bz2
21 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
22 Source2:        %{name}-non-english-man-pages.tar.bz2
23 Patch0:         %{name}-slibdir.patch
24 Patch1:         %{name}-paths.patch
25 Patch2:         %{name}-ada-no-addr2line.patch
26 Patch3:         %{name}-ada-no-prefix.o.patch
27 Patch4:         %{name}-nolocalefiles.patch
28
29 Patch6:         %{name}-info.patch
30 # -- stolen patches from RH --
31 Patch10:        gcc32-ada-link.patch
32 Patch11:        gcc32-attr-visibility.patch
33 Patch12:        gcc32-attr-visibility2.patch
34 Patch13:        gcc32-attr-visibility3.patch
35 Patch14:        gcc32-attr-visibility4.patch
36 Patch15:        gcc32-attr-visibility5.patch
37 Patch16:        gcc32-boehm-gc-libs.patch
38 Patch17:        gcc32-bogus-inline.patch
39 Patch18:        gcc32-c++-nrv-test.patch
40 Patch19:        gcc32-c++-pretty_function.patch
41 Patch20:        gcc32-c++-tsubst-asm.patch
42 Patch21:        gcc32-cfg-eh.patch
43 Patch22:        gcc32-debug-pr7241.patch
44
45 Patch24:        gcc32-duplicate-decl.patch
46 Patch25:        gcc32-dwarf2-pr6381.patch 
47 Patch26:        gcc32-dwarf2-pr6436-test.patch
48 Patch27:        gcc32-fde-merge-compat.patch 
49 Patch28:        gcc32-fold-const-associate.patch
50 Patch29:        gcc32-hard-reg-sharing.patch
51 Patch30:        gcc32-hard-reg-sharing2.patch 
52 Patch31:        gcc32-i386-default-momit-leaf-frame-pointer.patch
53 Patch32:        gcc32-i386-memtest-test.patch 
54 Patch33:        gcc32-i386-no-default-momit-leaf-frame-pointer.patch
55 Patch34:        gcc32-i386-pic-label-thunk.patch
56 Patch35:        gcc32-i386-profile-olfp.patch
57 Patch36:        gcc32-inline-label.patch 
58 Patch37:        gcc32-java-no-rpath.patch
59 Patch38:        gcc32-pr6842.patch 
60 Patch39:        gcc32-sparc-sll1.patch
61 Patch40:        gcc32-test-rh65771.patch 
62 Patch41:        gcc32-test-rotate.patch  
63 Patch42:        gcc32-tls-dwarf2.patch 
64 Patch43:        gcc32-tls.patch      
65 Patch44:        gcc32-tls2.patch 
66 Patch45:        gcc32-tls3.patch
67 Patch46:        gcc32-tls4.patch 
68 Patch47:        gcc32-tls5.patch    
69 BuildRequires:  autoconf
70 BuildRequires:  bison
71 BuildRequires:  fileutils >= 4.0.41
72 BuildRequires:  gcc
73 %{!?_without_ada:BuildRequires: gcc-ada}
74 BuildRequires:  glibc-devel >= 2.2.5-20
75 BuildRequires:  perl-devel
76 BuildRequires:  texinfo >= 4.1
77 BuildRequires:  zlib-devel
78 BuildRequires:  gettext-devel
79 Requires:       binutils >= 2.12.90.0.4
80 Requires:       cpp = %{GCC_VERSION}
81 Requires:       libgcc = %{GCC_VERSION}
82 Conflicts:      glibc-devel < 2.2.5-20
83 URL:            http://gcc.gnu.org/
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         _slibdir        /lib
87
88 %description
89 A compiler aimed at integrating all the optimizations and features
90 necessary for a high-performance and stable development environment.
91
92 %description -l pl
93 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
94 wyprodukowania szybkiego i stablinego kodu wynikowego.
95
96 %package -n libgcc
97 Summary:        Shared gcc library
98 Summary(pl):    Biblioteka gcc
99 Group:          Libraries
100 Version:        %{GCC_VERSION}
101
102 %description -n libgcc
103 Shared gcc library.
104
105 %description -n libgcc -l pl
106 Biblioteka dynamiczna gcc.
107
108 %package c++
109 Summary:        C++ support for gcc
110 Summary(pl):    Obs³uga C++ dla gcc
111 Group:          Development/Languages
112 Obsoletes:      egcc-c++
113 Obsoletes:      egcs-c++
114 Requires:       gcc = %{GCC_VERSION}
115
116 %description c++
117 This package adds C++ support to the GNU C compiler. It includes
118 support for most of the current C++ specification, including templates
119 and exception handling. It does not include a standard C++ library,
120 which is available separately.
121
122 %description c++ -l de
123 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
124 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
125 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
126 sie ist getrennt erhältlich.
127
128 %description c++ -l fr
129 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
130 support pour la plupart des spécifications actuelles de C++, dont les
131 modéles et la gestion des exceptions. Il ne comprend pas une
132 bibliothéque C++ standard, qui est disponible séparément.
133
134 %description c++ -l pl
135 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
136 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
137 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
138
139 %description c++ -l tr
140 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
141 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
142 C++ kitaplýðý bu pakette yer almaz.
143
144 %package objc
145 Summary:        Objective C support for gcc
146 Summary(de):    Objektive C-Unterstützung für gcc
147 Summary(fr):    Gestion d'Objective C pour gcc
148 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
149 Summary(tr):    gcc için Objective C desteði
150 Group:          Development/Languages
151 Obsoletes:      egcc-objc
152 Obsoletes:      egcs-objc
153 Requires:       libobjc = %{GCC_VERSION}
154 Requires:       gcc = %{GCC_VERSION}
155
156 %description objc
157 This package adds Objective C support to the GNU C compiler. Objective
158 C is a object oriented derivative of the C language, mainly used on
159 systems running NeXTSTEP. This package does not include the standard
160 objective C object library.
161
162 %description objc -l de
163 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
164 Objective C ist ein objektorientiertes Derivat von C, das zur
165 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
166 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
167
168 %description objc -l fr
169 Ce package ajoute un support Objective C au compilateur C GNU.
170 L'Objective C est un langage orienté objetdérivé du langage C,
171 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
172 pas la bibliothéque Objective C standard.
173
174 %description objc -l pl
175 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
176 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
177 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
178 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
179
180 %description objc -l tr
181 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
182 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
183 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
184 kitaplýðý bu pakette yer almaz.
185
186 %package -n libobjc
187 Summary:        Objective C Libraries
188 Summary(pl):    Biblioteki Obiektowego C
189 Group:          Libraries
190 Version:        %{GCC_VERSION}
191
192 %description -n libobjc
193 Objective C Libraries.
194
195 %description -n libobjc -l pl
196 Biblioteki Obiektowego C.
197
198 %package -n libobjc-static
199 Summary:        Static Objective C Libraries
200 Summary(pl):    Statyczne Biblioteki Obiektowego C
201 Group:          Development/Libraries
202 Version:        %{GCC_VERSION}
203 Requires:       libobjc = %{GCC_VERSION}
204
205 %description -n libobjc-static
206 Static Objective C Libraries.
207
208 %description -n libobjc-static -l pl
209 Statyczne biblioteki Obiektowego C.
210
211 %package g77
212 Summary:        Fortran 77 support for gcc
213 Summary(pl):    Obs³uga Fortranu 77 dla gcc
214 Group:          Development/Languages
215 Version:        %{GCC_VERSION}
216 Obsoletes:      egcs-g77
217 Requires:       libg2c = %{GCC_VERSION}
218
219 %description g77
220 This apckage adds support for compiling Fortran 77 programs with the
221 GNU compiler.
222
223 %description g77 -l pl
224 Ten pakiet dodaje obs³ugê Fortranu 77 do kompilatora gcc. Jest
225 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
226
227 %package -n libg2c
228 Summary:        Fortran 77 Libraries
229 Summary(pl):    Biblioteki Fortranu 77
230 Group:          Libraries
231 Version:        %{GCC_VERSION}
232
233 %description -n libg2c
234 Fortran 77 Libraries.
235
236 %description -n libg2c -l pl
237 Biblioteki Fortranu 77.
238
239 %package -n libg2c-static
240 Summary:        Static Fortran 77 Libraries
241 Summary(pl):    Statyczne Biblioteki Fortranu 77
242 Group:          Development/Libraries
243 Version:        %{GCC_VERSION}
244 Requires:       libg2c = %{GCC_VERSION}
245
246 %description -n libg2c-static
247 Static Fortran 77 Libraries.
248
249 %description -n libg2c-static -l pl
250 Statyczne biblioteki Fortranu 77.
251
252 %package java
253 Summary:        Java support for gcc
254 Summary(pl):    Obs³uga Javy dla gcc
255 Group:          Development/Languages
256 Version:        %{GCC_VERSION}
257 Requires:       %{name} = %{version}
258 Requires:       libgcj >= 3.0.0
259 Provides:       gcj = %{epoch}:%{GCC_VERSION}-%{release}
260 Provides:       jar = %{epoch}:%{GCC_VERSION}-%{release}
261
262 %description java
263 This package adds experimental support for compiling Java(tm) programs
264 and bytecode into native code. To use this you will also need the
265 libgcj package.
266
267 %description -l pl java
268 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
269 do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
270 by³o przeprowadziæ kompilacjê.
271
272 %package -n libgcj
273 Summary:        Java Class Libraries
274 Summary(pl):    Biblioteki Klas Javy
275 Group:          Libraries
276 Version:        %{GCC_VERSION}
277 Requires:       zlib
278
279 %description -n libgcj
280 Java Class Libraries.
281
282 %description -n libgcj -l pl
283 Biblioteki Klas Javy.
284
285 %package -n libgcj-devel
286 Summary:        Development files for Java Class Libraries
287 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
288 Group:          Development/Libraries
289 Version:        %{GCC_VERSION}
290 Requires:       libgcj = %{GCC_VERSION}
291 Requires:       %{name}-java
292
293 %description -n libgcj-devel
294 Development files for Java Class Libraries.
295
296 %description -n libgcj-devel -l pl
297 Pliki nag³ówkowe dla Bibliotek Klas Javy.
298
299 %package -n libgcj-static
300 Summary:        Static Java Class Libraries
301 Summary(pl):    Statyczne Biblioteki Klas Javy
302 Group:          Development/Libraries
303 Version:        %{GCC_VERSION}
304 Requires:       libstdc++-devel = %{GCC_VERSION}
305 Requires:       libgcj-devel = %{GCC_VERSION}
306
307 %description -n libgcj-static
308 Static Java Class Libraries.
309
310 %description -n libgcj-static -l pl
311 Statyczne Biblioteki Klas Javy.
312
313 %package -n libstdc++
314 Summary:        GNU c++ library
315 Summary(pl):    Biblioteki GNU C++ 
316 Group:          Libraries
317 Version:        %{GCC_VERSION}
318 Obsoletes:      libg++
319
320 %description -n libstdc++
321 This is the GNU implementation of the standard C++ libraries, along
322 with additional GNU tools. This package includes the shared libraries
323 necessary to run C++ applications.
324
325 %description -n libstdc++ -l de
326 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
327 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
328 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
329
330 %description -n libstdc++ -l fr
331 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
332 des outils GNU supplémentaires. Ce package comprend les librairies
333 partagées nécessaires à l'exécution d'application C++.
334
335 %description -n libstdc++ -l pl
336 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
337 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
338 uruchomienia aplikacji napisanych w C++.
339
340 %description -n libstdc++ -l tr
341 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
342 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
343
344 %package -n libstdc++-devel
345 Summary:        Header files and documentatino for C++ development
346 Summary(de):    Header-Dateien zur Entwicklung mit C++
347 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
348 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
349 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
350 Group:          Development/Libraries
351 Version:        %{GCC_VERSION}
352 Requires:       libstdc++ = %{GCC_VERSION}
353 Requires:       %{name}-c++
354 Obsoletes:      libg++-devel
355
356 %description -n libstdc++-devel
357 This is the GNU implementation of the standard C++ libraries. This
358 package includes the header files needed for C++ development and
359 library documentation.
360
361 %description -n libstdc++-devel -l pl
362 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
363 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
364 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
365
366 %package -n libstdc++-static
367 Summary:        Static C++ standard library
368 Summary(pl):    Statyczna biblioteka standardowa C++
369 Group:          Development/Libraries
370 Version:        %{GCC_VERSION}
371 Requires:       libstdc++-devel = %{GCC_VERSION}
372
373 %description -n libstdc++-static
374 Static C++ standard library.
375
376 %description -n libstdc++-static -l pl
377 Statycza biblioteka standardowa C++.
378
379 %package ada
380 Summary:        Ada support for gcc
381 Summary(pl):    Obs³uga Ady do gcc
382 Group:          Development/Languages
383 Version:        %{GCC_VERSION}
384 Requires:       libgnat = %{GCC_VERSION}
385 Requires:       gcc = %{GCC_VERSION}
386 Obsoletes:      gcc-gnat
387 Obsoletes:      gnat-devel
388
389 %description ada
390 This package adds experimental support for compiling Ada programs.
391
392 %description -l pl ada
393 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
394 w Adzie.
395
396 %package -n libgnat
397 Summary:        Ada standard libraries
398 Summary(pl):    Biblioteki standardowe dla Ady
399 Group:          Libraries
400 Version:        %{GCC_VERSION}
401 Obsoletes:      gnat
402
403 %description -n libgnat
404 This package contains shared libraries needed to run programs written
405 in Ada.
406
407 %description -n libgnat -l pl
408 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów napisanych
409 w Adzie.
410
411 %package -n libgnat-static
412 Summary:        Static Ada standard libraries
413 Summary(pl):    Statyczne biblioteki standardowe dla Ady
414 Group:          Libraries
415 Version:        %{GCC_VERSION}
416 Obsoletes:      gnat-static
417
418 %description -n libgnat-static
419 This package contains static libraries for programs written in Ada.
420
421 %description -n libgnat-static -l pl
422 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
423 Adzie.
424
425 %package ksi
426 Summary:        Ksi support for gcc
427 Summary(pl):    Obs³uga Ksi dla gcc
428 Version:        %{GCC_VERSION}.%{KSI_VERSION}
429 Group:          Development/Languages
430 Requires:       gcc = %{GCC_VERSION}
431
432 %description ksi
433 This package adds experimental support for compiling Ksi programs
434 into native code. You proabably don't need it, unless your are going
435 to develop a compiler using Ksi as intermediate representation or
436 you are using such compiler (like Gont).
437
438 %description ksi -l pl
439 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
440 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
441 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jako reprezentacji
442 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
443
444 %package -n cpp
445 Summary:        The C Pre Processor
446 Summary(pl):    Preprocesor C
447 Group:          Development/Languages
448 Version:        %{GCC_VERSION}
449 Obsoletes:      egcs-cpp
450 Obsoletes:      gcc-cpp
451
452 %description -n cpp
453 The C preprocessor is a "macro processor" that is used automatically
454 by the C compiler to transform your program before actual compilation.
455 It is called a macro processor because it allows you to define
456 "macros", which are brief abbreviations for longer constructs.
457
458 The C preprocessor provides four separate facilities that you can use
459 as you see fit:
460
461 - Inclusion of header files. These are files of declarations that can
462   be substituted into your program.
463 - Macro expansion. You can define "macros", which are abbreviations
464   for arbitrary fragments of C code, and then the C preprocessor will
465   replace the macros with their definitions throughout the program.
466 - Conditional compilation. Using special preprocessing directives, you
467   can include or exclude parts of the program according to various
468   conditions.
469 - Line control. If you use a program to combine or rearrange source
470   files into an intermediate file which is then compiled, you can use
471   line control to inform the compiler of where each source line
472   originally came from.
473
474 %description -n cpp -l pl
475 Przeprocesor C jest "makro procesorem" który jest automatycznie
476 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
477 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
478 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
479 d³ugich konstrukcji w jêzyku C.
480
481 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
482
483 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
484   deklaracji polecenia do³±czenia innego pliku.
485 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
486   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
487   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
488 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
489   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
490   fragmenty obrabianego strumienia tekstów.
491 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
492   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
493   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
494   odpowiada fragment pliku wynikowego.
495
496 %prep
497 %setup -q -a1 -n %{name}-%{GCC_VERSION}-%{SNAP}
498 mv ksi-%{KSI_VERSION} gcc/ksi
499
500 %patch0 -p1
501 %patch1 -p1
502 %patch2 -p1
503 %patch3 -p1
504 %patch4 -p1
505
506 %patch10 
507 %patch11 
508 %patch12 
509 %patch13 
510 %patch14 
511 %patch15 
512 %patch16 
513 %patch17 
514 %patch18 
515 %patch19 
516 %patch20 
517 %patch21 
518 %patch22 
519
520 %patch24 
521 %patch25 
522 %patch26 
523 %patch27 
524 %patch28 
525 %patch29 
526 %patch30 
527 %patch31 
528 %patch32 
529 %patch33 
530 %patch34 
531 %patch35 
532 %patch36 
533 %patch37 
534 %patch38 
535 %patch39 
536 %patch40 
537 %patch41 
538 %patch42 
539 %patch43
540 %patch44 
541 %patch45 
542 %patch46
543 %patch47
544
545 %patch6 -p1
546
547 %build
548 # cd gcc && autoconf; cd ..
549 # autoconf is not needed!
550 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform}
551
552 CFLAGS="%{rpmcflags}" \
553 CXXFLAGS="%{rpmcflags}" \
554 TEXCONFIG=false ../configure \
555         --prefix=%{_prefix} \
556         --infodir=%{_infodir} \
557         --mandir=%{_mandir} \
558         --enable-shared \
559         --enable-threads=posix \
560         --enable-__cxa_atexit \
561         --enable-languages="c,c++,f77,gcov,objc,ksi%{!?_without_ada:,ada}%{!?_without_java:,java}" \
562         --enable-c99 \
563         --enable-long-long \
564         --enable-multilib \
565         --enable-nls \
566         --with-gnu-as \
567         --with-gnu-ld \
568         --with-system-zlib \
569         --with-slibdir=%{_slibdir} \
570         --without-x \
571         %{_target_platform}
572
573 PATH=$PATH:/sbin:%{_sbindir}
574
575 # this dirty hack is relict of setting, where objdir is subdir of srcdir
576 %if %{!?_without_ada:1}%{?_without_ada:0}
577 sed -e 's/srcdir=\$(fsrcdir)/srcdir=\$(fsrcdir) VPATH=\$(fsrcdir)/' \
578         gcc/ada/Makefile > makefile.tmp
579 mv -f makefile.tmp gcc/ada/Makefile
580 %endif
581
582 cd ..
583 %{__make} -C obj-%{_target_platform} bootstrap-lean \
584         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
585         mandir=%{_mandir} \
586         infodir=%{_infodir}
587
588 %if %{!?_without_ada:1}%{?_without_ada:0}
589 %{__make} -C obj-%{_target_platform}/gcc gnatlib gnattools gnatlib-shared \
590         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
591         mandir=%{_mandir} \
592         infodir=%{_infodir}
593
594 # make Gnat Reference Manual
595 %{__make} -C obj-%{_target_platform}/gcc/ada doc
596 %endif
597
598 %install
599 rm -rf $RPM_BUILD_ROOT
600 install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_infodir}}
601
602 cd obj-%{_target_platform}
603 PATH=$PATH:/sbin:%{_sbindir}
604
605 %{__make} install \
606         prefix=$RPM_BUILD_ROOT%{_prefix} \
607         mandir=$RPM_BUILD_ROOT%{_mandir} \
608         infodir=$RPM_BUILD_ROOT%{_infodir} \
609         slibdir=$RPM_BUILD_ROOT/lib
610
611 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
612 echo .so gcc.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
613
614 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
615 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
616
617 %if %{!?_without_ada:1}%{?_without_ada:0}
618 # move ada shared libraries to proper place...
619 mv $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*-*so.1 \
620         $RPM_BUILD_ROOT%{_libdir}
621 rm -f $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.so.1
622 (cd $RPM_BUILD_ROOT%{_libdir} && \
623  ln -s libgnat-*so.1 libgnat.so.1 && \
624  ln -s libgnarl-*so.1 libgnarl.so.1)
625 %endif
626
627 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
628
629 cd ..
630
631 %if %{!?_without_ada:1}%{?_without_ada:0}
632 install obj-%{_target_platform}/gcc/ada/gnat_rm.info* $RPM_BUILD_ROOT%{_infodir}
633 install obj-%{_target_platform}/gcc/ada/gnat_ug_unx.info* $RPM_BUILD_ROOT%{_infodir}
634 %endif
635
636 %if %{!?_without_java:1}%{?_without_java:0}
637 install -d java-doc
638 cp -f libjava/doc/cni.sgml libjava/READ* java-doc
639 cp -f fastjar/README java-doc/README.fastjar
640 cp -f libffi/README java-doc/README.libffi
641 cp -f libffi/LICENSE java-doc/LICENSE.libffi
642
643 cp -f libobjc/README gcc/objc/README.libobjc
644 %endif
645
646 bzip2 -dc %{SOURCE2} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
647 mv -f $RPM_BUILD_ROOT%{_mandir}/ja/man1/{cccp,cpp}.1
648
649 %find_lang %{name}
650 %find_lang libstdc\+\+
651
652 %clean
653 rm -rf $RPM_BUILD_ROOT
654
655 %post
656 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
657
658 %postun
659 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
660
661 %post g77
662 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
663
664 %postun g77
665 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
666
667 %post java
668 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
669
670 %postun java
671 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
672
673 %post ksi
674 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
675
676 %postun ksi
677 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
678
679 %post -n cpp
680 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
681
682 %postun -n cpp
683 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
684
685 %post   -p /sbin/ldconfig -n libgcc
686 %postun -p /sbin/ldconfig -n libgcc
687 %post   -p /sbin/ldconfig -n libstdc++
688 %postun -p /sbin/ldconfig -n libstdc++
689 %post   -p /sbin/ldconfig -n libobjc
690 %postun -p /sbin/ldconfig -n libobjc
691 %post   -p /sbin/ldconfig -n libg2c
692 %postun -p /sbin/ldconfig -n libg2c
693 %post   -p /sbin/ldconfig -n libgcj
694 %postun -p /sbin/ldconfig -n libgcj
695 %post   -p /sbin/ldconfig -n libgnat
696 %postun -p /sbin/ldconfig -n libgnat
697
698 %files -f %{name}.lang
699 %defattr(644,root,root,755)
700 %doc READ* ChangeLog
701 %dir %{_libdir}/gcc-lib
702 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
703 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
704 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
705 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
706 %attr(755,root,root) %{_bindir}/gcc
707 %attr(755,root,root) %{_bindir}/gccbug
708 %attr(755,root,root) %{_bindir}/gcov
709 %attr(755,root,root) %{_bindir}/cc
710
711 %{_mandir}/man1/gcc.1*
712 %{_mandir}/man1/cc.1*
713 %{_mandir}/man1/gcov.1*
714 %lang(fr) %{_mandir}/fr/man1/gcc.1*
715 %lang(ja) %{_mandir}/ja/man1/gcc.1*
716 %{_infodir}/gcc*
717
718 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
719 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
720 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
721 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
722 %ifarch ppc
723 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ecrt*.o
724 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ncrt*.o
725 %{_libdir}/gcc-lib/%{_target_cpu}*/*/nof
726 %dir %{_libdir}/nof
727 %endif
728 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
729 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
730
731 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
732 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
733 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
734 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
735 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
736 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
737 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
738 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
739 %ifarch %{ix86}
740 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/mmintrin.h
741 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/xmmintrin.h
742 %endif
743 %ifarch ppc
744 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/altivec.h
745 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/ppc-asm.h
746 %endif
747
748 %files -n libgcc
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_slibdir}/lib*.so*
751
752 %files c++
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_bindir}/g++
755 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
756 %attr(755,root,root) %{_bindir}/c++
757 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
758 %attr(755,root,root) %{_bindir}/c++filt
759 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
760 %attr(755,root,root) %{_libdir}/libsupc++.la
761 %ifarch ppc
762 %attr(755,root,root) %{_libdir}/nof/libsupc++.la
763 %{_libdir}/nof/libsupc++.a
764 %endif
765 %{_libdir}/libsupc++.a
766 %{_mandir}/man1/g++.1*
767 %lang(es) %{_mandir}/es/man1/c++filt.1*
768 %lang(ja) %{_mandir}/ja/man1/g++.1*
769
770 %files -n libstdc++ -f libstdc++.lang
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
773 %ifarch ppc
774 %attr(755,root,root) %{_libdir}/nof/libstdc++.so.*.*.*
775 %endif
776
777 %files -n libstdc++-devel
778 %defattr(644,root,root,755)
779 %doc libstdc++-v3/docs/html
780 %dir %{_includedir}/c++
781 %{_includedir}/c++/%{GCC_VERSION}
782 %attr(755,root,root) %{_libdir}/libstdc++.so
783 %attr(755,root,root) %{_libdir}/libstdc++.la
784 %ifarch ppc
785 %attr(755,root,root) %{_libdir}/nof/libstdc++.so
786 %attr(755,root,root) %{_libdir}/nof/libstdc++.la
787 %endif
788
789 %files -n libstdc++-static
790 %defattr(644,root,root,755)
791 %{_libdir}/libstdc++.a
792 %ifarch ppc
793 %{_libdir}/nof/libstdc++.a
794 %endif
795
796 %files objc
797 %defattr(644,root,root,755)
798 %doc gcc/objc/READ*
799 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
800 %attr(755,root,root) %{_libdir}/libobjc.so
801 %attr(755,root,root) %{_libdir}/libobjc.la
802 %ifarch ppc
803 %attr(755,root,root) %{_libdir}/nof/libobjc.so
804 %attr(755,root,root) %{_libdir}/nof/libobjc.la
805 %endif
806 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
807
808 %files -n libobjc
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
811 %ifarch ppc
812 %attr(755,root,root) %{_libdir}/nof/libobjc.so.*.*.*
813 %endif
814
815 %files -n libobjc-static
816 %defattr(644,root,root,755)
817 %{_libdir}/libobjc.a
818 %ifarch ppc
819 %{_libdir}/nof/libobjc.a
820 %endif
821
822 %files g77
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_bindir}/g77
825 %attr(755,root,root) %{_bindir}/f77
826 %{_infodir}/g77*
827 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
828 %{_libdir}/libfrtbegin.a
829 %attr(755,root,root) %{_libdir}/libg2c.la
830 %attr(755,root,root) %{_libdir}/libg2c.so
831 %ifarch ppc
832 %{_libdir}/nof/libfrtbegin.a
833 %attr(755,root,root) %{_libdir}/nof/libg2c.la
834 %attr(755,root,root) %{_libdir}/nof/libg2c.so
835 %endif
836 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
837 %{_mandir}/man1/g77.1*
838 %{_mandir}/man1/f77.1*
839 %lang(ja) %{_mandir}/ja/man1/g77.1*
840 %lang(ja) %{_mandir}/ja/man1/f77.1*
841
842 %files -n libg2c
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{_libdir}/libg2c.so.*.*.*
845 %ifarch ppc
846 %attr(755,root,root) %{_libdir}/nof/libg2c.so.*.*.*
847 %endif
848
849 %files -n libg2c-static
850 %{_libdir}/libg2c.a
851 %ifarch ppc
852 %{_libdir}/nof/libg2c.a
853 %endif
854
855 %if %{!?_without_java:1}%{?_without_java:0}
856 %files java
857 %defattr(644,root,root,755)
858 %doc java-doc/*
859 %attr(755,root,root) %{_bindir}/gcj*
860 %attr(755,root,root) %{_bindir}/gij
861 %attr(755,root,root) %{_bindir}/jcf-dump
862 %attr(755,root,root) %{_bindir}/jv-*
863 %attr(755,root,root) %{_bindir}/rmi*
864 %attr(755,root,root) %{_bindir}/jar
865 %attr(755,root,root) %{_bindir}/grepjar
866 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
867 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
868 %{_infodir}/gcj*
869 %{_mandir}/man1/jcf-*
870 %{_mandir}/man1/jv-*
871 %{_mandir}/man1/gij*
872 %{_mandir}/man1/gcj*
873 %{_mandir}/man1/rmi*
874
875 %files -n libgcj
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_bindir}/addr2name.awk
878 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
879 %ifarch ppc
880 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so.*
881 %endif
882
883 %files -n libgcj-devel
884 %defattr(644,root,root,755)
885 %{_includedir}/java
886 %{_includedir}/javax
887 %{_includedir}/org
888 %{_includedir}/gcj
889 %{_includedir}/j*.h
890 %{_includedir}/gnu/*
891 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/gcj
892 %{_libdir}/security/*
893 %dir %{_datadir}/java
894 %{_datadir}/java/libgcj*.jar
895 %{_libdir}/lib*cj.spec
896 %attr(755,root,root) %{_libdir}/lib*cj*.la
897 %attr(755,root,root) %{_libdir}/lib*cj*.so
898 %ifarch ppc
899 %{_libdir}/nof/lib*cj.spec
900 %attr(755,root,root) %{_libdir}/nof/lib*cj*.la
901 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so
902 %endif
903
904 %files -n libgcj-static
905 %defattr(644,root,root,755)
906 %{_libdir}/lib*cj*.a
907 %ifarch ppc
908 %{_libdir}/nof/lib*cj*.a
909 %endif
910 %endif
911
912 %if %{!?_without_ada:1}%{?_without_ada:0}
913 %files ada
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/gnat1
916 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adainclude
917 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib
918 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.ali
919 %ifnarch ppc
920 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgmem.a
921 %endif
922 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/Makefile.adalib
923 %attr(755,root,root) %{_bindir}/gnat*
924 %{_infodir}/gnat*
925 %attr(755,root,root) %{_libdir}/libgnat.so.1
926 %attr(755,root,root) %{_libdir}/libgnarl.so.1
927
928 %files -n libgnat
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_libdir}/libgna*-*so.1
931
932 %files -n libgnat-static
933 %defattr(644,root,root,755)
934 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgna*.a
935 %endif
936
937 %files ksi
938 %defattr(644,root,root,755)
939 %doc gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
940 %{_infodir}/ksi*
941 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
942
943 %files -n cpp
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_slibdir}/cpp
946 %attr(755,root,root) %{_bindir}/cpp
947 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
948 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
949 %{_mandir}/man1/cpp.1*
950 %lang(ja) %{_mandir}/ja/man1/cpp.1*
951 %{_infodir}/cpp*
This page took 0.108422 seconds and 3 git commands to generate.