]> git.pld-linux.org Git - packages/frogatto.git/blob - frogatto.spec
- install sounds and music
[packages/frogatto.git] / frogatto.spec
1 Summary:        An open-source "platformer" game
2 Name:           frogatto
3 Version:        1.1.1
4 Release:        2
5 License:        GPL v3+
6 Group:          X11/Applications/Games
7 Source0:        http://www.frogatto.com/files/%{name}-%{version}.tar.bz2
8 # Source0-md5:  bf5a2ee4c3254a424766895ff250758b
9 Patch0:         %{name}-makefile.patch
10 Patch1:         %{name}-assertion.patch
11 URL:            http://www.frogatto.com/
12 BuildRequires:  OpenGL-GLU-devel
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  SDL-devel >= 1.2.7
15 BuildRequires:  SDL_image-devel >= 1.2.0
16 BuildRequires:  SDL_mixer-devel >= 1.2.0
17 BuildRequires:  SDL_ttf-devel >= 2.0.8
18 BuildRequires:  boost-devel >= 1.35.0
19 BuildRequires:  ccache
20 BuildRequires:  glew-devel
21 BuildRequires:  sed >= 4.0
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Frogatto is an open-source "platformer" game, which means you're given
27 a cross-section view into the world, and you help a small green fellow
28 named Frogatto walk and jump between solid footholds whilst you lead
29 him through his story. There's a long history to the genre, so just by
30 being in it we inevitably have a lot in common with other games,
31 however, we're not trying to clone any specific game.
32
33 %prep
34 %setup -q
35 %patch0 -p1
36 %patch1 -p1
37
38 # fix linking with our boost libs
39 %{__sed} -i 's,-mt,,g' Makefile
40
41 # set proper paths
42 %{__sed} -i 's,data/,%{_datadir}/frogatto/data/,g' `find -name "*.[ch]pp" -o -name "*.po*" -o -name "*.cfg"`
43 %{__sed} -i 's,./images/,%{_datadir}/frogatto/images/,g' `find -name "*.cpp"`
44 %{__sed} -i 's,./locale/,%{_datadir}/locale/,g' src/i18n.cpp
45 %{__sed} -i 's,music/,%{_datadir}/frogatto/music/,g' src/sound.cpp
46 %{__sed} -i 's,sounds/,%{_datadir}/frogatto/sounds/,g' src/sound.cpp
47
48 %build
49 %{__make} \
50         CXX="%{__cxx}" \
51         OPT="%{rpmcxxflags}" \
52         LDFLAGS="%{rpmldflags}"
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/frogatto,%{_datadir}/locale}
57
58 cp -a game $RPM_BUILD_ROOT%{_bindir}/frogatto
59 cp -a data $RPM_BUILD_ROOT%{_datadir}/frogatto
60 cp -a images $RPM_BUILD_ROOT%{_datadir}/frogatto
61 cp -a locale/* $RPM_BUILD_ROOT%{_datadir}/locale
62 cp -a music $RPM_BUILD_ROOT%{_datadir}/frogatto
63 cp -a sounds $RPM_BUILD_ROOT%{_datadir}/frogatto
64
65 %find_lang %{name} --all-name
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files -f %{name}.lang
71 %defattr(644,root,root,755)
72 %doc CHANGELOG
73 %attr(755,root,root) %{_bindir}/frogatto
74 %{_datadir}/frogatto
This page took 0.086176 seconds and 4 git commands to generate.