]> git.pld-linux.org Git - packages/frogatto.git/blob - frogatto.spec
- removed -no_fbo_assert.patch (shadzik's request)
[packages/frogatto.git] / frogatto.spec
1 Summary:        An open-source "platformer" game
2 Name:           frogatto
3 Version:        1.1.1
4 Release:        7
5 License:        GPL v3+
6 Group:          X11/Applications/Games
7 Source0:        http://www.frogatto.com/files/%{name}-%{version}.tar.bz2
8 # Source0-md5:  bf5a2ee4c3254a424766895ff250758b
9 Patch0:         %{name}-makefile.patch
10 Patch1:         %{name}-assertion.patch
11 Patch2:         %{name}-libpng15.patch
12 URL:            http://www.frogatto.com/
13 BuildRequires:  OpenGL-GLU-devel
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  SDL-devel >= 1.2.7
16 BuildRequires:  SDL_image-devel >= 1.2.0
17 BuildRequires:  SDL_mixer-devel >= 1.2.0
18 BuildRequires:  SDL_ttf-devel >= 2.0.8
19 BuildRequires:  boost-devel >= 1.35.0
20 BuildRequires:  ccache
21 BuildRequires:  glew-devel
22 BuildRequires:  sed >= 4.0
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Frogatto is an open-source "platformer" game, which means you're given
28 a cross-section view into the world, and you help a small green fellow
29 named Frogatto walk and jump between solid footholds whilst you lead
30 him through his story. There's a long history to the genre, so just by
31 being in it we inevitably have a lot in common with other games,
32 however, we're not trying to clone any specific game.
33
34 %prep
35 %setup -q
36 %patch0 -p1
37 %patch1 -p1
38 %patch2 -p1
39
40 # fix linking with our boost libs
41 %{__sed} -i 's,-mt,,g' Makefile
42
43 # set proper paths
44 %{__sed} -i 's,data/,%{_datadir}/frogatto/data/,g' `find -name "*.[ch]pp" -o -name "*.po*" -o -name "*.cfg"`
45 %{__sed} -i 's,./images/,%{_datadir}/frogatto/images/,g' `find -name "*.cpp"`
46 %{__sed} -i 's,./locale/,%{_datadir}/locale/,g' src/i18n.cpp
47 %{__sed} -i 's,music/,%{_datadir}/frogatto/music/,g' src/sound.cpp
48 %{__sed} -i 's,sounds/,%{_datadir}/frogatto/sounds/,g' src/sound.cpp
49
50 %build
51 %{__make} \
52         CXX="%{__cxx}" \
53         OPT="%{rpmcxxflags}" \
54         LDFLAGS="%{rpmldflags}"
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/frogatto,%{_datadir}/locale}
59
60 cp -a game $RPM_BUILD_ROOT%{_bindir}/frogatto
61 cp -a data $RPM_BUILD_ROOT%{_datadir}/frogatto
62 cp -a images $RPM_BUILD_ROOT%{_datadir}/frogatto
63 cp -a locale/* $RPM_BUILD_ROOT%{_datadir}/locale
64 cp -a music $RPM_BUILD_ROOT%{_datadir}/frogatto
65 cp -a sounds $RPM_BUILD_ROOT%{_datadir}/frogatto
66
67 %find_lang %{name} --all-name
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files -f %{name}.lang
73 %defattr(644,root,root,755)
74 %doc CHANGELOG
75 %attr(755,root,root) %{_bindir}/frogatto
76 %{_datadir}/frogatto
This page took 0.027551 seconds and 3 git commands to generate.