]> git.pld-linux.org Git - packages/freshplayerplugin.git/blob - freshplayerplugin.spec
- updated to 0.3.11, generalized OpenGL/OpenGLES dependencies
[packages/freshplayerplugin.git] / freshplayerplugin.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk3            # build with gtk+3 instead of gtk+2
4 %bcond_without  jack            # jack
5 %bcond_without  pulseaudio      # pulseaudio
6 %bcond_without  vaapi           # vaapi
7
8 Summary:        PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based browsers
9 Name:           freshplayerplugin
10 Version:        0.3.4
11 Release:        1
12 License:        MIT
13 Group:          X11/Applications/Multimedia
14 Source0:        https://github.com/i-rinat/freshplayerplugin/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  e5d5df12de8dbb1caf4e349b4e4ae520
16 URL:            https://github.com/i-rinat/freshplayerplugin
17 BuildRequires:  Mesa-libEGL-devel
18 BuildRequires:  Mesa-libGLES-devel
19 BuildRequires:  alsa-lib-devel
20 BuildRequires:  cmake >= 2.8.8
21 BuildRequires:  ffmpeg-devel
22 BuildRequires:  freetype-devel
23 BuildRequires:  glib2-devel
24 %{!?with_gtk3:BuildRequires: gtk+2-devel}
25 %{?with_gtk3:BuildRequires: gtk+3-devel}
26 %{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
27 BuildRequires:  libevent-devel
28 BuildRequires:  libv4l-devel
29 %{?with_vaapi:BuildRequires: libva-devel}
30 BuildRequires:  libva-x11-devel
31 BuildRequires:  openssl-devel
32 BuildRequires:  pkgconfig
33 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
34 BuildRequires:  ragel
35 BuildRequires:  rpmbuild(macros) >= 1.357
36 BuildRequires:  xorg-lib-libXrandr-devel
37 BuildRequires:  xorg-lib-libXrender-devel
38 Requires:       browser-plugins >= 2.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based
43 browsers.
44
45 %prep
46 %setup -q
47
48 %build
49 install -d build
50 cd build
51 %cmake \
52         -DCMAKE_SKIP_RPATH=1 \
53         %{?with_jack:-DJACK=1} \
54         %{?with_pulseaudio:-DPULSEAUDIO=1} \
55         -DWITH_GTK=%{!?with_gtk3:2}%{?with_gtk3:3} \
56         -DWITH_HWDEC=%{!?with_vaapi:0}%{?with_vaapi:1} \
57         ..
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_browserpluginsdir}
63 install -p build/libfreshwrapper-flashplayer.so $RPM_BUILD_ROOT%{_browserpluginsdir}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post
69 %update_browser_plugins
70
71 %postun
72 if [ "$1" = 0 ]; then
73         %update_browser_plugins
74 fi
75
76 %files
77 %defattr(644,root,root,755)
78 %doc ChangeLog data/freshwrapper.conf.example README.md
79 %attr(755,root,root) %{_browserpluginsdir}/libfreshwrapper-flashplayer.so
This page took 0.190527 seconds and 3 git commands to generate.