]> git.pld-linux.org Git - packages/freetds.git/blob - freetds.spec
- added pool.conf to sysconfdir
[packages/freetds.git] / freetds.spec
1 #
2 # Conditional build:
3 %bcond_with     msdblib         # use MS-style dblib
4 #
5 # %%define tdsver - protocol version; valid versions:
6 # 4.2 (used by Sybase SQLServer <= 10 and MS SQL Server 6.5)
7 # 4.6
8 # 5.0 (used by Sybase SQLServer >= 11)
9 # 7.0 (used by MS SQL Server 7.0) [default]
10 # 8.0 (not finished yet!)
11
12 %{!?tdsver:%define tdsver 7.0}
13
14 Summary:        Free implementation of Sybase's db-lib
15 Summary(pl):    Wolnodostêpna implementacja db-lib firmy Sybase
16 Name:           freetds
17 Version:        0.62.4
18 Release:        1
19 License:        LGPL
20 Group:          Libraries
21 Source0:        http://ibiblio.org/pub/Linux/ALPHA/freetds/stable/%{name}-%{version}.tar.gz
22 # Source0-md5:  09695686e7aa2eaf963c2ebe30c7ae74
23 URL:            http://www.freetds.org/
24 BuildRequires:  autoconf
25 BuildRequires:  libltdl-devel
26 BuildRequires:  libtool
27 BuildRequires:  unixODBC-devel
28 Requires(post): /sbin/ldconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _sysconfdir     /etc/tds
32
33 %description
34 FreeTDS is a free (open source) implementation of Sybase's db-lib,
35 ct-lib, and ODBC libraries (which can be used also to work with MS SQL
36 databases). Currently, dblib and ctlib are most mature. Both of these
37 libraries have several programs known to compile and run against them.
38 ODBC is not quite as mature, but may work depending on your needs.
39
40 %description -l pl
41 FreeTDS to wolnodostêpna (z otwartymi ¼ród³ami) implementacja
42 bibliotek db-lib, ct-lib i ODBC firmy Sybase (których mo¿na u¿ywaæ
43 tak¿e do pracy z bazami MS SQL). Aktualnie najlepiej dzia³aj± dblib i
44 ctlib - istnieje trochê programów, o których wiadomo, ¿e kompiluj± siê
45 i dzia³aj± z tymi bibliotekami. ODBC nie jest jeszcze na tyle
46 skoñczony, ale mo¿e dzia³aæ w zale¿no¶ci od potrzeb.
47
48 %package devel
49 Summary:        FreeTDS header files
50 Summary(pl):    Pliki nag³ówkowe FreeTDS
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}
53
54 %description devel
55 FreeTDS header files.
56
57 %description devel -l pl
58 Pliki nag³ówkowe FreeTDS.
59
60 %package static
61 Summary:        FreeTDS static libraries
62 Summary(pl):    Statyczne biblioteki FreeTDS
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}
65
66 %description static
67 FreeTDS static libraries.
68
69 %description static -l pl
70 Statyczne biblioteki FreeTDS.
71
72 %prep
73 %setup -q
74
75 %build
76 %{__autoconf}
77 %configure \
78         --with-tdsver=%{tdsver} \
79         %{?with_msdblib:--with-msdblib} \
80         --with-unixodbc
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT \
88         ETC=$RPM_BUILD_ROOT%{_sysconfdir}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 /sbin/ldconfig
95 if [ -f /etc/freetds.conf ]; then
96         mv -f /etc/freetds.conf %{_sysconfdir}/freetds.conf
97 fi
98
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS BUGS ChangeLog NEWS README* TODO
104 %attr(755,root,root) %{_libdir}/lib*.so.*.*
105 %attr(755,root,root) %{_bindir}/*
106 %dir %{_sysconfdir}
107 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freetds.conf
108 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/locales.conf
109 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pool.conf
110 %{_mandir}/man1/*
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/lib*.so
115 %attr(755,root,root) %{_libdir}/lib*.la
116 %{_includedir}/*
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/lib*.a
This page took 0.068708 seconds and 3 git commands to generate.