]> git.pld-linux.org Git - packages/freetds.git/blob - freetds.spec
- rebuild with readline 5.0
[packages/freetds.git] / freetds.spec
1 #
2 # Conditional build:
3 %bcond_with     msdblib         # use MS-style dblib
4 #
5 # %%define tdsver - protocol version; valid versions:
6 # 4.2 (used by Sybase SQLServer <= 10 and MS SQL Server 6.5)
7 # 4.6
8 # 5.0 (used by Sybase SQLServer >= 11)
9 # 7.0 (used by MS SQL Server 7.0) [default]
10 # 8.0 (not finished yet!)
11
12 %{!?tdsver:%define tdsver 7.0}
13
14 Summary:        Free implementation of Sybase's db-lib
15 Summary(pl):    Wolnodostêpna implementacja db-lib firmy Sybase
16 Name:           freetds
17 Version:        0.63
18 Release:        3
19 License:        LGPL
20 Group:          Libraries
21 Source0:        ftp://ftp.ibiblio.org/pub/Linux/ALPHA/freetds/stable/%{name}-%{version}.tar.gz
22 # Source0-md5:  a0a5038cfb708180308b381f848baf75
23 URL:            http://www.freetds.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  libltdl-devel
27 BuildRequires:  libtool
28 BuildRequires:  unixODBC-devel
29 Requires(post): /sbin/ldconfig
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _sysconfdir     /etc/tds
33
34 %description
35 FreeTDS is a free (open source) implementation of Sybase's db-lib,
36 ct-lib, and ODBC libraries (which can be used also to work with MS SQL
37 databases). Currently, dblib and ctlib are most mature. Both of these
38 libraries have several programs known to compile and run against them.
39 ODBC is not quite as mature, but may work depending on your needs.
40
41 %description -l pl
42 FreeTDS to wolnodostêpna (z otwartymi ¼ród³ami) implementacja
43 bibliotek db-lib, ct-lib i ODBC firmy Sybase (których mo¿na u¿ywaæ
44 tak¿e do pracy z bazami MS SQL). Aktualnie najlepiej dzia³aj± dblib i
45 ctlib - istnieje trochê programów, o których wiadomo, ¿e kompiluj± siê
46 i dzia³aj± z tymi bibliotekami. ODBC nie jest jeszcze na tyle
47 skoñczony, ale mo¿e dzia³aæ w zale¿no¶ci od potrzeb.
48
49 %package devel
50 Summary:        FreeTDS header files
51 Summary(pl):    Pliki nag³ówkowe FreeTDS
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description devel
56 FreeTDS header files.
57
58 %description devel -l pl
59 Pliki nag³ówkowe FreeTDS.
60
61 %package static
62 Summary:        FreeTDS static libraries
63 Summary(pl):    Statyczne biblioteki FreeTDS
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 FreeTDS static libraries.
69
70 %description static -l pl
71 Statyczne biblioteki FreeTDS.
72
73 %prep
74 %setup -q
75
76 %build
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %{__automake}
81 %configure \
82         --with-tdsver=%{tdsver} \
83         %{?with_msdblib:--with-msdblib} \
84         --with-unixodbc=/usr
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT \
92         ETC=$RPM_BUILD_ROOT%{_sysconfdir}
93
94 mv -f src/pool/BUGS BUGS.pool
95 mv -f src/pool/README README.pool
96 mv -f src/pool/TODO TODO.pool
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post
102 /sbin/ldconfig
103 if [ -f /etc/freetds.conf ]; then
104         mv -f /etc/freetds.conf %{_sysconfdir}/freetds.conf
105 fi
106
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS BUGS* ChangeLog NEWS README* TODO*
112 %attr(755,root,root) %{_libdir}/lib*.so.*.*
113 %attr(755,root,root) %{_bindir}/*
114 %dir %{_sysconfdir}
115 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freetds.conf
116 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/locales.conf
117 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pool.conf
118 %{_mandir}/man1/*
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/lib*.so
123 %{_libdir}/lib*.la
124 %{_includedir}/*
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/lib*.a
This page took 0.064276 seconds and 3 git commands to generate.