]> git.pld-linux.org Git - packages/fpm.git/blob - ruby-fpm.spec
build with rubygems provides
[packages/fpm.git] / ruby-fpm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname fpm
6 Summary:        fpm - package building and mangling
7 Name:           ruby-%{pkgname}
8 Version:        0.4.36
9 Release:        2
10 License:        GPL v2+ or Ruby
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  722802ab7f9ab4c2befa26551314fcff
14 URL:            https://github.com/jordansissel/fpm
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.665
17 BuildRequires:  sed >= 4.0
18 %if %{with tests}
19 BuildRequires:  ruby-insist < 0.1
20 BuildRequires:  ruby-insist >= 0.0.5
21 BuildRequires:  ruby-minitest
22 BuildRequires:  ruby-pry
23 BuildRequires:  ruby-rspec
24 BuildRequires:  ruby-rush
25 %endif
26 Requires:       ruby-arr-pm < 0.1
27 Requires:       ruby-arr-pm >= 0.0.8
28 Requires:       ruby-backports >= 2.6.2
29 Requires:       ruby-cabin >= 0.6.0
30 Requires:       ruby-childprocess
31 Requires:       ruby-clamp = 0.6.0
32 Requires:       ruby-ftw < 0.1
33 Requires:       ruby-ftw >= 0.0.30
34 Requires:       ruby-json < 1.8
35 Requires:       ruby-json >= 1.7.7
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Convert directories, rpms, python eggs, rubygems, and more to rpms,
41 debs, solaris packages and more. Win at package management without
42 wasting pointless hours debugging bad rpm specs!
43
44 %prep
45 %setup -q -n %{pkgname}-%{version}
46 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
47
48 %build
49 %__gem_helper spec
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
54 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
55 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
56 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %attr(755,root,root) %{_bindir}/fpm
64 %{ruby_vendorlibdir}/%{pkgname}.rb
65 %{ruby_vendorlibdir}/%{pkgname}
66 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.102734 seconds and 4 git commands to generate.