]> git.pld-linux.org Git - packages/fpm.git/blob - fpm.spec
run rspec when tests enabled
[packages/fpm.git] / fpm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        fpm - package building and mangling
6 Name:           fpm
7 Version:        1.4.0
8 Release:        1
9 License:        MIT-like
10 Group:          Development/Languages
11 Source0:        https://github.com/jordansissel/fpm/archive/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  1aae7b53d0e6470183222a7634b7d799
13 Patch0:         templates.patch
14 Patch1:         tmppath.patch
15 Patch2:         config-attrs.patch
16 Patch3:         pld-init.d-dir.patch
17 URL:            https://github.com/jordansissel/fpm
18 BuildRequires:  rpm-rubyprov
19 BuildRequires:  rpmbuild(macros) >= 1.665
20 BuildRequires:  sed >= 4.0
21 %if %{with tests}
22 BuildRequires:  ruby-insist < 0.1
23 BuildRequires:  ruby-insist >= 0.0.5
24 BuildRequires:  ruby-pry
25 BuildRequires:  ruby-rspec < 3.1
26 BuildRequires:  ruby-rspec >= 3.0.0
27 BuildRequires:  ruby-stud
28 %endif
29 Requires:       ruby-arr-pm < 0.1
30 Requires:       ruby-arr-pm >= 0.0.10
31 Requires:       ruby-backports >= 2.6.2
32 Requires:       ruby-cabin >= 0.6.0
33 Requires:       ruby-childprocess
34 Requires:       ruby-clamp < 1
35 Requires:       ruby-clamp >= 0.6
36 Requires:       ruby-ffi
37 Requires:       ruby-json >= 1.7.7
38 Suggests:       rpm-build
39 Obsoletes:      ruby-fpm <= 1.4.0-2
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Convert directories, rpms, python eggs, rubygems, and more to rpms,
45 debs, solaris packages and more. Win at package management without
46 wasting pointless hours debugging bad rpm specs!
47
48 %prep
49 %setup -q
50 %patch0 -p1
51 %patch1 -p1
52 %patch2 -p1
53 %patch3 -p1
54 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
55
56 # cleanup backups after patching
57 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
58
59 %build
60 # make gemspec self-contained
61 ruby -r rubygems -e 'spec = eval(File.read("%{name}.gemspec"))
62         File.open("%{name}-%{version}.gemspec", "w") do |file|
63         file.puts spec.to_ruby_for_cache
64 end'
65
66 %if %{with tests}
67 rspec
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
73 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
74 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
75 cp -a templates $RPM_BUILD_ROOT%{ruby_vendorlibdir}/%{name}
76 cp -p %{name}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_bindir}/fpm
84 %{ruby_vendorlibdir}/%{name}.rb
85 %{ruby_vendorlibdir}/%{name}
86 %{ruby_specdir}/%{name}-%{version}.gemspec
This page took 0.079131 seconds and 3 git commands to generate.