]> git.pld-linux.org Git - packages/fpm.git/blob - fpm.spec
add tmppath.patch
[packages/fpm.git] / fpm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        fpm - package building and mangling
6 Name:           fpm
7 Version:        1.4.0
8 Release:        1
9 License:        MIT-like
10 Group:          Development/Languages
11 Source0:        https://github.com/jordansissel/fpm/archive/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  1aae7b53d0e6470183222a7634b7d799
13 Source1:        filesystem_list
14 Patch0:         templates.patch
15 Patch1:         tmppath.patch
16 Patch2:         config-attrs.patch
17 Patch3:         pld-init.d-dir.patch
18 URL:            https://github.com/jordansissel/fpm
19 BuildRequires:  rpm-rubyprov
20 BuildRequires:  rpmbuild(macros) >= 1.665
21 BuildRequires:  sed >= 4.0
22 %if %{with tests}
23 BuildRequires:  ruby-insist >= 0.0.6
24 BuildRequires:  ruby-pry
25 BuildRequires:  ruby-rspec < 3.1
26 BuildRequires:  ruby-rspec >= 3.0.0
27 BuildRequires:  ruby-stud
28 %endif
29 Requires:       ruby-arr-pm < 0.1
30 Requires:       ruby-arr-pm >= 0.0.10
31 Requires:       ruby-backports >= 2.6.2
32 Requires:       ruby-cabin >= 0.6.0
33 Requires:       ruby-childprocess
34 Requires:       ruby-clamp < 1
35 Requires:       ruby-clamp >= 0.6
36 Requires:       ruby-ffi
37 Requires:       ruby-json >= 1.7.7
38 Suggests:       rpm-build
39 Obsoletes:      ruby-fpm <= 1.4.0-2
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Convert directories, rpms, python eggs, rubygems, and more to rpms,
45 debs, solaris packages and more. Win at package management without
46 wasting pointless hours debugging bad rpm specs!
47
48 %prep
49 %setup -q
50 %patch0 -p1
51 %patch1 -p1
52 %patch2 -p1
53 %patch3 -p1
54 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
55
56 # replace filesystem_list with pld version
57 cp -p %{SOURCE1} templates/rpm/filesystem_list
58
59 # cleanup backups after patching
60 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
61
62 %build
63 # make gemspec self-contained
64 ruby -r rubygems -e 'spec = eval(File.read("%{name}.gemspec"))
65         File.open("%{name}-%{version}.gemspec", "w") do |file|
66         file.puts spec.to_ruby_for_cache
67 end'
68
69 %if %{with tests}
70 rspec
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
76 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
77 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
78 cp -a templates $RPM_BUILD_ROOT%{ruby_vendorlibdir}/%{name}
79 cp -p %{name}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_bindir}/fpm
87 %{ruby_vendorlibdir}/%{name}.rb
88 %{ruby_vendorlibdir}/%{name}
89 %{ruby_specdir}/%{name}-%{version}.gemspec
This page took 0.072814 seconds and 3 git commands to generate.