]> git.pld-linux.org Git - packages/fox16.git/blob - fox16.spec
Release 2 (by relup.sh)
[packages/fox16.git] / fox16.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        The FOX 1.6 C++ GUI Toolkit
6 Summary(pl.UTF-8):      FOX 1.6 - toolkit graficzny w C++
7 Name:           fox16
8 Version:        1.6.53
9 Release:        2
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        http://ftp.fox-toolkit.org/pub/fox-%{version}.tar.gz
13 # Source0-md5:  324a8f4c53e9bee690252b229ca74a73
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-Makefile.patch
16 Patch2:         %{name}-format.patch
17 URL:            http://www.fox-toolkit.org/
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  autoconf >= 2.59-9
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel >= 1.0.2
22 BuildRequires:  doxygen
23 BuildRequires:  graphviz
24 BuildRequires:  libjpeg-devel >= 6b
25 BuildRequires:  libpng-devel >= 1.2.5
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtiff-devel >= 3.5.7
28 BuildRequires:  libtool >= 2:1.5
29 BuildRequires:  xorg-lib-libXcursor-devel
30 BuildRequires:  xorg-lib-libXext-devel
31 BuildRequires:  xorg-lib-libXft-devel
32 BuildRequires:  xorg-lib-libXrandr-devel
33 BuildRequires:  zlib-devel >= 1.1.4
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 FOX is a C++-Based Library for Graphical User Interface Development
38 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
39 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
40 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
41 graphics. Subclassing of basic FOX widgets allows for easy extension
42 beyond the built-in widgets by application writers.
43
44 This package contains FOX 1.6.x series.
45
46 %description -l pl.UTF-8
47 FOX jest biblioteką bazującą na C++ do projektowania graficznych
48 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
49 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
50 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
51 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
52 rozszerzanie.
53
54 Ten pakiet zawiera FOX z serii 1.6.x.
55
56 %package progs
57 Summary:        FOX 1.6 example applications
58 Summary(pl.UTF-8):      Przykłady aplikacji wykorzystujących FOX 1.6
59 Group:          X11/Applications
60 Requires:       %{name} = %{version}-%{release}
61 Obsoletes:      fox-example-apps
62 Obsoletes:      fox-progs < 1.7
63 Conflicts:      fox-progs >= 1.7
64
65 %description progs
66 Editor and file browser, written with FOX 1.6.
67
68 %description progs -l pl.UTF-8
69 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX 1.6.
70
71 %package devel
72 Summary:        Header files for FOX 1.6 library
73 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX 1.6
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       OpenGL-GLU-devel
77 Requires:       bzip2-devel >= 1.0.2
78 Requires:       libjpeg-devel >= 6b
79 Requires:       libpng-devel >= 1.2.5
80 Requires:       libstdc++-devel
81 Requires:       libtiff-devel >= 3.5.7
82 Requires:       xorg-lib-libXcursor-devel
83 Requires:       xorg-lib-libXext-devel
84 Requires:       xorg-lib-libXft-devel
85 Requires:       xorg-lib-libXrandr-devel
86 Requires:       zlib-devel >= 1.1.4
87
88 %description devel
89 Header files for FOX 1.6 library.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe biblioteki FOX 1.6.
93
94 %package static
95 Summary:        FOX 1.6 static libraries
96 Summary(pl.UTF-8):      Biblioteki statyczne FOX 1.6
97 Group:          X11/Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 FOX 1.6 static libraries.
102
103 %description static -l pl.UTF-8
104 Biblioteki statyczne FOX 1.6.
105
106 %package doc
107 Summary:        Development documentation for FOX 1.6 library
108 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX 1.6
109 Group:          X11/Development/Libraries
110
111 %description doc
112 Development documentation for FOX 1.6 library.
113
114 %description doc -l pl.UTF-8
115 Dokumentacja programisty do biblioteki FOX 1.6.
116
117 %package examples
118 Summary:        FOX 1.6 - example programs
119 Summary(pl.UTF-8):      FOX 1.6 - programy przykładowe
120 Group:          X11/Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122
123 %description examples
124 FOX 1.6 - example programs.
125
126 %description examples -l pl.UTF-8
127 FOX 1.6 - przykładowe programy.
128
129 %prep
130 %setup -q -n fox-%{version}
131 %patch0 -p1
132 %patch1 -p1
133 %patch2 -p1
134
135 %build
136 %{__libtoolize}
137 %{__aclocal}
138 %{__autoconf}
139 %{__automake}
140 %configure \
141         %{?debug:--enable-debug}%{!?debug:--enable-release} \
142         --enable-static%{!?with_static_libs:=no} \
143         --with-opengl \
144         --with-xft \
145         --with-shape \
146         --with-xshm \
147         --with-xcursor \
148         --with-xrandr \
149         --with-xim
150
151 %{__make}
152
153 %{__make} -C doc docs
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 %{__make} -C tests clean
163 cp -a tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
164
165 mv -v $RPM_BUILD_ROOT%{_bindir}/fox-config $RPM_BUILD_ROOT%{_bindir}/fox16-config
166 mv -v $RPM_BUILD_ROOT%{_bindir}/reswrap $RPM_BUILD_ROOT%{_bindir}/reswrap16
167 mv -v $RPM_BUILD_ROOT%{_mandir}/man1/reswrap.1 $RPM_BUILD_ROOT%{_mandir}/man1/reswrap16.1
168 mv -v $RPM_BUILD_ROOT%{_pkgconfigdir}/fox.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/fox-1.6.pc
169
170 %{__rm} doc/Makefile* doc/*/Makefile*
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %files
179 %defattr(644,root,root,755)
180 %doc AUTHORS LICENSE_ADDENDUM README
181 %attr(755,root,root) %{_libdir}/libCHART-1.6.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.6.so.0
183 %attr(755,root,root) %{_libdir}/libFOX-1.6.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.6.so.0
185
186 %files progs
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/Adie.stx
189 %attr(755,root,root) %{_bindir}/PathFinder
190 %attr(755,root,root) %{_bindir}/adie
191 %attr(755,root,root) %{_bindir}/calculator
192 %attr(755,root,root) %{_bindir}/shutterbug
193 %{_mandir}/man1/PathFinder.1*
194 %{_mandir}/man1/adie.1*
195 %{_mandir}/man1/calculator.1*
196 %{_mandir}/man1/shutterbug.1*
197
198 %files devel
199 %defattr(644,root,root,755)
200 %doc ADDITIONS TRACING
201 %attr(755,root,root) %{_bindir}/fox16-config
202 %attr(755,root,root) %{_bindir}/reswrap16
203 %attr(755,root,root) %{_libdir}/libCHART-1.6.so
204 %attr(755,root,root) %{_libdir}/libFOX-1.6.so
205 %{_libdir}/libCHART-1.6.la
206 %{_libdir}/libFOX-1.6.la
207 %{_includedir}/fox-1.6
208 %{_pkgconfigdir}/fox-1.6.pc
209 %{_mandir}/man1/reswrap16.1*
210
211 %if %{with static_libs}
212 %files static
213 %defattr(644,root,root,755)
214 %{_libdir}/libCHART-1.6.a
215 %{_libdir}/libFOX-1.6.a
216 %endif
217
218 %files doc
219 %defattr(644,root,root,755)
220 %doc doc/*
221
222 %files examples
223 %defattr(644,root,root,755)
224 %{_examplesdir}/%{name}-%{version}
This page took 0.050243 seconds and 3 git commands to generate.