]> git.pld-linux.org Git - packages/fox16.git/blob - fox16.spec
- release 3 (by relup.sh)
[packages/fox16.git] / fox16.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        The FOX 1.6 C++ GUI Toolkit
6 Summary(pl.UTF-8):      FOX 1.6 - toolkit graficzny w C++
7 Name:           fox16
8 Version:        1.6.49
9 Release:        3
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        http://ftp.fox-toolkit.org/pub/fox-%{version}.tar.gz
13 # Source0-md5:  e120647d26a27ed37cd5fed8b75c8a3d
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-link.patch
16 Patch2:         %{name}-Makefile.patch
17 Patch3:         %{name}-format.patch
18 URL:            http://www.fox-toolkit.org/
19 BuildRequires:  OpenGL-GLU-devel
20 BuildRequires:  autoconf >= 2.59-9
21 BuildRequires:  automake
22 BuildRequires:  bzip2-devel >= 1.0.2
23 BuildRequires:  doxygen
24 BuildRequires:  graphviz
25 BuildRequires:  libjpeg-devel >= 6b
26 BuildRequires:  libpng-devel >= 1.2.5
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel >= 3.5.7
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  xorg-lib-libXcursor-devel
31 BuildRequires:  xorg-lib-libXext-devel
32 BuildRequires:  xorg-lib-libXft-devel
33 BuildRequires:  xorg-lib-libXrandr-devel
34 BuildRequires:  zlib-devel >= 1.1.4
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 FOX is a C++-Based Library for Graphical User Interface Development
39 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
40 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
41 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
42 graphics. Subclassing of basic FOX widgets allows for easy extension
43 beyond the built-in widgets by application writers.
44
45 This package contains FOX 1.6.x series.
46
47 %description -l pl.UTF-8
48 FOX jest biblioteką bazującą na C++ do projektowania graficznych
49 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
50 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
51 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
52 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
53 rozszerzanie.
54
55 Ten pakiet zawiera FOX z serii 1.6.x.
56
57 %package progs
58 Summary:        FOX 1.6 example applications
59 Summary(pl.UTF-8):      Przykłady aplikacji wykorzystujących FOX 1.6
60 Group:          X11/Applications
61 Requires:       %{name} = %{version}-%{release}
62 Obsoletes:      fox-example-apps
63 Obsoletes:      fox-progs < 1.7
64 Conflicts:      fox-progs >= 1.7
65
66 %description progs
67 Editor and file browser, written with FOX 1.6.
68
69 %description progs -l pl.UTF-8
70 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX 1.6.
71
72 %package devel
73 Summary:        Header files for FOX 1.6 library
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX 1.6
75 Group:          X11/Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       OpenGL-GLU-devel
78 Requires:       bzip2-devel >= 1.0.2
79 Requires:       libjpeg-devel >= 6b
80 Requires:       libpng-devel >= 1.2.5
81 Requires:       libstdc++-devel
82 Requires:       libtiff-devel >= 3.5.7
83 Requires:       xorg-lib-libXcursor-devel
84 Requires:       xorg-lib-libXext-devel
85 Requires:       xorg-lib-libXft-devel
86 Requires:       xorg-lib-libXrandr-devel
87 Requires:       zlib-devel >= 1.1.4
88
89 %description devel
90 Header files for FOX 1.6 library.
91
92 %description devel -l pl.UTF-8
93 Pliki nagłówkowe biblioteki FOX 1.6.
94
95 %package static
96 Summary:        FOX 1.6 static libraries
97 Summary(pl.UTF-8):      Biblioteki statyczne FOX 1.6
98 Group:          X11/Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100
101 %description static
102 FOX 1.6 static libraries.
103
104 %description static -l pl.UTF-8
105 Biblioteki statyczne FOX 1.6.
106
107 %package doc
108 Summary:        Development documentation for FOX 1.6 library
109 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX 1.6
110 Group:          X11/Development/Libraries
111
112 %description doc
113 Development documentation for FOX 1.6 library.
114
115 %description doc -l pl.UTF-8
116 Dokumentacja programisty do biblioteki FOX 1.6.
117
118 %package examples
119 Summary:        FOX 1.6 - example programs
120 Summary(pl.UTF-8):      FOX 1.6 - programy przykładowe
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description examples
125 FOX 1.6 - example programs.
126
127 %description examples -l pl.UTF-8
128 FOX 1.6 - przykładowe programy.
129
130 %prep
131 %setup -q -n fox-%{version}
132 %patch0 -p1
133 %patch1 -p1
134 %patch2 -p1
135 %patch3 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__automake}
142 %configure \
143         %{?debug:--enable-debug}%{!?debug:--enable-release} \
144         --enable-static%{!?with_static_libs:=no} \
145         --with-opengl \
146         --with-xft \
147         --with-shape \
148         --with-xshm \
149         --with-xcursor \
150         --with-xrandr \
151         --with-xim
152
153 %{__make}
154
155 %{__make} -C doc docs
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %{__make} -C tests clean
165 cp -a tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
166
167 mv -v $RPM_BUILD_ROOT%{_bindir}/fox-config $RPM_BUILD_ROOT%{_bindir}/fox16-config
168 mv -v $RPM_BUILD_ROOT%{_bindir}/reswrap $RPM_BUILD_ROOT%{_bindir}/reswrap16
169 mv -v $RPM_BUILD_ROOT%{_mandir}/man1/reswrap.1 $RPM_BUILD_ROOT%{_mandir}/man1/reswrap16.1
170 mv -v $RPM_BUILD_ROOT%{_pkgconfigdir}/fox.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/fox-1.6.pc
171
172 %{__rm} doc/Makefile* doc/*/Makefile*
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %files
181 %defattr(644,root,root,755)
182 %doc AUTHORS LICENSE_ADDENDUM README
183 %attr(755,root,root) %{_libdir}/libCHART-1.6.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.6.so.0
185 %attr(755,root,root) %{_libdir}/libFOX-1.6.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.6.so.0
187
188 %files progs
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_bindir}/Adie.stx
191 %attr(755,root,root) %{_bindir}/PathFinder
192 %attr(755,root,root) %{_bindir}/adie
193 %attr(755,root,root) %{_bindir}/calculator
194 %attr(755,root,root) %{_bindir}/shutterbug
195 %{_mandir}/man1/PathFinder.1*
196 %{_mandir}/man1/adie.1*
197 %{_mandir}/man1/calculator.1*
198 %{_mandir}/man1/shutterbug.1*
199
200 %files devel
201 %defattr(644,root,root,755)
202 %doc ADDITIONS TRACING
203 %attr(755,root,root) %{_bindir}/fox16-config
204 %attr(755,root,root) %{_bindir}/reswrap16
205 %attr(755,root,root) %{_libdir}/libCHART-1.6.so
206 %attr(755,root,root) %{_libdir}/libFOX-1.6.so
207 %{_libdir}/libCHART-1.6.la
208 %{_libdir}/libFOX-1.6.la
209 %{_includedir}/fox-1.6
210 %{_pkgconfigdir}/fox-1.6.pc
211 %{_mandir}/man1/reswrap16.1*
212
213 %if %{with static_libs}
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/libCHART-1.6.a
217 %{_libdir}/libFOX-1.6.a
218 %endif
219
220 %files doc
221 %defattr(644,root,root,755)
222 %doc doc/*
223
224 %files examples
225 %defattr(644,root,root,755)
226 %{_examplesdir}/%{name}-%{version}
This page took 0.335897 seconds and 3 git commands to generate.