]> git.pld-linux.org Git - packages/fox14.git/blob - fox14.spec
- added fox14.spec & patches for FOX-1.4.X series (STABLE)
[packages/fox14.git] / fox14.spec
1 #
2 # NOTE: don't add --with-xft to configure - you will get fonts beautiful like a crap
3 #
4 %bcond_without  static_libs # don't build static libraries
5 #
6 %define _oname  fox
7 %define _suffix 14
8 #
9 Summary:        The FOX C++ GUI Toolkit
10 Summary(pl):    FOX - toolkit graficzny w C++
11 Name:           %{_oname}%{_suffix}
12 Version:        1.4.27
13 Release:        0.1
14 License:        LGPL
15 Group:          X11/Libraries
16 Source0:        ftp://ftp.fox-toolkit.com/pub/%{_oname}-%{version}.tar.gz
17 # Source0-md5:  0f2925b1d595a889640b4222ab1c6a15
18 Patch0:         %{name}-opt.patch
19 Patch1:         %{name}-link.patch
20 Patch2:         %{name}-Makefile.patch
21 URL:            http://www.fox-toolkit.org/fox.html
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  bzip2-devel
26 BuildRequires:  cups-devel
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel
31 BuildRequires:  libtool
32 BuildRequires:  xcursor-devel
33 Requires:       OpenGL
34 Provides:       %{_oname} = %{version}-%{release}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
38
39 %description
40 FOX is a C++-Based Library for Graphical User Interface Development
41 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
42 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
43 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
44 graphics. Subclassing of basic FOX widgets allows for easy extension
45 beyond the built-in widgets by application writers.
46
47 %description -l pl
48 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
49 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
50 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
51 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obs³ugê
52 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
53 rozszerzanie.
54
55 %package progs
56 Summary:        FOX example applications
57 Summary(pl):    Przyk³ady aplikacji w FOX
58 Group:          X11/Applications
59 Requires:       %{name} = %{version}-%{release}
60 Provides:       %{_oname}-progs = %{version}-%{release}
61 Obsoletes:      %{name}-example-apps
62
63 %description progs
64 Editor and file browser, written with FOX.
65
66 %description progs -l pl
67 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
68
69 %package devel
70 Summary:        Header files for FOX library
71 Summary(pl):    Pliki nag³ówkowe biblioteki FOX
72 Group:          X11/Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       OpenGL-devel
75 Requires:       bzip2-devel
76 Requires:       libjpeg-devel
77 Requires:       libpng-devel
78 Requires:       libstdc++-devel
79 Requires:       libtiff-devel
80 Requires:       xcursor-devel
81 Provides:       %{_oname}-devel = %{version}-%{release}
82
83 %description devel
84 Header files for FOX library.
85
86 %description devel -l pl
87 Pliki nag³ówkowe biblioteki FOX.
88
89 %package static
90 Summary:        FOX static libraries
91 Summary(pl):    Biblioteki statyczne FOX
92 Group:          X11/Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94 Provides:       %{_oname}-static = %{version}-%{release}
95
96 %description static
97 FOX static libraries.
98
99 %description static -l pl
100 Biblioteki statyczne FOX.
101
102 %package doc
103 Summary:        Development documentation for FOX library
104 Summary(pl):    Dokumentacja programisty do biblioteki FOX
105 Group:          X11/Development/Libraries
106
107 %description doc
108 Development documentation for FOX library.
109
110 %description doc -l pl
111 Dokumentacja programisty do biblioteki FOX.
112
113 %prep
114 %setup -q -n %{_oname}-%{version}
115 %patch0 -p1
116 %patch1 -p1
117 %patch2 -p1
118
119 %build
120 %{__libtoolize}
121 %{__aclocal}
122 %{__autoconf}
123 %{__automake}
124 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
125 %configure \
126         --enable-cups \
127         --enable-release \
128         --enable-threadsafe \
129         --with-xcursor \
130         --with-xrandr \
131         --with-opengl \
132         --with-shape \
133         --with-xshm \
134         %{?debug:--enable-debug}%{!?_debug:--enable-release} \
135         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT%{_datadir}
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 rm -f doc/Makefile* doc/*/Makefile*
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS LICENSE_ADDENDUM README
156 %attr(755,root,root) %{_libdir}/lib*.so.*.*
157
158 %files progs
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/adie
161 %attr(755,root,root) %{_bindir}/calculator
162 %attr(755,root,root) %{_bindir}/PathFinder
163 %attr(755,root,root) %{_bindir}/shutterbug
164 %attr(755,root,root) %{_bindir}/Adie.stx
165 %{_mandir}/man1/*
166
167 %files devel
168 %defattr(644,root,root,755)
169 %doc ADDITIONS TRACING
170 %attr(755,root,root) %{_bindir}/fox-config
171 %attr(755,root,root) %{_bindir}/reswrap
172 %attr(755,root,root) %{_libdir}/lib*.so
173 %{_libdir}/lib*.la
174 %{_includedir}/fox-1.4
175
176 %if %{with static_libs}
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/lib*.a
180 %endif
181
182 %files doc
183 %defattr(644,root,root,755)
184 %doc doc/*
This page took 0.081886 seconds and 3 git commands to generate.