]> git.pld-linux.org Git - packages/fox14.git/commitdiff
- added fox14.spec & patches for FOX-1.4.X series (STABLE)
authortwittner <twittner@pld-linux.org>
Sat, 17 Dec 2005 01:28:46 +0000 (01:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  (fox.spec on HEAD is occupied by FOX-1.6.0-rc1)
- updated to 1.4.27

Changed files:
    fox14-Makefile.patch -> 1.1
    fox14-link.patch -> 1.1
    fox14-opt.patch -> 1.1
    fox14.spec -> 1.1

fox14-Makefile.patch [new file with mode: 0644]
fox14-link.patch [new file with mode: 0644]
fox14-opt.patch [new file with mode: 0644]
fox14.spec [new file with mode: 0644]

diff --git a/fox14-Makefile.patch b/fox14-Makefile.patch
new file mode 100644 (file)
index 0000000..c54b8f6
--- /dev/null
@@ -0,0 +1,24 @@
+diff -Nru fox-1.4.5.orig/Makefile.am fox-1.4.5/Makefile.am
+--- fox-1.4.5.orig/Makefile.am 2005-02-16 13:32:39.178606728 +0000
++++ fox-1.4.5/Makefile.am      2005-02-16 13:32:53.081493168 +0000
+@@ -4,7 +4,7 @@
+ AUTOMAKE_OPTIONS = foreign dist-zip
+ #AUTOMAKE_OPTIONS = foreign dist-zip no-dependencies
+-SUBDIRS    = utils include src chart doc tests shutterbug adie pathfinder calculator windows
++SUBDIRS    = utils include src chart tests shutterbug adie pathfinder calculator windows
+ EXTRA_DIST = ADDITIONS AUTHORS INSTALL LICENSE LICENSE_ADDENDUM TRACING README fox.lsm index.html aclocal.m4
+ bin_SCRIPTS = fox-config
+diff -Nru fox-1.4.5.orig/Makefile.in fox-1.4.5/Makefile.in
+--- fox-1.4.5.orig/Makefile.in 2005-02-16 13:32:39.178606728 +0000
++++ fox-1.4.5/Makefile.in      2005-02-16 13:32:49.459043864 +0000
+@@ -102,7 +102,7 @@
+ AUTOMAKE_OPTIONS = foreign dist-zip
+ #AUTOMAKE_OPTIONS = foreign dist-zip no-dependencies
+-SUBDIRS = utils include src chart doc tests shutterbug adie pathfinder calculator windows
++SUBDIRS = utils include src chart tests shutterbug adie pathfinder calculator windows
+ EXTRA_DIST = ADDITIONS AUTHORS INSTALL LICENSE LICENSE_ADDENDUM TRACING README fox.lsm index.html aclocal.m4
+ bin_SCRIPTS = fox-config
diff --git a/fox14-link.patch b/fox14-link.patch
new file mode 100644 (file)
index 0000000..1be716a
--- /dev/null
@@ -0,0 +1,11 @@
+--- fox-1.2.4/chart/Makefile.am        2004-05-17 06:58:27.000000000 +0000
++++ fox-1.2.4.new/chart/Makefile.am    2004-06-16 17:57:39.030439224 +0000
+@@ -8,7 +8,7 @@
+ lib_LTLIBRARIES = libCHART-1.4.la
+-libCHART_1_4_la_LIBADD  = $(X_LIBS) $(X_BASE_LIBS) $(X_EXTRA_LIBS)
++libCHART_1_4_la_LIBADD  = $(X_LIBS) $(X_BASE_LIBS) $(X_EXTRA_LIBS) ../src/libFOX-1.4.la
+ libCHART_1_4_la_LDFLAGS = \
+         -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)    \
diff --git a/fox14-opt.patch b/fox14-opt.patch
new file mode 100644 (file)
index 0000000..97eae94
--- /dev/null
@@ -0,0 +1,30 @@
+--- fox-1.0.30/configure.in.orig       Sat Jan 11 06:01:11 2003
++++ fox-1.0.30/configure.in    Tue Jan 28 19:29:29 2003
+@@ -49,9 +49,6 @@
+ AC_SUBST(LT_REVISION)
+ AC_SUBST(LT_AGE)
+-dnl Prevents setting flags.
+-CXXFLAGS=""
+-
+ dnl Checks for programs.
+ AC_PROG_MAKE_SET
+ AC_PROG_CC
+@@ -240,7 +237,7 @@
+ AC_ARG_ENABLE(debug,[  --enable-debug          compile for debugging])
+ AC_MSG_RESULT([$enable_debug])
+ if test "x$enable_debug" = "xyes" ; then
+-CXXFLAGS="${CXXFLAGS} -g -DDEBUG"
++CXXFLAGS="${CXXFLAGS} -DDEBUG"
+ fi
+ dnl Building for release
+@@ -248,7 +245,7 @@
+ AC_ARG_ENABLE(release,[  --enable-release        compile for release])
+ AC_MSG_RESULT([$enable_release])
+ if test "x$enable_release" = "xyes" ; then
+-CXXFLAGS="${CXXFLAGS} -O2 -DNDEBUG"
++CXXFLAGS="${CXXFLAGS} -DNDEBUG"
+ if test "${GXX}" = "yes" ; then
+ CXXFLAGS="${CXXFLAGS} -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations"
+ fi
diff --git a/fox14.spec b/fox14.spec
new file mode 100644 (file)
index 0000000..c724b0a
--- /dev/null
@@ -0,0 +1,184 @@
+#
+# NOTE: don't add --with-xft to configure - you will get fonts beautiful like a crap
+#
+%bcond_without static_libs # don't build static libraries
+#
+%define        _oname  fox
+%define _suffix        14
+#
+Summary:       The FOX C++ GUI Toolkit
+Summary(pl):   FOX - toolkit graficzny w C++
+Name:          %{_oname}%{_suffix}
+Version:       1.4.27
+Release:       0.1
+License:       LGPL
+Group:         X11/Libraries
+Source0:       ftp://ftp.fox-toolkit.com/pub/%{_oname}-%{version}.tar.gz
+# Source0-md5: 0f2925b1d595a889640b4222ab1c6a15
+Patch0:                %{name}-opt.patch
+Patch1:                %{name}-link.patch
+Patch2:                %{name}-Makefile.patch
+URL:           http://www.fox-toolkit.org/fox.html
+BuildRequires: OpenGL-devel
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: bzip2-devel
+BuildRequires: cups-devel
+BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel
+BuildRequires: libstdc++-devel
+BuildRequires: libtiff-devel
+BuildRequires: libtool
+BuildRequires: xcursor-devel
+Requires:      OpenGL
+Provides:      %{_oname} = %{version}-%{release}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define        _noautoreqdep   libGL.so.1 libGLU.so.1
+
+%description
+FOX is a C++-Based Library for Graphical User Interface Development
+FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
+Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
+idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
+graphics. Subclassing of basic FOX widgets allows for easy extension
+beyond the built-in widgets by application writers.
+
+%description -l pl
+FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
+interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
+GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
+liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obs³ugê
+grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
+rozszerzanie.
+
+%package progs
+Summary:       FOX example applications
+Summary(pl):   Przyk³ady aplikacji w FOX
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{_oname}-progs = %{version}-%{release}
+Obsoletes:     %{name}-example-apps
+
+%description progs
+Editor and file browser, written with FOX.
+
+%description progs -l pl
+Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
+
+%package devel
+Summary:       Header files for FOX library
+Summary(pl):   Pliki nag³ówkowe biblioteki FOX
+Group:         X11/Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      OpenGL-devel
+Requires:      bzip2-devel
+Requires:      libjpeg-devel
+Requires:      libpng-devel
+Requires:      libstdc++-devel
+Requires:      libtiff-devel
+Requires:      xcursor-devel
+Provides:      %{_oname}-devel = %{version}-%{release}
+
+%description devel
+Header files for FOX library.
+
+%description devel -l pl
+Pliki nag³ówkowe biblioteki FOX.
+
+%package static
+Summary:       FOX static libraries
+Summary(pl):   Biblioteki statyczne FOX
+Group:         X11/Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+Provides:      %{_oname}-static = %{version}-%{release}
+
+%description static
+FOX static libraries.
+
+%description static -l pl
+Biblioteki statyczne FOX.
+
+%package doc
+Summary:       Development documentation for FOX library
+Summary(pl):   Dokumentacja programisty do biblioteki FOX
+Group:         X11/Development/Libraries
+
+%description doc
+Development documentation for FOX library.
+
+%description doc -l pl
+Dokumentacja programisty do biblioteki FOX.
+
+%prep
+%setup -q -n %{_oname}-%{version}
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+
+%build
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__automake}
+LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
+%configure \
+       --enable-cups \
+       --enable-release \
+       --enable-threadsafe \
+       --with-xcursor \
+       --with-xrandr \
+       --with-opengl \
+       --with-shape \
+       --with-xshm \
+       %{?debug:--enable-debug}%{!?_debug:--enable-release} \
+       --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_datadir}
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+rm -f doc/Makefile* doc/*/Makefile*
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS LICENSE_ADDENDUM README
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
+
+%files progs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/adie
+%attr(755,root,root) %{_bindir}/calculator
+%attr(755,root,root) %{_bindir}/PathFinder
+%attr(755,root,root) %{_bindir}/shutterbug
+%attr(755,root,root) %{_bindir}/Adie.stx
+%{_mandir}/man1/*
+
+%files devel
+%defattr(644,root,root,755)
+%doc ADDITIONS TRACING
+%attr(755,root,root) %{_bindir}/fox-config
+%attr(755,root,root) %{_bindir}/reswrap
+%attr(755,root,root) %{_libdir}/lib*.so
+%{_libdir}/lib*.la
+%{_includedir}/fox-1.4
+
+%if %{with static_libs}
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/lib*.a
+%endif
+
+%files doc
+%defattr(644,root,root,755)
+%doc doc/*
This page took 0.099065 seconds and 4 git commands to generate.