]> git.pld-linux.org Git - packages/fonts-TTF-microsoft.git/commitdiff
- switch to license-installer.sh from SVN/DistFiles
authorpawelz <pawelz@pld-linux.org>
Sat, 26 Dec 2009 12:54:49 +0000 (12:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fonts-TTF-microsoft.spec -> 1.41
    license-installer.sh -> 1.14

fonts-TTF-microsoft.spec
license-installer.sh [deleted file]

index d9d25a2b13e6f8d2735427a5f70964c0d6b39bfb..1c30e612c48e35891795f178c6df34826a2ac848 100644 (file)
@@ -43,7 +43,8 @@ Source9:      http://dl.sourceforge.net/corefonts/verdan32.exe
 Source10:      http://dl.sourceforge.net/corefonts/webdin32.exe
 # Source10-md5:        230a1d13a365b22815f502eb24d9149b
 %else
 Source10:      http://dl.sourceforge.net/corefonts/webdin32.exe
 # Source10-md5:        230a1d13a365b22815f502eb24d9149b
 %else
-Source21:      license-installer.sh
+Source21:      http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source21-md5:        4fb1600353dd57fe088e0b12fb0ecac2
 # extracted from one of the above
 Source20:      Microsoft-EULA.txt
 %endif
 # extracted from one of the above
 Source20:      Microsoft-EULA.txt
 %endif
diff --git a/license-installer.sh b/license-installer.sh
deleted file mode 100644 (file)
index a47c817..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/bin/sh
-if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
-       tmp=$(mktemp -d)
-       SRPMDIR=`rpm --define "_topdir $tmp" --eval "%{_srcrpmdir}"`
-       BUILDDIR=`rpm --define "_topdir $tmp" --eval "%{_builddir}"`
-       RPMDIR=`rpm --define "_topdir $tmp" --eval "%{_rpmdir}"`
-       PACKAGEDIR="$tmp/packages/@BASE_NAME@"
-       mkdir -p $SRPMDIR $RPMDIR $SRPMDIR $BUILDDIR $PACKAGEDIR
-
-       if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               (
-               if echo "$3" | grep '://' >/dev/null; then
-                       cd $SRPMDIR
-                       wget --passive-ftp -t0 "$3"
-               else
-                       cp -f "$3" $SRPMDIR
-               fi
-               rpm2cpio `basename "$3"` | ( cd $PACKAGEDIR; cpio -i @BASE_NAME@.spec )
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       rpm2cpio `basename "$3"` | ( cd $PACKAGEDIR; cpio -i @COPYSOURCES@ )
-               fi
-               )
-       else
-               cp -i "$3" $PACKAGEDIR || exit 1
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       for i in @COPYSOURCES@; do
-                               cp -i @DATADIR@/$i $PACKAGEDIR/$i || exit 1
-                       done
-               fi
-       fi
-       ( cd $PACKAGEDIR
-       nd=
-       if [ '@USE_DISTFILES@' = 'no' ]; then
-               nd=-nd
-       fi
-       /usr/bin/builder --define _topdir $tmp $nd -nm -nc -ncs --with license_agreement --target @TARGET_CPU@ @BASE_NAME@.spec
-       if [ "$?" -ne 0 ]; then
-               exit 2
-       fi
-       RPMNAMES="$RPMDIR/@BASE_NAME@-@VERSION@-@RELEASE@wla.@TARGET_CPU@.rpm"
-       rpm -Uhv $RPMNAMES || echo -e "Install manually the file(s):\n   $RPMNAMES" )
-else
-       if [ "@LICENSE@" != '@'LICENSE'@' ]; then
-               cat @LICENSE@
-               echo "
-If you accept the above license rebuild the package using:
-"
-       else
-               echo "
-License issues made us not to include inherent files into
-this package by default. If you want to create full working
-package please build it with the following command:
-"
-       fi
-       echo "$0 --with license_agreement @SPECFILE@"
-fi
This page took 0.159821 seconds and 4 git commands to generate.