]> git.pld-linux.org Git - packages/fonts-TTF-microsoft.git/blob - fonts-TTF-microsoft.spec
d9d25a2b13e6f8d2735427a5f70964c0d6b39bfb
[packages/fonts-TTF-microsoft.git] / fonts-TTF-microsoft.spec
1 # NOTE
2 # according to EULA we *can* store the .exe's in distfiles in
3 # unaltered form (that is those .exe files), while can't distribute
4 # resulting rpm.
5 #
6 # Conditional build:
7 %bcond_with     license_agreement       # generates package
8
9 %define         base_name       fonts-TTF-microsoft
10 %define         rel     9
11 Summary:        Microsoft TrueType fonts
12 Summary(pl.UTF-8):      Fonty TrueType firmy Microsoft
13 %if %{with license_agreement}
14 Name:           %{base_name}
15 %else
16 Name:           %{base_name}-installer
17 %endif
18 Version:        20020525
19 Release:        %{rel}%{?with_license_agreement:wla}
20 License:        Microsoft EULA (for non-commercial use)
21 Group:          Fonts
22 %if %{with license_agreement}
23 Source0:        http://dl.sourceforge.net/corefonts/andale32.exe
24 # Source0-md5:  cbdc2fdd7d2ed0832795e86a8b9ee19a
25 Source1:        http://dl.sourceforge.net/corefonts/arial32.exe
26 # Source1-md5:  9637df0e91703179f0723ec095a36cb5
27 Source2:        http://dl.sourceforge.net/corefonts/arialb32.exe
28 # Source2-md5:  c9089ae0c3b3d0d8c4b0a95979bb9ff0
29 Source3:        http://dl.sourceforge.net/corefonts/comic32.exe
30 # Source3-md5:  2b30de40bb5e803a0452c7715fc835d1
31 Source4:        http://dl.sourceforge.net/corefonts/courie32.exe
32 # Source4-md5:  4e412c772294403ab62fb2d247d85c60
33 Source5:        http://dl.sourceforge.net/corefonts/georgi32.exe
34 # Source5-md5:  4d90016026e2da447593b41a8d8fa8bd
35 Source6:        http://dl.sourceforge.net/corefonts/impact32.exe
36 # Source6-md5:  7907c7dd6684e9bade91cff82683d9d7
37 Source7:        http://dl.sourceforge.net/corefonts/times32.exe
38 # Source7-md5:  ed39c8ef91b9fb80f76f702568291bd5
39 Source8:        http://dl.sourceforge.net/corefonts/trebuc32.exe
40 # Source8-md5:  0d7ea16cac6261f8513a061fbfcdb2b5
41 Source9:        http://dl.sourceforge.net/corefonts/verdan32.exe
42 # Source9-md5:  12d2a75f8156e10607be1eaa8e8ef120
43 Source10:       http://dl.sourceforge.net/corefonts/webdin32.exe
44 # Source10-md5: 230a1d13a365b22815f502eb24d9149b
45 %else
46 Source21:       license-installer.sh
47 # extracted from one of the above
48 Source20:       Microsoft-EULA.txt
49 %endif
50 URL:            http://corefonts.sourceforge.net/
51 %if %{with license_agreement}
52 BuildRequires:  cabextract
53 Requires(post,postun):  fontpostinst
54 Requires:       %{_fontsdir}/TTF
55 Requires:       fontpostinst
56 %else
57 Requires:       cabextract
58 Requires:       mktemp > 1.5-18
59 Requires:       rpm-build-tools >= 4.4.35
60 %endif
61 BuildArch:      noarch
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         ttffontsdir     %{_fontsdir}/TTF
65
66 %description
67 Microsoft free TrueType fonts collection.
68
69 %description -l pl.UTF-8
70 Kolekcja darmowych fontów TrueType firmy Microsoft.
71
72 %prep
73 %if %{with license_agreement}
74 %setup -q -c -T
75 %{_bindir}/cabextract -L %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} \
76 %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} \
77 %{SOURCE10}
78 %endif
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %if !%{with license_agreement}
84 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
85
86 sed -e '
87         s/@BASE_NAME@/%{base_name}/g
88         s/@TARGET_CPU@/%{_target_cpu}/g
89         s-@VERSION@-%{version}-g
90         s-@RELEASE@-%{release}-g
91         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
92         s,@DATADIR@,%{_datadir}/%{base_name},g
93         s,@LICENSE@,%{_datadir}/%{base_name}/Microsoft-EULA.txt,
94 ' %{SOURCE21} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
95
96 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
97 install %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
98
99 %else
100 install -d $RPM_BUILD_ROOT%{ttffontsdir}
101 install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
102 %endif
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %if %{with license_agreement}
108 %post
109 fontpostinst TTF
110
111 %postun
112 fontpostinst TTF
113
114 %else
115 %post
116 echo "
117 If you accept the license enclosed in the file
118 %{_datadir}/%{base_name}/Microsoft-EULA.txt
119 and want to install real fonts, then rebuild the package with the
120 following command:
121
122 %{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
123 "
124 %endif
125
126 %files
127 %defattr(644,root,root,755)
128 %if %{with license_agreement}
129 %doc licen.txt
130 %{ttffontsdir}/*
131 %else
132 %attr(755,root,root) %{_bindir}/%{base_name}.install
133 %{_datadir}/%{base_name}
134 %endif
This page took 0.030134 seconds and 2 git commands to generate.