]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
- rel 3; disable tests using bwrap
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  doc             # don't build HTML and man docs
5 %bcond_without  tests           # don't perform make check
6
7 Summary:        Font configuration and customization tools
8 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów
9 Summary(pt_BR.UTF-8):   Ferramentas para configuração e customização do acesso a fontes
10 Name:           fontconfig
11 Version:        2.13.1
12 Release:        3
13 Epoch:          1
14 License:        MIT
15 Group:          Libraries
16 Source0:        https://www.freedesktop.org/software/fontconfig/release/%{name}-%{version}.tar.bz2
17 # Source0-md5:  36cdea1058ef13cbbfdabe6cb019dc1c
18 Source1:        %{name}-lcd-filter.conf
19 Patch0:         %{name}-bitstream-cyberbit.patch
20 URL:            http://fontconfig.org/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake >= 1:1.11
23 %if %{with doc}
24 BuildRequires:  docbook-dtd31-sgml
25 BuildRequires:  docbook-dtd41-sgml
26 BuildRequires:  docbook-utils >= 0.6.13-3
27 %endif
28 BuildRequires:  ed
29 BuildRequires:  expat-devel
30 # pkgconfig(freetype) >= 21.0.15
31 BuildRequires:  freetype-devel >= 1:2.8.1
32 BuildRequires:  gettext-tools >= 0.19.8
33 BuildRequires:  gperf
34 %{?with_tests:BuildRequires:    json-c-devel}
35 BuildRequires:  libtool >= 2:2.2
36 BuildRequires:  libuuid-devel
37 BuildRequires:  pkgconfig
38 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Fontconfig is designed to locate fonts within the system and select
43 them according to requirements specified by applications.
44
45 This package contains tools and documentation.
46
47 %description -l pl.UTF-8
48 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
49 systemie i wybierania ich w zależności od potrzeb aplikacji.
50
51 Paket ten zawiera programy narzędziowe i dokumentację.
52
53 %description -l pt_BR.UTF-8
54 Fontconfig é uma biblioteca para configuração e customização do acesso
55 a fontes.
56
57 Este pacote contém as ferramentas e documentação.
58
59 %package libs
60 Summary:        Font configuration and customization library
61 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów
62 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes
63 Group:          Libraries
64 Requires:       freetype >= 1:2.8.1
65 Provides:       XFree86-fontconfig
66 Obsoletes:      XFree86-fontconfig
67 Conflicts:      fontconfig <= 1:2.2.98-1
68
69 %description libs
70 Fontconfig is designed to locate fonts within the system and select
71 them according to requirements specified by applications.
72
73 %description libs -l pl.UTF-8
74 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
75 systemie i wybierania ich w zależności od potrzeb aplikacji.
76
77 %description libs -l pt_BR.UTF-8
78 Fontconfig é uma biblioteca para configuração e customização do acesso
79 a fontes.
80
81 %package devel
82 Summary:        Font configuration and customization library - development files
83 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów - pliki dla programistów
84 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
85 Group:          Development/Libraries
86 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
87 Requires:       expat-devel
88 Requires:       freetype-devel >= 1:2.8.1
89 Requires:       libuuid-devel
90 Provides:       XFree86-fontconfig-devel
91 Obsoletes:      XFree86-fontconfig-devel
92
93 %description devel
94 Fontconfig is designed to locate fonts within the system and select
95 them according to requirements specified by applications.
96
97 This package contains the header files needed to develop programs that
98 use these fontconfig.
99
100 %description devel -l pl.UTF-8
101 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
102 systemie i wybierania ich w zależności od potrzeb aplikacji.
103
104 Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
105 programów korzystających z biblioteki fontconfig.
106
107 %description devel -l pt_BR.UTF-8
108 Fontconfig é uma biblioteca para configuração e customização do acesso
109 a fontes.
110
111 Este pacote contém arquivos de desenvolvimento necessários à criação
112 de extensões baseadas na biblioteca fontconfig.
113
114 %package static
115 Summary:        Static font configuration and customization library
116 Summary(pl.UTF-8):      Statyczna biblioteka do konfigurowania fontów
117 Summary(pt_BR.UTF-8):   Biblioteca estática para configuração e customização do acesso a fontes
118 Group:          Development/Libraries
119 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
120 Provides:       XFree86-fontconfig-static
121 Obsoletes:      XFree86-fontconfig-static
122
123 %description static
124 This package contains static version of fontconfig library.
125
126 %description static -l pl.UTF-8
127 Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
128
129 %description static -l pt_BR.UTF-8
130 Este pacote contém a biblioteca estática do fontconfig
131
132 %prep
133 %setup -q
134 %patch0 -p1
135
136 # bwrap: No permissions to creating new namespace, likely because the kernel does not allow non-privileged user namespaces...
137 sed -i -e 's#BWRAP=.*#BWRAP=#g' test/run-test.sh
138
139 %build
140 %{__gettextize}
141 %{__libtoolize}
142 %{__aclocal} -I m4
143 %{__autoconf}
144 %{__autoheader}
145 %{__automake}
146
147 # don't rebuild docs by default, use prebuild ones
148 export HASDOCBOOK=no
149
150 %configure \
151         --enable-docs%{!?with_doc:=no} \
152         --disable-silent-rules \
153         --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static
154 %{__make}
155
156 %{?with_tests:%{__make} OSTYPE=linux check || (cat test/test-suite.log && /bin/false)}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT \
164         htmldoc_DATA= \
165         doc_DATA=
166
167 install %{SOURCE1} \
168         $RPM_BUILD_ROOT%{_datadir}/%{name}/conf.avail/10-lcd-filter.conf
169
170 ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.avail
171
172 cp -pf conf.d/README README.confd
173
174 %find_lang %{name}
175 %find_lang %{name}-conf -a %{name}.lang
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %pretrans
181 # this needs to be a symlink
182 if [ -d %{_sysconfdir}/fonts/conf.avail ] && [ ! -L %{_sysconfdir}/fonts/conf.avail ]; then
183         mv -f %{_sysconfdir}/fonts/conf.avail{,.rpmsave}
184         install -d %{_datadir}/%{name}/conf.avail
185         ln -s %{_datadir}/%{name}/conf.avail %{_sysconfdir}/fonts/conf.avail
186         mv -f %{_sysconfdir}/fonts/conf.avail.rpmsave/*.conf %{_sysconfdir}/fonts/conf.avail/
187         rmdir %{_sysconfdir}/fonts/conf.avail.rpmsave 2>/dev/null || :
188 fi
189
190 %post
191 umask 022
192 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
193
194 %post   libs -p /sbin/ldconfig
195 %postun libs -p /sbin/ldconfig
196
197 %files -f %{name}.lang
198 %defattr(644,root,root,755)
199 %doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
200 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
201 %{_sysconfdir}/fonts/conf.avail
202 %{_sysconfdir}/fonts/conf.d/README
203 %config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
204 %attr(755,root,root) %{_bindir}/fc-cache
205 %attr(755,root,root) %{_bindir}/fc-cat
206 %attr(755,root,root) %{_bindir}/fc-conflist
207 %attr(755,root,root) %{_bindir}/fc-list
208 %attr(755,root,root) %{_bindir}/fc-match
209 %attr(755,root,root) %{_bindir}/fc-query
210 %attr(755,root,root) %{_bindir}/fc-pattern
211 %attr(755,root,root) %{_bindir}/fc-scan
212 %attr(755,root,root) %{_bindir}/fc-validate
213 %dir %{_datadir}/xml/%{name}
214 %{_datadir}/xml/%{name}/fonts.dtd
215 %{_datadir}/%{name}/conf.avail/*.conf
216 %if %{with doc}
217 %{_mandir}/man1/fc-*.1*
218 %{_mandir}/man5/fonts-conf.5*
219 %endif
220 %dir /var/cache/fontconfig
221
222 %files libs
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/libfontconfig.so.*.*.*
225 %attr(755,root,root) %ghost %{_libdir}/libfontconfig.so.1
226
227 %files devel
228 %defattr(644,root,root,755)
229 %doc doc/fontconfig-devel/*.html
230 %attr(755,root,root) %{_libdir}/libfontconfig.so
231 %{_libdir}/libfontconfig.la
232 %{_includedir}/fontconfig
233 %{_pkgconfigdir}/fontconfig.pc
234 %{_datadir}/gettext/its/fontconfig.its
235 %{_datadir}/gettext/its/fontconfig.loc
236 %if %{with doc}
237 %{_mandir}/man3/Fc*.3*
238 %endif
239
240 %if %{with static_libs}
241 %files static
242 %defattr(644,root,root,755)
243 %{_libdir}/libfontconfig.a
244 %endif
This page took 0.041834 seconds and 4 git commands to generate.