]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
- rel 4; drop non upstream default config from here; drop blacklist (dropped by fc)
[packages/fontconfig.git] / fontconfig.spec
1 # Conditional build
2 %bcond_without  static_libs     # don't build static library
3 %bcond_without  doc
4
5 Summary:        Font configuration and customization tools
6 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów
7 Summary(pt_BR.UTF-8):   Ferramentas para configuração e customização do acesso a fontes
8 Name:           fontconfig
9 Version:        2.10.1
10 Release:        4
11 Epoch:          1
12 License:        MIT
13 Group:          Libraries
14 Source0:        http://fontconfig.org/release/%{name}-%{version}.tar.gz
15 # Source0-md5:  c94e380eea42f2f23ca9537035ef1899
16 Patch0:         %{name}-bitstream-cyberbit.patch
17 URL:            http://fontconfig.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 %if %{with doc}
21 BuildRequires:  docbook-dtd31-sgml
22 BuildRequires:  docbook-dtd41-sgml
23 BuildRequires:  docbook-utils >= 0.6.13-3
24 %endif
25 BuildRequires:  ed
26 BuildRequires:  expat-devel
27 BuildRequires:  freetype-devel >= 2.1.5
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig
30 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
31 Requires:       freetype >= 2.1.5
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Fontconfig is designed to locate fonts within the system and select
36 them according to requirements specified by applications.
37
38 This package contains tools and documentation.
39
40 %description -l pl.UTF-8
41 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
42 systemie i wybierania ich w zależności od potrzeb aplikacji.
43
44 Paket ten zawiera programy narzędziowe i dokumentację.
45
46 %description -l pt_BR.UTF-8
47 Fontconfig é uma biblioteca para configuração e customização do acesso
48 a fontes.
49
50 Este pacote contém as ferramentas e documentação.
51
52 %package libs
53 Summary:        Font configuration and customization library
54 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów
55 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes
56 Group:          Libraries
57 Requires:       freetype >= 2.1.5
58 Provides:       XFree86-fontconfig
59 Obsoletes:      XFree86-fontconfig
60 Conflicts:      fontconfig <= 1:2.2.98-1
61
62 %description libs
63 Fontconfig is designed to locate fonts within the system and select
64 them according to requirements specified by applications.
65
66 %description libs -l pl.UTF-8
67 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
68 systemie i wybierania ich w zależności od potrzeb aplikacji.
69
70 %description libs -l pt_BR.UTF-8
71 Fontconfig é uma biblioteca para configuração e customização do acesso
72 a fontes.
73
74 %package devel
75 Summary:        Font configuration and customization library - development files
76 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów - pliki dla programistów
77 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
80 Requires:       expat-devel
81 Requires:       freetype-devel >= 2.1.5
82 Provides:       XFree86-fontconfig-devel
83 Obsoletes:      XFree86-fontconfig-devel
84
85 %description devel
86 Fontconfig is designed to locate fonts within the system and select
87 them according to requirements specified by applications.
88
89 This package contains the header files needed to develop programs that
90 use these fontconfig.
91
92 %description devel -l pl.UTF-8
93 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
94 systemie i wybierania ich w zależności od potrzeb aplikacji.
95
96 Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
97 programów korzystających z biblioteki fontconfig.
98
99 %description devel -l pt_BR.UTF-8
100 Fontconfig é uma biblioteca para configuração e customização do acesso
101 a fontes.
102
103 Este pacote contém arquivos de desenvolvimento necessários à criação
104 de extensões baseadas na biblioteca fontconfig.
105
106 %package static
107 Summary:        Static font configuration and customization library
108 Summary(pl.UTF-8):      Statyczna biblioteka do konfigurowania fontów
109 Summary(pt_BR.UTF-8):   Biblioteca estática para configuração e customização do acesso a fontes
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
112 Provides:       XFree86-fontconfig-static
113 Obsoletes:      XFree86-fontconfig-static
114
115 %description static
116 This package contains static version of fontconfig library.
117
118 %description static -l pl.UTF-8
119 Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
120
121 %description static -l pt_BR.UTF-8
122 Este pacote contém a biblioteca estática do fontconfig
123
124 %prep
125 %setup -q
126 %patch0 -p1
127
128 %build
129 %{__libtoolize}
130 %{__aclocal}
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134
135 # don't rebuild docs by default, use prebuild ones
136 export HASDOCBOOK=no
137
138 %configure \
139         --%{?with_doc:en}%{!?with_doc:dis}able-docs \
140         --disable-silent-rules \
141         %{!?with_static_libs:--disable-static}
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
147
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT \
150         htmldoc_DATA= \
151         doc_DATA=
152
153 ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.avail
154
155 cp -pf conf.d/README README.confd
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %pretrans
161 # this needs to be a symlink
162 if [ -d %{_sysconfdir}/fonts/conf.avail ] && [ ! -L %{_sysconfdir}/fonts/conf.avail ]; then
163         mv -f %{_sysconfdir}/fonts/conf.avail{,.rpmsave}
164         install -d %{_datadir}/%{name}/conf.avail
165         ln -s %{_datadir}/%{name}/conf.avail %{_sysconfdir}/fonts/conf.avail
166         mv -f %{_sysconfdir}/fonts/conf.avail.rpmsave/*.conf %{_sysconfdir}/fonts/conf.avail/
167         rmdir %{_sysconfdir}/fonts/conf.avail.rpmsave 2>/dev/null || :
168 fi
169
170 %post
171 umask 022
172 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
173
174 %post   libs -p /sbin/ldconfig
175 %postun libs -p /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 %doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
180 %dir %{_sysconfdir}/fonts
181 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
182 %{_sysconfdir}/fonts/conf.avail
183 %dir %{_datadir}/xml/%{name}
184 %{_datadir}/xml/%{name}/fonts.dtd
185 %dir %{_datadir}/%{name}
186 %dir %{_datadir}/%{name}/conf.avail
187 %{_datadir}/%{name}/conf.avail/*.conf
188 %dir %{_sysconfdir}/fonts/conf.d
189 %{_sysconfdir}/fonts/conf.d/README
190 %config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
191 %attr(755,root,root) %{_bindir}/fc-cache
192 %attr(755,root,root) %{_bindir}/fc-cat
193 %attr(755,root,root) %{_bindir}/fc-list
194 %attr(755,root,root) %{_bindir}/fc-match
195 %attr(755,root,root) %{_bindir}/fc-query
196 %attr(755,root,root) %{_bindir}/fc-pattern
197 %attr(755,root,root) %{_bindir}/fc-scan
198 %if %{with doc}
199 %{_mandir}/man1/fc-*.1*
200 %{_mandir}/man5/fonts-conf.5*
201 %endif
202 %dir /var/cache/fontconfig
203
204 %files libs
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/libfontconfig.so.*.*.*
207 %attr(755,root,root) %ghost %{_libdir}/libfontconfig.so.1
208
209 %files devel
210 %defattr(644,root,root,755)
211 %doc doc/fontconfig-devel/*.html
212 %attr(755,root,root) %{_libdir}/libfontconfig.so
213 %{_libdir}/libfontconfig.la
214 %{_includedir}/fontconfig
215 %{_pkgconfigdir}/fontconfig.pc
216 %if %{with doc}
217 %{_mandir}/man3/Fc*.3*
218 %endif
219
220 %if %{with static_libs}
221 %files static
222 %defattr(644,root,root,755)
223 %{_libdir}/libfontconfig.a
224 %endif
This page took 0.043346 seconds and 4 git commands to generate.