]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
- added -cmap-parsing.patch from FC (speed up cache generation)
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_with     bytecode        # use bytecode hinting instead of autohinting by default
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        Font configuration and customization tools
7 Summary(pl):    Narzêdzia do konfigurowania fontów
8 Summary(pt_BR): Ferramentas para configuração e customização do acesso a fontes
9 Name:           fontconfig
10 Version:        2.3.95
11 Release:        2
12 Epoch:          1
13 License:        MIT
14 Group:          Libraries
15 Source0:        http://fontconfig.org/release/%{name}-%{version}.tar.gz
16 # Source0-md5:  6860be35882f6d34636d52345efd5944
17 Patch0:         %{name}-blacklist.patch
18 Patch1:         %{name}-autohint.patch
19 Patch2:         %{name}-cmap-parsing.patch
20 URL:            http://fontconfig.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  docbook-utils >= 0.6.13-3
24 BuildRequires:  docbook-dtd41-sgml
25 BuildRequires:  ed
26 BuildRequires:  expat-devel
27 BuildRequires:  freetype-devel >= 2.1.5
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig
30 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
31 Requires:       freetype >= 2.1.5
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Fontconfig is designed to locate fonts within the system and select
36 them according to requirements specified by applications.
37
38 This package contains tools and documentation.
39
40 %description -l pl
41 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
42 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
43
44 Paket ten zawiera programy narzêdziowe i dokumentacjê.
45
46 %description -l pt_BR
47 Fontconfig é uma biblioteca para configuração e customização do acesso
48 a fontes.
49
50 Este pacote contém as ferramentas e documentação.
51
52 %package libs
53 Summary:        Font configuration and customization library
54 Summary(pl):    Biblioteka do konfigurowania fontów
55 Summary(pt_BR): Biblioteca para configuração e customização do acesso a fontes
56 Group:          Development/Libraries
57 Requires:       freetype >= 2.1.5
58 Provides:       XFree86-fontconfig
59 Conflicts:      fontconfig <= 1:2.2.98-1
60 Obsoletes:      XFree86-fontconfig
61
62 %description libs
63 Fontconfig is designed to locate fonts within the system and select
64 them according to requirements specified by applications.
65
66 %description libs -l pl
67 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
68 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
69
70 %description libs -l pt_BR
71 Fontconfig é uma biblioteca para configuração e customização do acesso
72 a fontes.
73
74 %package devel
75 Summary:        Font configuration and customization library - development files
76 Summary(pl):    Biblioteka do konfigurowania fontów - pliki dla programistów
77 Summary(pt_BR): Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
80 Requires:       expat-devel
81 Requires:       freetype-devel >= 2.1.5
82 Provides:       XFree86-fontconfig-devel
83 Obsoletes:      XFree86-fontconfig-devel
84
85 %description devel
86 Fontconfig is designed to locate fonts within the system and select
87 them according to requirements specified by applications.
88
89 This package contains the header files needed to develop programs that
90 use these fontconfig.
91
92 %description devel -l pl
93 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
94 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
95
96 Ten pakiet zawiera pliki nag³ówkowe potrzebne do kompilowania
97 programów korzystaj±cych z biblioteki fontconfig.
98
99 %description devel -l pt_BR
100 Fontconfig é uma biblioteca para configuração e customização do acesso
101 a fontes.
102
103 Este pacote contém arquivos de desenvolvimento necessários à criação
104 de extensões baseadas na biblioteca fontconfig.
105
106 %package static
107 Summary:        Static font configuration and customization library
108 Summary(pl):    Statyczna biblioteka do konfigurowania fontów
109 Summary(pt_BR): Biblioteca estática para configuração e customização do acesso a fontes
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
112 Provides:       XFree86-fontconfig-static
113 Obsoletes:      XFree86-fontconfig-static
114
115 %description static
116 This package contains static version of fontconfig library.
117
118 %description static -l pl
119 Ten pakiet zawiera statyczn± wersjê biblioteki fontconfig.
120
121 %description static -l pt_BR
122 Este pacote contém a biblioteca estática do fontconfig
123
124 %prep
125 %setup -q
126 %patch0 -p1
127 %if %{with bytecode}
128 %patch1 -p1
129 %endif
130 %patch2 -p1
131
132 %build
133 %{__libtoolize}
134 %{__aclocal}
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure \
139         --disable-docs \
140         %{!?with_static_libs:--disable-static}
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig}
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 install doc/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
151 install doc/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
152
153 cp -f conf.d/README README.confd
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post
159 umask 022
160 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
161
162 %post   libs -p /sbin/ldconfig
163 %postun libs -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc AUTHORS COPYING ChangeLog README README.confd
168 %attr(755,root,root) %{_bindir}/fc-*
169 %{_mandir}/man1/*.1*
170 %{_mandir}/man5/*.5*
171 /var/cache/fontconfig
172
173 %files libs
174 %defattr(644,root,root,755)
175 %dir %{_sysconfdir}/fonts
176 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
177 %{_sysconfdir}/fonts/fonts.dtd
178 %dir %{_sysconfdir}/fonts/conf.d
179 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
180 %attr(755,root,root) %{_libdir}/lib*.so.*.*
181
182 %files devel
183 %defattr(644,root,root,755)
184 %doc doc/fontconfig-devel/*.html
185 %attr(755,root,root) %{_libdir}/lib*.so
186 %{_libdir}/lib*.la
187 %{_includedir}/fontconfig
188 %{_pkgconfigdir}/fontconfig.pc
189 %{_mandir}/man3/*.3*
190
191 %if %{with static_libs}
192 %files static
193 %defattr(644,root,root,755)
194 %{_libdir}/lib*.a
195 %endif
This page took 0.054344 seconds and 4 git commands to generate.