]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
Release 2 to rebuild to fix missing FT_Done_MM_Var symbol
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  doc             # don't build HTML and man docs
5 %bcond_without  tests           # don't perform make check
6
7 Summary:        Font configuration and customization tools
8 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów
9 Summary(pt_BR.UTF-8):   Ferramentas para configuração e customização do acesso a fontes
10 Name:           fontconfig
11 Version:        2.13.1
12 Release:        2
13 Epoch:          1
14 License:        MIT
15 Group:          Libraries
16 Source0:        https://www.freedesktop.org/software/fontconfig/release/%{name}-%{version}.tar.bz2
17 # Source0-md5:  36cdea1058ef13cbbfdabe6cb019dc1c
18 Source1:        %{name}-lcd-filter.conf
19 Patch0:         %{name}-bitstream-cyberbit.patch
20 URL:            http://fontconfig.org/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake >= 1:1.11
23 %if %{with doc}
24 BuildRequires:  docbook-dtd31-sgml
25 BuildRequires:  docbook-dtd41-sgml
26 BuildRequires:  docbook-utils >= 0.6.13-3
27 %endif
28 BuildRequires:  ed
29 BuildRequires:  expat-devel
30 # pkgconfig(freetype) >= 21.0.15
31 BuildRequires:  freetype-devel >= 1:2.8.1
32 BuildRequires:  gettext-tools >= 0.19.8
33 BuildRequires:  gperf
34 %{?with_tests:BuildRequires:    json-c-devel}
35 BuildRequires:  libtool >= 2:2.2
36 BuildRequires:  libuuid-devel
37 BuildRequires:  pkgconfig
38 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Fontconfig is designed to locate fonts within the system and select
43 them according to requirements specified by applications.
44
45 This package contains tools and documentation.
46
47 %description -l pl.UTF-8
48 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
49 systemie i wybierania ich w zależności od potrzeb aplikacji.
50
51 Paket ten zawiera programy narzędziowe i dokumentację.
52
53 %description -l pt_BR.UTF-8
54 Fontconfig é uma biblioteca para configuração e customização do acesso
55 a fontes.
56
57 Este pacote contém as ferramentas e documentação.
58
59 %package libs
60 Summary:        Font configuration and customization library
61 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów
62 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes
63 Group:          Libraries
64 Requires:       freetype >= 1:2.8.1
65 Provides:       XFree86-fontconfig
66 Obsoletes:      XFree86-fontconfig
67 Conflicts:      fontconfig <= 1:2.2.98-1
68
69 %description libs
70 Fontconfig is designed to locate fonts within the system and select
71 them according to requirements specified by applications.
72
73 %description libs -l pl.UTF-8
74 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
75 systemie i wybierania ich w zależności od potrzeb aplikacji.
76
77 %description libs -l pt_BR.UTF-8
78 Fontconfig é uma biblioteca para configuração e customização do acesso
79 a fontes.
80
81 %package devel
82 Summary:        Font configuration and customization library - development files
83 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów - pliki dla programistów
84 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
85 Group:          Development/Libraries
86 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
87 Requires:       expat-devel
88 Requires:       freetype-devel >= 1:2.8.1
89 Requires:       libuuid-devel
90 Provides:       XFree86-fontconfig-devel
91 Obsoletes:      XFree86-fontconfig-devel
92
93 %description devel
94 Fontconfig is designed to locate fonts within the system and select
95 them according to requirements specified by applications.
96
97 This package contains the header files needed to develop programs that
98 use these fontconfig.
99
100 %description devel -l pl.UTF-8
101 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
102 systemie i wybierania ich w zależności od potrzeb aplikacji.
103
104 Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
105 programów korzystających z biblioteki fontconfig.
106
107 %description devel -l pt_BR.UTF-8
108 Fontconfig é uma biblioteca para configuração e customização do acesso
109 a fontes.
110
111 Este pacote contém arquivos de desenvolvimento necessários à criação
112 de extensões baseadas na biblioteca fontconfig.
113
114 %package static
115 Summary:        Static font configuration and customization library
116 Summary(pl.UTF-8):      Statyczna biblioteka do konfigurowania fontów
117 Summary(pt_BR.UTF-8):   Biblioteca estática para configuração e customização do acesso a fontes
118 Group:          Development/Libraries
119 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
120 Provides:       XFree86-fontconfig-static
121 Obsoletes:      XFree86-fontconfig-static
122
123 %description static
124 This package contains static version of fontconfig library.
125
126 %description static -l pl.UTF-8
127 Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
128
129 %description static -l pt_BR.UTF-8
130 Este pacote contém a biblioteca estática do fontconfig
131
132 %prep
133 %setup -q
134 %patch0 -p1
135
136 %build
137 %{__gettextize}
138 %{__libtoolize}
139 %{__aclocal} -I m4
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143
144 # don't rebuild docs by default, use prebuild ones
145 export HASDOCBOOK=no
146
147 %configure \
148         --enable-docs%{!?with_doc:=no} \
149         --disable-silent-rules \
150         --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static
151 %{__make}
152
153 %{?with_tests:%{__make} OSTYPE=linux check || (cat test/test-suite.log && /bin/false)}
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT \
161         htmldoc_DATA= \
162         doc_DATA=
163
164 install %{SOURCE1} \
165         $RPM_BUILD_ROOT%{_datadir}/%{name}/conf.avail/10-lcd-filter.conf
166
167 ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.avail
168
169 cp -pf conf.d/README README.confd
170
171 %find_lang %{name}
172 %find_lang %{name}-conf -a %{name}.lang
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %pretrans
178 # this needs to be a symlink
179 if [ -d %{_sysconfdir}/fonts/conf.avail ] && [ ! -L %{_sysconfdir}/fonts/conf.avail ]; then
180         mv -f %{_sysconfdir}/fonts/conf.avail{,.rpmsave}
181         install -d %{_datadir}/%{name}/conf.avail
182         ln -s %{_datadir}/%{name}/conf.avail %{_sysconfdir}/fonts/conf.avail
183         mv -f %{_sysconfdir}/fonts/conf.avail.rpmsave/*.conf %{_sysconfdir}/fonts/conf.avail/
184         rmdir %{_sysconfdir}/fonts/conf.avail.rpmsave 2>/dev/null || :
185 fi
186
187 %post
188 umask 022
189 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
190
191 %post   libs -p /sbin/ldconfig
192 %postun libs -p /sbin/ldconfig
193
194 %files -f %{name}.lang
195 %defattr(644,root,root,755)
196 %doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
197 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
198 %{_sysconfdir}/fonts/conf.avail
199 %{_sysconfdir}/fonts/conf.d/README
200 %config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
201 %attr(755,root,root) %{_bindir}/fc-cache
202 %attr(755,root,root) %{_bindir}/fc-cat
203 %attr(755,root,root) %{_bindir}/fc-conflist
204 %attr(755,root,root) %{_bindir}/fc-list
205 %attr(755,root,root) %{_bindir}/fc-match
206 %attr(755,root,root) %{_bindir}/fc-query
207 %attr(755,root,root) %{_bindir}/fc-pattern
208 %attr(755,root,root) %{_bindir}/fc-scan
209 %attr(755,root,root) %{_bindir}/fc-validate
210 %dir %{_datadir}/xml/%{name}
211 %{_datadir}/xml/%{name}/fonts.dtd
212 %{_datadir}/%{name}/conf.avail/*.conf
213 %if %{with doc}
214 %{_mandir}/man1/fc-*.1*
215 %{_mandir}/man5/fonts-conf.5*
216 %endif
217 %dir /var/cache/fontconfig
218
219 %files libs
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libfontconfig.so.*.*.*
222 %attr(755,root,root) %ghost %{_libdir}/libfontconfig.so.1
223
224 %files devel
225 %defattr(644,root,root,755)
226 %doc doc/fontconfig-devel/*.html
227 %attr(755,root,root) %{_libdir}/libfontconfig.so
228 %{_libdir}/libfontconfig.la
229 %{_includedir}/fontconfig
230 %{_pkgconfigdir}/fontconfig.pc
231 %{_datadir}/gettext/its/fontconfig.its
232 %{_datadir}/gettext/its/fontconfig.loc
233 %if %{with doc}
234 %{_mandir}/man3/Fc*.3*
235 %endif
236
237 %if %{with static_libs}
238 %files static
239 %defattr(644,root,root,755)
240 %{_libdir}/libfontconfig.a
241 %endif
This page took 0.058062 seconds and 4 git commands to generate.