]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
- ignore error from fc-cache in %post
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_with     bytecode        # use bytecode hinting instead of autohinting by default
4 #
5 Summary:        Font configuration and customization tools
6 Summary(pl):    Narzêdzia do konfigurowania fontów
7 Summary(pt_BR): Ferramentas para configuração e customização do acesso a fontes
8 Name:           fontconfig
9 Version:        2.3.95
10 Release:        1
11 Epoch:          1
12 License:        MIT
13 Group:          Libraries
14 Source0:        http://fontconfig.org/release/%{name}-%{version}.tar.gz
15 # Source0-md5:  6860be35882f6d34636d52345efd5944
16 Patch0:         %{name}-blacklist.patch
17 Patch1:         %{name}-autohint.patch
18 URL:            http://fontconfig.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  docbook-utils >= 0.6.13-3
22 BuildRequires:  docbook-dtd41-sgml
23 BuildRequires:  ed
24 BuildRequires:  expat-devel
25 BuildRequires:  freetype-devel >= 2.1.5
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
29 Requires:       freetype >= 2.1.5
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Fontconfig is designed to locate fonts within the system and select
34 them according to requirements specified by applications.
35
36 This package contains tools and documentation.
37
38 %description -l pl
39 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
40 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
41
42 Paket ten zawiera programy narzêdziowe i dokumentacjê.
43
44 %description -l pt_BR
45 Fontconfig é uma biblioteca para configuração e customização do acesso
46 a fontes.
47
48 Este pacote contém as ferramentas e documentação.
49
50 %package libs
51 Summary:        Font configuration and customization library
52 Summary(pl):    Biblioteka do konfigurowania fontów
53 Summary(pt_BR): Biblioteca para configuração e customização do acesso a fontes
54 Group:          Development/Libraries
55 Requires:       freetype >= 2.1.5
56 Provides:       XFree86-fontconfig
57 Conflicts:      fontconfig <= 1:2.2.98-1
58 Obsoletes:      XFree86-fontconfig
59
60 %description libs
61 Fontconfig is designed to locate fonts within the system and select
62 them according to requirements specified by applications.
63
64 %description libs -l pl
65 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
66 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
67
68 %description libs -l pt_BR
69 Fontconfig é uma biblioteca para configuração e customização do acesso
70 a fontes.
71
72 %package devel
73 Summary:        Font configuration and customization library - development files
74 Summary(pl):    Biblioteka do konfigurowania fontów - pliki dla programistów
75 Summary(pt_BR): Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
76 Group:          Development/Libraries
77 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
78 Requires:       expat-devel
79 Requires:       freetype-devel >= 2.1.5
80 Provides:       XFree86-fontconfig-devel
81 Obsoletes:      XFree86-fontconfig-devel
82
83 %description devel
84 Fontconfig is designed to locate fonts within the system and select
85 them according to requirements specified by applications.
86
87 This package contains the header files needed to develop programs that
88 use these fontconfig.
89
90 %description devel -l pl
91 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
92 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
93
94 Ten pakiet zawiera pliki nag³ówkowe potrzebne do kompilowania
95 programów korzystaj±cych z biblioteki fontconfig.
96
97 %description devel -l pt_BR
98 Fontconfig é uma biblioteca para configuração e customização do acesso
99 a fontes.
100
101 Este pacote contém arquivos de desenvolvimento necessários à criação
102 de extensões baseadas na biblioteca fontconfig.
103
104 %package static
105 Summary:        Static font configuration and customization library
106 Summary(pl):    Statyczna biblioteka do konfigurowania fontów
107 Summary(pt_BR): Biblioteca estática para configuração e customização do acesso a fontes
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
110 Provides:       XFree86-fontconfig-static
111 Obsoletes:      XFree86-fontconfig-static
112
113 %description static
114 This package contains static version of fontconfig library.
115
116 %description static -l pl
117 Ten pakiet zawiera statyczn± wersjê biblioteki fontconfig.
118
119 %description static -l pt_BR
120 Este pacote contém a biblioteca estática do fontconfig
121
122 %prep
123 %setup -q
124 %patch0 -p1
125 %if %{with bytecode}
126 %patch1 -p1
127 %endif
128
129 %build
130 %{__libtoolize}
131 %{__aclocal}
132 %{__autoconf}
133 %{__autoheader}
134 %{__automake}
135 %configure \
136         --disable-docs
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 install doc/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
147 install doc/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
148
149 cp -f conf.d/README README.confd
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 umask 022
156 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
157
158 %post   libs -p /sbin/ldconfig
159 %postun libs -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS COPYING ChangeLog README README.confd
164 %attr(755,root,root) %{_bindir}/fc-*
165 %{_mandir}/man1/*.1*
166 %{_mandir}/man5/*.5*
167 /var/cache/fontconfig
168
169 %files libs
170 %defattr(644,root,root,755)
171 %dir %{_sysconfdir}/fonts
172 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
173 %{_sysconfdir}/fonts/fonts.dtd
174 %dir %{_sysconfdir}/fonts/conf.d
175 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
176 %attr(755,root,root) %{_libdir}/lib*.so.*.*
177
178 %files devel
179 %defattr(644,root,root,755)
180 %doc doc/fontconfig-devel/*.html
181 %attr(755,root,root) %{_libdir}/lib*.so
182 %{_libdir}/lib*.la
183 %{_includedir}/fontconfig
184 %{_pkgconfigdir}/fontconfig.pc
185 %{_mandir}/man3/*.3*
186
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/lib*.a
This page took 0.601105 seconds and 4 git commands to generate.