]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
- fixed pt_BR stuff
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_with     bytecode        # use bytecode hinting instead of autohinting by default
4 #
5 Summary:        Font configuration and customization tools
6 Summary(pl):    Narzêdzia do konfigurowania fontów
7 Summary(pt_BR): Ferramentas para configuração e customização do acesso a fontes
8 Name:           fontconfig
9 Version:        2.3.1
10 Release:        1
11 Epoch:          1
12 License:        MIT
13 Group:          Libraries
14 Source0:        http://fontconfig.org/release/%{name}-%{version}.tar.gz
15 # Source0-md5:  d5e42a27ad2f22bc5ec45f15533fc5d1
16 Patch0:         %{name}-blacklist.patch
17 Patch1:         %{name}-autohint.patch
18 Patch2:         %{name}-autohint2.patch
19 URL:            http://fontconfig.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  docbook-utils >= 0.6.13-3
23 BuildRequires:  docbook-dtd41-sgml
24 BuildRequires:  ed
25 BuildRequires:  expat-devel
26 BuildRequires:  freetype-devel >= 2.1.5
27 BuildRequires:  libtool
28 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
29 Requires:       freetype >= 2.1.5
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Fontconfig is designed to locate fonts within the system and select
34 them according to requirements specified by applications.
35
36 This package contains tools and documentation.
37
38 %description -l pl
39 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
40 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
41
42 Paket ten zawiera programy narzêdziowe i dokumentacjê.
43
44 %description -l pt_BR
45 Fontconfig é uma biblioteca para configuração e customização do acesso
46 a fontes.
47
48 Este pacote contém as ferramentas e documentação.
49
50 %package libs
51 Summary:        Font configuration and customization library
52 Summary(pl):    Biblioteka do konfigurowania fontów
53 Summary(pt_BR): Biblioteca para configuração e customização do acesso a fontes
54 Group:          Development/Libraries
55 Requires:       freetype >= 2.1.5
56 Provides:       XFree86-fontconfig
57 Conflicts:      fontconfig <= 1:2.2.98-1
58 Obsoletes:      XFree86-fontconfig
59
60 %description libs
61 Fontconfig is designed to locate fonts within the system and select
62 them according to requirements specified by applications.
63
64 %description libs -l pl
65 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
66 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
67
68 %description libs -l pt_BR
69 Fontconfig é uma biblioteca para configuração e customização do acesso
70 a fontes.
71
72 %package devel
73 Summary:        Font configuration and customization library - development files
74 Summary(pl):    Biblioteka do konfigurowania fontów - pliki dla programistów
75 Summary(pt_BR): Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
76 Group:          Development/Libraries
77 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
78 Requires:       expat-devel
79 Requires:       freetype-devel >= 2.1.5
80 Provides:       XFree86-fontconfig-devel
81 Obsoletes:      XFree86-fontconfig-devel
82
83 %description devel
84 Fontconfig is designed to locate fonts within the system and select
85 them according to requirements specified by applications.
86
87 This package contains the header files needed to develop programs that
88 use these fontconfig.
89
90 %description devel -l pl
91 Fontconfig jest bibliotek± przeznaczon± do lokalizowania fontów w
92 systemie i wybierania ich w zale¿no¶ci od potrzeb aplikacji.
93
94 Ten pakiet zawiera pliki nag³ówkowe potrzebne do kompilowania
95 programów korzystaj±cych z biblioteki fontconfig.
96
97 %description devel -l pt_BR
98 Fontconfig é uma biblioteca para configuração e customização do acesso
99 a fontes.
100
101 Este pacote contém arquivos de desenvolvimento necessários à criação
102 de extensões baseadas na biblioteca fontconfig.
103
104 %package static
105 Summary:        Static font configuration and customization library
106 Summary(pl):    Statyczna biblioteka do konfigurowania fontów
107 Summary(pt_BR): Biblioteca estática para configuração e customização do acesso a fontes
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
110 Provides:       XFree86-fontconfig-static
111 Obsoletes:      XFree86-fontconfig-static
112
113 %description static
114 This package contains static version of fontconfig library.
115
116 %description static -l pl
117 Ten pakiet zawiera statyczn± wersjê biblioteki fontconfig.
118
119 %description static -l pt_BR
120 Este pacote contém a biblioteca estática do fontconfig
121
122 %prep
123 %setup -q
124 %patch0 -p1
125 %if %{with bytecode}
126 %patch1 -p1
127 %else
128 %patch2 -p1
129 %endif
130
131 %build
132 %{__libtoolize}
133 %{__aclocal}
134 %{__autoconf}
135 %{__autoheader}
136 %{__automake}
137 %configure \
138         --disable-docs
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT%{_mandir}/man{1,3,5}
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 install doc/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
149 install doc/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
150
151 cp -f conf.d/README README.confd
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post
157 umask 022
158 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null
159
160 %post   libs -p /sbin/ldconfig
161 %postun libs -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS COPYING ChangeLog README README.confd
166 %attr(755,root,root) %{_bindir}/fc-*
167 %{_mandir}/man1/*.1*
168 %{_mandir}/man5/*.5*
169
170 %files libs
171 %defattr(644,root,root,755)
172 %dir %{_sysconfdir}/fonts
173 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
174 %{_sysconfdir}/fonts/fonts.dtd
175 %dir %{_sysconfdir}/fonts/conf.d
176 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
177 %attr(755,root,root) %{_libdir}/lib*.so.*.*
178
179 %files devel
180 %defattr(644,root,root,755)
181 %doc doc/fontconfig-devel/*.html
182 %attr(755,root,root) %{_libdir}/lib*.so
183 %{_libdir}/lib*.la
184 %{_includedir}/fontconfig
185 %{_pkgconfigdir}/fontconfig.pc
186 %{_mandir}/man3/*.3*
187
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/lib*.a
This page took 0.104232 seconds and 3 git commands to generate.